]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- BR QtXmlPatterns-devel
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # -- Building engines: gst
4 # -- Skipping engines: vlc xine qt-phonon
5 #    The following engines are NOT supported by clementine developers:
6 #     vlc xine qt-phonon
7 # - apply patches to libprojectM.spec and use
8 # - make engines pluggable not statically linked, then could enable the bconds
9 #
10 # Conditional build:
11 %bcond_with             engine_xine             # without xine engine
12 %bcond_with             engine_vlc              # without vlc engine
13 %bcond_with             engine_qt_phonon        # without qt-phonon engine
14 %bcond_without  engine_gstreamer        # without gstreamer engine
15 %bcond_without  static_sqlite   # with static sqlite3
16 %bcond_with             static_projectm # with static projectM
17
18 %define         qtver   4.5
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.6
23 Release:        0.1
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  7b7ee4c16f648a15eb2cff9ed2163e0e
29 Patch0:         desktop-install.patch
30 Patch1:         unbundle-po.patch
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
42 BuildRequires:  boost-devel
43 BuildRequires:  cmake >= 2.6
44 #BuildRequires: desktop-file-utils
45 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
46 BuildRequires:  gettext-devel
47 %{?with_static_projectm:BuildRequires:  glew-devel}
48 BuildRequires:  glib2-devel
49 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
50 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
51 BuildRequires:  gtest-devel
52 BuildRequires:  libgpod-devel >= 0.7.92
53 BuildRequires:  libimobiledevice-devel
54 BuildRequires:  liblastfm-devel
55 BuildRequires:  libmtp-devel
56 BuildRequires:  libnotify-devel
57 BuildRequires:  libplist-devel
58 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
59 BuildRequires:  libqxt-devel
60 #BuildRequires: libqxt-devel >= 0.6.0-0.2
61 BuildRequires:  libxml2-devel
62 BuildRequires:  notification-daemon
63 BuildRequires:  phonon
64 %{?with_engine_phonon:BuildRequires:    phonon-devel}
65 BuildRequires:  pkgconfig
66 BuildRequires:  qt4-build >= %{qtver}
67 BuildRequires:  qt4-linguist
68 BuildRequires:  qt4-qmake
69 BuildRequires:  rpmbuild(find_lang) = 1.33
70 BuildRequires:  rpmbuild(macros) >= 1.577
71 BuildRequires:  sed >= 4.0
72 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
73 BuildRequires:  taglib-devel >= 1.6
74 BuildRequires:  usbmuxd-devel
75 %{?with_engine_vlc:BuildRequires:       vlc-devel}
76 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
77 Requires(post,postun):  desktop-file-utils
78 Requires:       QtSingleApplication >= 2.6-4
79 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
80 # while we do not link (yet), we use datafiles
81 Requires:       libprojectM
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 # see libprojectM.spec for explanation
85 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
86
87 %description
88 Clementine is a modern music player and library organiser. It is
89 largely a port of Amarok 1.4, with some features rewritten to take
90 advantage of Qt4.
91
92 %description -l hu.UTF-8
93 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
94 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
95 a Qt4 előnyeit.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101
102 # We already don't use these but just to make sure
103 rm -rf 3rdparty/gmock
104 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
105 rm -rf 3rdparty/qtsingleapplication
106 rm -rf 3rdparty/qxt
107 rm -rf 3rdparty/qtiocompressor
108 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
109
110 # Don't build tests. They require gmock
111 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
112
113 %build
114 install -d build
115 install -d build/src/translations
116 cd build
117 %cmake \
118         -DBUNDLE_PROJECTM_PRESETS=OFF \
119         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
120         -DUSE_SYSTEM_QXT=ON \
121         -DUSE_SYSTEM_PROJECTM=ON \
122         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
123         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
124         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
125         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
126         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
127         ..
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 %{__make} -C build install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
136
137 %find_lang %{name} --with-qm
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 %update_desktop_database_post
144
145 %postun
146 %update_desktop_database_postun
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc Changelog TODO
151 %attr(755,root,root) %{_bindir}/clementine
152 %{_desktopdir}/clementine.desktop
153 %{_pixmapsdir}/clementine.png
This page took 0.068851 seconds and 4 git commands to generate.