]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- R qtsql-sqlite3
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - update patch0
3 # - add missing BRs
4 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed." 
5 #
6 # Conditional build:
7 %bcond_without  engine_xine             # without xine engine
8 %bcond_without  engine_vlc              # without vlc engine
9 %bcond_without  engine_qt_phonon        # without qt-phonon engine
10 %bcond_without  engine_gstreamer        # without gstreamer engine
11 #
12 Summary:        A music player and library organiser
13 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
14 Name:           clementine
15 Version:        0.3
16 Release:        0.1
17 License:        GPL v3 and GPL v2+
18 Group:          Applications/Multimedia
19 URL:            http://code.google.com/p/clementine-player
20 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
21 # Source0-md5:  3aff98e41d9bf96717ecf97c780ef086
22 Patch0:         %{name}-dont-bundle-external-lib.patch
23 Patch1:         %{name}-static.patch
24 Patch2:         desktop-install.patch
25 BuildRequires:  QtCore-devel
26 BuildRequires:  QtDBus-devel
27 BuildRequires:  QtGui-devel
28 BuildRequires:  QtNetwork-devel
29 BuildRequires:  QtOpenGL-devel
30 BuildRequires:  QtSingleApplication-devel
31 BuildRequires:  QtSql-devel
32 BuildRequires:  QtTest-devel
33 BuildRequires:  boost-devel
34 BuildRequires:  cmake >= 2.6
35 BuildRequires:  desktop-file-utils
36 BuildRequires:  gettext-devel
37 BuildRequires:  gstreamer-devel
38 BuildRequires:  gtest-devel
39 BuildRequires:  liblastfm-devel
40 BuildRequires:  libnotify-devel
41 BuildRequires:  libqxt-devel
42 BuildRequires:  notification-daemon
43 BuildRequires:  phonon-devel
44 BuildRequires:  pkgconfig
45 BuildRequires:  qt4-build
46 BuildRequires:  qt4-linguist
47 BuildRequires:  qt4-qmake
48 BuildRequires:  rpmbuild(macros) >= 1.198
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  sqlite-devel
51 BuildRequires:  sqlite3-devel
52 BuildRequires:  taglib-devel
53 BuildRequires:  vlc-devel
54 BuildRequires:  xine-lib-devel
55 Requires(post,postun):  desktop-file-utils
56 Requires:       QtSql-sqlite3
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Clementine is a modern music player and library organiser. It is
61 largely a port of Amarok 1.4, with some features rewritten to take
62 advantage of Qt4.
63
64 %description -l hu.UTF-8
65 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
66 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
67 a Qt4 előnyeit.
68
69 %prep
70 %setup -q
71 #%patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74
75 # We already don't use these but just to make sure
76 #rm -fr 3rdparty
77
78 # Don't build tests. They require gmock
79 sed -i -e '/tests/d' CMakeLists.txt
80
81 %build
82 install -d build
83 cd build
84 %cmake \
85         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
86         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
87         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
88         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
89         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
90         ..
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} -C build install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 %update_desktop_database_post
103
104 %postun
105 %update_desktop_database_postun
106
107 %files
108 %defattr(644,root,root,755)
109 %doc Changelog TODO
110 %attr(755,root,root) %{_bindir}/clementine
111 %{_desktopdir}/clementine.desktop
112 %{_pixmapsdir}/clementine.png
This page took 0.046117 seconds and 4 git commands to generate.