]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- up to 0.7
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # -- Building engines: gst
4 # -- Skipping engines: vlc xine qt-phonon
5 #    The following engines are NOT supported by clementine developers:
6 #     vlc xine qt-phonon
7 # - apply patches to libprojectM.spec and use
8 # - make engines pluggable not statically linked, then could enable the bconds
9 #
10 # Conditional build:
11 %bcond_with             engine_xine             # without xine engine
12 %bcond_with             engine_vlc              # without vlc engine
13 %bcond_with             engine_qt_phonon        # without qt-phonon engine
14 %bcond_without  engine_gstreamer        # without gstreamer engine
15 %bcond_without  static_sqlite   # with static sqlite3
16 %bcond_with             static_projectm # with static projectM
17
18 %define     qtver       %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.7
23 Release:        1
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  d417d1e4b1d1c295ab93c574e073da28
29 Patch0:         desktop-install.patch
30 Patch1:         unbundle-po.patch
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  boost-devel
42 BuildRequires:  cmake >= 2.6
43 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
44 BuildRequires:  gettext-devel
45 %{?with_static_projectm:BuildRequires:  glew-devel}
46 BuildRequires:  glib2-devel
47 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
48 BuildRequires:  gtest-devel
49 BuildRequires:  libgpod-devel >= 0.7.92
50 BuildRequires:  libimobiledevice-devel
51 BuildRequires:  libindicate-qt-devel
52 BuildRequires:  liblastfm-devel
53 BuildRequires:  libmtp-devel
54 BuildRequires:  libplist-devel
55 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
56 BuildRequires:  libqxt-devel
57 BuildRequires:  libxml2-devel
58 %{?with_engine_phonon:BuildRequires:    phonon-devel}
59 BuildRequires:  pkgconfig
60 BuildRequires:  pkgconfig
61 BuildRequires:  qt4-build >= %{qtver}
62 BuildRequires:  qt4-linguist
63 BuildRequires:  qt4-qmake
64 BuildRequires:  rpmbuild(find_lang) >= 1.33
65 BuildRequires:  rpmbuild(macros) >= 1.596
66 BuildRequires:  sed >= 4.0
67 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
68 BuildRequires:  taglib-devel >= 1.6
69 BuildRequires:  usbmuxd-devel
70 %{?with_engine_vlc:BuildRequires:       vlc-devel}
71 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
72 Requires(post,postun):  desktop-file-utils
73 Requires(post,postun):  gtk-update-icon-cache
74 Requires(post,postun):  hicolor-icon-theme
75 Requires:       QtSingleApplication >= 2.6-4
76 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
77 Requires:       gstreamer-audio-effects-base
78 # while we do not link (yet), we use datafiles
79 Requires:       libprojectM
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 # see libprojectM.spec for explanation
83 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
84
85 %description
86 Clementine is a modern music player and library organiser. It is
87 largely a port of Amarok 1.4, with some features rewritten to take
88 advantage of Qt4.
89
90 %description -l hu.UTF-8
91 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
92 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
93 a Qt4 előnyeit.
94
95 %prep
96 %setup -q -n %{name}-%{version}
97 %patch0 -p1
98 %patch1 -p1
99
100 # We already don't use these but just to make sure
101 rm -rf 3rdparty/gmock
102 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
103 rm -rf 3rdparty/qtsingleapplication
104 rm -rf 3rdparty/qxt
105 rm -rf 3rdparty/qtiocompressor
106 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
107
108 # Don't build tests. They require gmock
109 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
110
111 %build
112 install -d build
113 install -d build/src/translations
114 cd build
115 %cmake \
116         -DBUNDLE_PROJECTM_PRESETS=OFF \
117         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
118         -DUSE_SYSTEM_QXT=ON \
119         -DUSE_SYSTEM_PROJECTM=ON \
120         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
121         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
122         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
123         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
124         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
125         ..
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 %{__make} -C build install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
134
135 %find_lang %{name} --with-qm
136
137 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
138 cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
139 cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %update_desktop_database_post
146 %update_icon_cache hicolor
147
148 %postun
149 %update_desktop_database_postun
150 %update_icon_cache hicolor
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc Changelog TODO
155 %attr(755,root,root) %{_bindir}/clementine
156 %{_desktopdir}/clementine.desktop
157 %{_pixmapsdir}/clementine.png
158 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
159 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.137225 seconds and 4 git commands to generate.