]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- vlc, xine and phonon engines were removed; now there is only gstreamer
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 #
5 # Conditional build:
6 %bcond_without  static_sqlite   # with static sqlite3
7 %bcond_with             static_projectm # with static projectM
8
9 %define     qtver       %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
10 Summary:        A music player and library organiser
11 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
12 Name:           clementine
13 Version:        0.7
14 Release:        1
15 License:        GPL v3 and GPL v2+
16 Group:          Applications/Multimedia
17 URL:            http://www.clementine-player.org/
18 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
19 # Source0-md5:  d417d1e4b1d1c295ab93c574e073da28
20 Patch0:         desktop-install.patch
21 Patch1:         unbundle-po.patch
22 BuildRequires:  QtCore-devel >= %{qtver}
23 BuildRequires:  QtDBus-devel >= %{qtver}
24 BuildRequires:  QtGui-devel >= %{qtver}
25 BuildRequires:  QtIOCompressor-devel
26 BuildRequires:  QtNetwork-devel >= %{qtver}
27 BuildRequires:  QtOpenGL-devel >= %{qtver}
28 BuildRequires:  QtSingleApplication-devel >= 2.6-4
29 BuildRequires:  QtSql-devel >= %{qtver}
30 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
31 BuildRequires:  QtXml-devel >= %{qtver}
32 BuildRequires:  boost-devel
33 BuildRequires:  cmake >= 2.6
34 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
35 BuildRequires:  gettext-devel
36 %{?with_static_projectm:BuildRequires:  glew-devel}
37 BuildRequires:  glib2-devel
38 BuildRequires:  gstreamer-devel >= 0.10
39 BuildRequires:  gtest-devel
40 BuildRequires:  libgpod-devel >= 0.7.92
41 BuildRequires:  libimobiledevice-devel
42 BuildRequires:  libindicate-qt-devel
43 BuildRequires:  liblastfm-devel
44 BuildRequires:  libmtp-devel
45 BuildRequires:  libplist-devel
46 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
47 BuildRequires:  libqxt-devel
48 BuildRequires:  libxml2-devel
49 BuildRequires:  pkgconfig
50 BuildRequires:  pkgconfig
51 BuildRequires:  qt4-build >= %{qtver}
52 BuildRequires:  qt4-linguist
53 BuildRequires:  qt4-qmake
54 BuildRequires:  rpmbuild(find_lang) >= 1.33
55 BuildRequires:  rpmbuild(macros) >= 1.596
56 BuildRequires:  sed >= 4.0
57 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
58 BuildRequires:  taglib-devel >= 1.6
59 BuildRequires:  usbmuxd-devel
60 Requires(post,postun):  desktop-file-utils
61 Requires(post,postun):  gtk-update-icon-cache
62 Requires(post,postun):  hicolor-icon-theme
63 Requires:       QtSingleApplication >= 2.6-4
64 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
65 Requires:       gstreamer-audio-effects-base
66 # while we do not link (yet), we use datafiles
67 Requires:       libprojectM
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # see libprojectM.spec for explanation
71 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
72
73 %description
74 Clementine is a modern music player and library organiser. It is
75 largely a port of Amarok 1.4, with some features rewritten to take
76 advantage of Qt4.
77
78 %description -l hu.UTF-8
79 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
80 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
81 a Qt4 előnyeit.
82
83 %prep
84 %setup -q -n %{name}-%{version}
85 %patch0 -p1
86 %patch1 -p1
87
88 # We already don't use these but just to make sure
89 rm -rf 3rdparty/gmock
90 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
91 rm -rf 3rdparty/qtsingleapplication
92 rm -rf 3rdparty/qxt
93 rm -rf 3rdparty/qtiocompressor
94 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
95
96 # Don't build tests. They require gmock
97 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
98
99 %build
100 install -d build
101 install -d build/src/translations
102 cd build
103 %cmake \
104         -DBUNDLE_PROJECTM_PRESETS=OFF \
105         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
106         -DUSE_SYSTEM_QXT=ON \
107         -DUSE_SYSTEM_PROJECTM=ON \
108         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
109         ..
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} -C build install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
118
119 %find_lang %{name} --with-qm
120
121 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
122 cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
123 cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %update_desktop_database_post
130 %update_icon_cache hicolor
131
132 %postun
133 %update_desktop_database_postun
134 %update_icon_cache hicolor
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc Changelog TODO
139 %attr(755,root,root) %{_bindir}/clementine
140 %{_desktopdir}/clementine.desktop
141 %{_pixmapsdir}/clementine.png
142 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
143 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.036942 seconds and 4 git commands to generate.