]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- up to 0.6
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # -- Building engines: gst
4 # -- Skipping engines: vlc xine qt-phonon
5 #    The following engines are NOT supported by clementine developers:
6 #     vlc xine qt-phonon
7 # - apply patches to libprojectM.spec and use
8 # - make engines pluggable not statically linked, then could enable the bconds
9 #
10 # Conditional build:
11 %bcond_with             engine_xine             # without xine engine
12 %bcond_with             engine_vlc              # without vlc engine
13 %bcond_with             engine_qt_phonon        # without qt-phonon engine
14 %bcond_without  engine_gstreamer        # without gstreamer engine
15 %bcond_without  static_sqlite   # with static sqlite3
16 %bcond_with             static_projectm # with static projectM
17
18 %define         qtver   4.5
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.6
23 Release:        0.1
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  7b7ee4c16f648a15eb2cff9ed2163e0e
29 Patch0:         desktop-install.patch
30 Patch1:         unbundle-po.patch
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  boost-devel
42 BuildRequires:  cmake >= 2.6
43 #BuildRequires: desktop-file-utils
44 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
45 BuildRequires:  gettext-devel
46 %{?with_static_projectm:BuildRequires:  glew-devel}
47 BuildRequires:  glib2-devel
48 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
49 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
50 BuildRequires:  gtest-devel
51 BuildRequires:  libgpod-devel >= 0.7.92
52 BuildRequires:  libimobiledevice-devel
53 BuildRequires:  liblastfm-devel
54 BuildRequires:  libmtp-devel
55 BuildRequires:  libnotify-devel
56 BuildRequires:  libplist-devel
57 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
58 BuildRequires:  libqxt-devel
59 #BuildRequires: libqxt-devel >= 0.6.0-0.2
60 BuildRequires:  libxml2-devel
61 BuildRequires:  notification-daemon
62 BuildRequires:  phonon
63 %{?with_engine_phonon:BuildRequires:    phonon-devel}
64 BuildRequires:  pkgconfig
65 BuildRequires:  qt4-build >= %{qtver}
66 BuildRequires:  qt4-linguist
67 BuildRequires:  qt4-qmake
68 BuildRequires:  rpmbuild(find_lang) = 1.33
69 BuildRequires:  rpmbuild(macros) >= 1.577
70 BuildRequires:  sed >= 4.0
71 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
72 BuildRequires:  taglib-devel >= 1.6
73 BuildRequires:  usbmuxd-devel
74 %{?with_engine_vlc:BuildRequires:       vlc-devel}
75 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
76 Requires(post,postun):  desktop-file-utils
77 Requires:       QtSingleApplication >= 2.6-4
78 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
79 # while we do not link (yet), we use datafiles
80 Requires:       libprojectM
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 # see libprojectM.spec for explanation
84 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
85
86 %description
87 Clementine is a modern music player and library organiser. It is
88 largely a port of Amarok 1.4, with some features rewritten to take
89 advantage of Qt4.
90
91 %description -l hu.UTF-8
92 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
93 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
94 a Qt4 előnyeit.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 # We already don't use these but just to make sure
102 rm -rf 3rdparty/gmock
103 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
104 rm -rf 3rdparty/qtsingleapplication
105 rm -rf 3rdparty/qxt
106 rm -rf 3rdparty/qtiocompressor
107 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
108
109 # Don't build tests. They require gmock
110 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
111
112 %build
113 install -d build
114 install -d build/src/translations
115 cd build
116 %cmake \
117         -DBUNDLE_PROJECTM_PRESETS=OFF \
118         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
119         -DUSE_SYSTEM_QXT=ON \
120         -DUSE_SYSTEM_PROJECTM=ON \
121         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
122         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
123         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
124         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
125         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
126         ..
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} -C build install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
135
136 %find_lang %{name} --with-qm
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 %update_desktop_database_post
143
144 %postun
145 %update_desktop_database_postun
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc Changelog TODO
150 %attr(755,root,root) %{_bindir}/clementine
151 %{_desktopdir}/clementine.desktop
152 %{_pixmapsdir}/clementine.png
This page took 1.026266 seconds and 4 git commands to generate.