]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
fix build with libimobiledevice-1.1.5; patch from fedora
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 # - checking for module 'libspotify>=12.1.45' - Spotify support: non-GPL binary helper (missing libspotify)
5 # - checking for module 'libchromaprint'
6 # - Google Drive support (missing Google sparsehash)
7 # - package for kde4 stuff (or nuke them):
8 #        /usr/share/kde4/services/clementine-feed.protocol
9 #        /usr/share/kde4/services/clementine-itms.protocol
10 #        /usr/share/kde4/services/clementine-itpc.protocol
11 #        /usr/share/kde4/services/clementine-zune.protocol
12 #
13 # Conditional build:
14 %bcond_without  static_sqlite   # with static sqlite3
15 %bcond_with     static_projectm # with static projectM
16
17 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
18 Summary:        A music player and library organiser
19 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
20 Name:           clementine
21 Version:        1.1.1
22 Release:        6
23 License:        GPL v3 and GPL v2+
24 Group:          Applications/Multimedia
25 URL:            http://www.clementine-player.org/
26 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
27 # Source0-md5:  28e4afb822388bd337a761db8f86febf
28 Patch0:         desktop-install.patch
29 Patch1:         unbundle-po.patch
30 Patch2:         %{name}-1.1.1-libimobiledevice-fix.patch
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
42 BuildRequires:  boost-devel
43 BuildRequires:  cmake >= 2.6
44 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
45 BuildRequires:  gettext-devel
46 %{?with_static_projectm:BuildRequires:  glew-devel}
47 BuildRequires:  glib2-devel
48 BuildRequires:  gstreamer0.10-devel
49 BuildRequires:  gstreamer0.10-plugins-base-devel
50 BuildRequires:  gtest-devel
51 BuildRequires:  libgpod-devel >= 0.7.92
52 BuildRequires:  libimobiledevice-devel
53 BuildRequires:  libindicate-qt-devel
54 BuildRequires:  liblastfm-devel >= 0.3.3
55 BuildRequires:  libmtp-devel
56 BuildRequires:  libplist-devel
57 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
58 BuildRequires:  libqxt-devel
59 BuildRequires:  libxml2-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  pkgconfig
62 BuildRequires:  protobuf-devel
63 BuildRequires:  qca-devel
64 BuildRequires:  qjson-devel
65 BuildRequires:  qt4-build >= %{qtver}
66 BuildRequires:  qt4-linguist
67 BuildRequires:  qt4-qmake
68 BuildRequires:  rpmbuild(find_lang) >= 1.33
69 BuildRequires:  rpmbuild(macros) >= 1.596
70 BuildRequires:  sed >= 4.0
71 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
72 BuildRequires:  taglib-devel >= 1.6
73 BuildRequires:  usbmuxd-devel
74 Requires(post,postun):  desktop-file-utils
75 Requires(post,postun):  gtk-update-icon-cache
76 Requires(post,postun):  hicolor-icon-theme
77 Requires:       QtSingleApplication >= 2.6-4
78 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
79 Requires:       gstreamer0.10-audio-effects-base
80 Requires:       gstreamer0.10-mad
81 # while we do not link (yet), we use datafiles
82 Requires:       libprojectM
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # see libprojectM.spec for explanation
86 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
87
88 %description
89 Clementine is a modern music player and library organiser. It is
90 largely a port of Amarok 1.4, with some features rewritten to take
91 advantage of Qt4.
92
93 %description -l hu.UTF-8
94 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
95 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
96 a Qt4 előnyeit.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 # We already don't use these but just to make sure
105 rm -rf 3rdparty/gmock
106 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
107 rm -rf 3rdparty/qtsingleapplication
108 rm -rf 3rdparty/qxt
109 rm -rf 3rdparty/qtiocompressor
110 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
111
112 # Don't build tests. They require gmock
113 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
114 # remove -Wall
115 sed -i -e 's/-Wall//' src/CMakeLists.txt
116 # ...and -Werror
117 sed -i -e 's/-Werror//' src/CMakeLists.txt
118
119 %build
120 install -d build
121 install -d build/src/translations
122 cd build
123 # as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
124 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
125 %cmake \
126         -DBUNDLE_PROJECTM_PRESETS=OFF \
127         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
128         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
129         -DUSE_SYSTEM_QXT=ON \
130         -DUSE_SYSTEM_PROJECTM=ON \
131         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
132         ..
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 %{__make} -C build install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
141
142 # not in our glibc?
143 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
144
145 %find_lang %{name} --with-qm
146
147 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
148 cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
149 cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 %update_desktop_database_post
156 %update_icon_cache hicolor
157
158 %postun
159 %update_desktop_database_postun
160 %update_icon_cache hicolor
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 %doc Changelog
165 %attr(755,root,root) %{_bindir}/clementine
166 %attr(755,root,root) %{_bindir}/clementine-tagreader
167 %{_desktopdir}/clementine.desktop
168 %{_pixmapsdir}/clementine.png
169 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
170 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.092833 seconds and 4 git commands to generate.