]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- -static.patch already in sources
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - update patch0
3 # - add missing BRs
4 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed." 
5 #
6 # Conditional build:
7 %bcond_without  engine_xine             # without xine engine
8 %bcond_without  engine_vlc              # without vlc engine
9 %bcond_without  engine_qt_phonon        # without qt-phonon engine
10 %bcond_without  engine_gstreamer        # without gstreamer engine
11 #
12 Summary:        A music player and library organiser
13 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
14 Name:           clementine
15 Version:        0.4
16 Release:        0.1
17 License:        GPL v3 and GPL v2+
18 Group:          Applications/Multimedia
19 URL:            http://code.google.com/p/clementine-player
20 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
21 # Source0-md5:  dbfec89142910a60502674234daf01df
22 Patch0:         %{name}-dont-bundle-external-lib.patch
23 Patch2:         desktop-install.patch
24 BuildRequires:  QtCore-devel
25 BuildRequires:  QtDBus-devel
26 BuildRequires:  QtGui-devel
27 BuildRequires:  QtNetwork-devel
28 BuildRequires:  QtOpenGL-devel
29 BuildRequires:  QtSingleApplication-devel
30 BuildRequires:  QtSql-devel
31 BuildRequires:  QtTest-devel
32 BuildRequires:  boost-devel
33 BuildRequires:  cmake >= 2.6
34 BuildRequires:  desktop-file-utils
35 BuildRequires:  gettext-devel
36 BuildRequires:  gstreamer-devel
37 BuildRequires:  gtest-devel
38 BuildRequires:  liblastfm-devel
39 BuildRequires:  libnotify-devel
40 BuildRequires:  libqxt-devel
41 BuildRequires:  notification-daemon
42 BuildRequires:  phonon-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  qt4-build
45 BuildRequires:  qt4-linguist
46 BuildRequires:  qt4-qmake
47 BuildRequires:  rpmbuild(macros) >= 1.198
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sqlite-devel
50 BuildRequires:  sqlite3-devel
51 BuildRequires:  taglib-devel
52 BuildRequires:  vlc-devel
53 BuildRequires:  xine-lib-devel
54 Requires(post,postun):  desktop-file-utils
55 Requires:       QtSql-sqlite3
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Clementine is a modern music player and library organiser. It is
60 largely a port of Amarok 1.4, with some features rewritten to take
61 advantage of Qt4.
62
63 %description -l hu.UTF-8
64 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
65 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
66 a Qt4 előnyeit.
67
68 %prep
69 %setup -q
70 #%patch0 -p1
71 %patch2 -p1
72
73 # We already don't use these but just to make sure
74 #rm -fr 3rdparty
75
76 # Don't build tests. They require gmock
77 sed -i -e '/tests/d' CMakeLists.txt
78
79 %build
80 install -d build
81 cd build
82 %cmake \
83         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
84         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
85         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
86         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
87         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
88         ..
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 %{__make} -C build install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 %update_desktop_database_post
101
102 %postun
103 %update_desktop_database_postun
104
105 %files
106 %defattr(644,root,root,755)
107 %doc Changelog TODO
108 %attr(755,root,root) %{_bindir}/clementine
109 %{_desktopdir}/clementine.desktop
110 %{_pixmapsdir}/clementine.png
This page took 0.065016 seconds and 4 git commands to generate.