]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- requires "volume" gst element
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # -- Building engines: gst
4 # -- Skipping engines: vlc xine qt-phonon
5 #    The following engines are NOT supported by clementine developers:
6 #     vlc xine qt-phonon
7 # - apply patches to libprojectM.spec and use
8 # - make engines pluggable not statically linked, then could enable the bconds
9 #
10 # Conditional build:
11 %bcond_with             engine_xine             # without xine engine
12 %bcond_with             engine_vlc              # without vlc engine
13 %bcond_with             engine_qt_phonon        # without qt-phonon engine
14 %bcond_without  engine_gstreamer        # without gstreamer engine
15 %bcond_without  static_sqlite   # with static sqlite3
16 %bcond_with             static_projectm # with static projectM
17
18 %define         qtver   4.5
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.6
23 Release:        0.1
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  7b7ee4c16f648a15eb2cff9ed2163e0e
29 Patch0:         desktop-install.patch
30 Patch1:         unbundle-po.patch
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
42 BuildRequires:  boost-devel
43 BuildRequires:  cmake >= 2.6
44 #BuildRequires: desktop-file-utils
45 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
46 BuildRequires:  gettext-devel
47 %{?with_static_projectm:BuildRequires:  glew-devel}
48 BuildRequires:  glib2-devel
49 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
50 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
51 BuildRequires:  gtest-devel
52 BuildRequires:  libgpod-devel >= 0.7.92
53 BuildRequires:  libimobiledevice-devel
54 BuildRequires:  liblastfm-devel
55 BuildRequires:  libmtp-devel
56 BuildRequires:  libnotify-devel
57 BuildRequires:  libplist-devel
58 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
59 BuildRequires:  libqxt-devel
60 #BuildRequires: libqxt-devel >= 0.6.0-0.2
61 BuildRequires:  libxml2-devel
62 BuildRequires:  notification-daemon
63 BuildRequires:  phonon
64 %{?with_engine_phonon:BuildRequires:    phonon-devel}
65 BuildRequires:  pkgconfig
66 BuildRequires:  qt4-build >= %{qtver}
67 BuildRequires:  qt4-linguist
68 BuildRequires:  qt4-qmake
69 BuildRequires:  rpmbuild(find_lang) = 1.33
70 BuildRequires:  rpmbuild(macros) >= 1.577
71 BuildRequires:  sed >= 4.0
72 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
73 BuildRequires:  taglib-devel >= 1.6
74 BuildRequires:  usbmuxd-devel
75 %{?with_engine_vlc:BuildRequires:       vlc-devel}
76 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
77 Requires(post,postun):  desktop-file-utils
78 Requires:       QtSingleApplication >= 2.6-4
79 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
80 Requires:       gstreamer-audio-effects-base
81 # while we do not link (yet), we use datafiles
82 Requires:       libprojectM
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # see libprojectM.spec for explanation
86 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
87
88 %description
89 Clementine is a modern music player and library organiser. It is
90 largely a port of Amarok 1.4, with some features rewritten to take
91 advantage of Qt4.
92
93 %description -l hu.UTF-8
94 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
95 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
96 a Qt4 előnyeit.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102
103 # We already don't use these but just to make sure
104 rm -rf 3rdparty/gmock
105 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
106 rm -rf 3rdparty/qtsingleapplication
107 rm -rf 3rdparty/qxt
108 rm -rf 3rdparty/qtiocompressor
109 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
110
111 # Don't build tests. They require gmock
112 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
113
114 %build
115 install -d build
116 install -d build/src/translations
117 cd build
118 %cmake \
119         -DBUNDLE_PROJECTM_PRESETS=OFF \
120         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
121         -DUSE_SYSTEM_QXT=ON \
122         -DUSE_SYSTEM_PROJECTM=ON \
123         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
124         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
125         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
126         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
127         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
128         ..
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 %{__make} -C build install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
137
138 %find_lang %{name} --with-qm
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %update_desktop_database_post
145
146 %postun
147 %update_desktop_database_postun
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc Changelog TODO
152 %attr(755,root,root) %{_bindir}/clementine
153 %{_desktopdir}/clementine.desktop
154 %{_pixmapsdir}/clementine.png
This page took 0.107919 seconds and 4 git commands to generate.