]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
f95837aafd6462f9f5b51ff0349792635a9b428e
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - add missing BRs
3 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4 # -- Building engines: gst
5 # -- Skipping engines: vlc xine qt-phonon
6 #    The following engines are NOT supported by clementine developers:
7 #     vlc xine qt-phonon
8 # - apply patches to libprojectM.spec and use
9 # - make engines pluggable not statically linked, then could enable the bconds
10 #
11 # Conditional build:
12 %bcond_with             engine_xine             # without xine engine
13 %bcond_with             engine_vlc              # without vlc engine
14 %bcond_with             engine_qt_phonon        # without qt-phonon engine
15 %bcond_without  engine_gstreamer        # without gstreamer engine
16 %bcond_without  static_sqlite   # with static sqlite3
17 %bcond_with             static_projectm # with static projectM
18
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.5.3
23 Release:        1
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  3411a0e31bdab7a6693048e934996f40
29 Patch0:         desktop-install.patch
30 BuildRequires:  QtCore-devel
31 BuildRequires:  QtDBus-devel
32 BuildRequires:  QtGui-devel
33 BuildRequires:  QtIOCompressor-devel
34 BuildRequires:  QtNetwork-devel
35 BuildRequires:  QtOpenGL-devel
36 BuildRequires:  QtSingleApplication-devel >= 2.6-4
37 BuildRequires:  QtSql-devel
38 %{?with_tests:BuildRequires:    QtTest-devel}
39 BuildRequires:  boost-devel
40 BuildRequires:  cmake >= 2.6
41 #BuildRequires: desktop-file-utils
42 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
43 BuildRequires:  gettext-devel
44 %{?with_static_projectm:BuildRequires:  glew-devel}
45 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
46 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
47 BuildRequires:  gtest-devel
48 BuildRequires:  liblastfm-devel
49 BuildRequires:  libnotify-devel
50 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
51 BuildRequires:  libqxt-devel
52 #BuildRequires: libqxt-devel >= 0.6.0-0.2
53 BuildRequires:  notification-daemon
54 %{?with_engine_phonon:BuildRequires:    phonon-devel}
55 BuildRequires:  pkgconfig
56 BuildRequires:  qt4-build
57 BuildRequires:  qt4-linguist
58 BuildRequires:  qt4-qmake
59 BuildRequires:  rpmbuild(macros) >= 1.577
60 BuildRequires:  sed >= 4.0
61 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
62 BuildRequires:  taglib-devel >= 1.6
63 %{?with_engine_vlc:BuildRequires:       vlc-devel}
64 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
65 Requires(post,postun):  desktop-file-utils
66 Requires:       QtSingleApplication >= 2.6-4
67 %{!?with_static_sqlite:Requires:        QtSql-sqlite3}
68 # while we do not link (yet), we use datafiles
69 Requires:       libprojectM
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 # see libprojectM.spec for explanation
73 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
74
75 %description
76 Clementine is a modern music player and library organiser. It is
77 largely a port of Amarok 1.4, with some features rewritten to take
78 advantage of Qt4.
79
80 %description -l hu.UTF-8
81 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
82 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
83 a Qt4 előnyeit.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 # We already don't use these but just to make sure
90 rm -rf 3rdparty/gmock
91 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
92 rm -rf 3rdparty/qtsingleapplication
93 rm -rf 3rdparty/qxt
94 rm -rf 3rdparty/qtiocompressor
95 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
96
97 # Don't build tests. They require gmock
98 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
99
100 %build
101 install -d build
102 cd build
103 %cmake \
104         -DBUNDLE_PROJECTM_PRESETS=OFF \
105         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
106         -DUSE_SYSTEM_QXT=ON \
107         -DUSE_SYSTEM_PROJECTM=ON \
108         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
109         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
110         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
111         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
112         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
113         ..
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 %{__make} -C build install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %update_desktop_database_post
128
129 %postun
130 %update_desktop_database_postun
131
132 %files
133 %defattr(644,root,root,755)
134 %doc Changelog TODO
135 %attr(755,root,root) %{_bindir}/clementine
136 %{_desktopdir}/clementine.desktop
137 %{_pixmapsdir}/clementine.png
This page took 0.047305 seconds and 2 git commands to generate.