]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- disable experimental engines, especially vlc that pulls so many deps
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - add missing BRs
3 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4 # -- Building engines: gst
5 # -- Skipping engines: vlc xine qt-phonon
6 #    The following engines are NOT supported by clementine developers:
7 #     vlc xine qt-phonon
8 # - apply patches to libprojectM.spec and use
9 # - make engines pluggable not statically linked, then could enable the bconds
10 #
11 # Conditional build:
12 %bcond_with             engine_xine             # without xine engine
13 %bcond_with             engine_vlc              # without vlc engine
14 %bcond_with             engine_qt_phonon        # without qt-phonon engine
15 %bcond_without  engine_gstreamer        # without gstreamer engine
16
17 Summary:        A music player and library organiser
18 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
19 Name:           clementine
20 Version:        0.4.2
21 Release:        0.2
22 License:        GPL v3 and GPL v2+
23 Group:          Applications/Multimedia
24 URL:            http://code.google.com/p/clementine-player
25 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
26 # Source0-md5:  c6819b0d2a8324f1d686fb5a3b1d287b
27 Patch0:         %{name}-dont-bundle-external-lib.patch
28 Patch2:         desktop-install.patch
29 BuildRequires:  QtCore-devel
30 BuildRequires:  QtDBus-devel
31 BuildRequires:  QtGui-devel
32 BuildRequires:  QtIOCompressor-devel
33 BuildRequires:  QtNetwork-devel
34 BuildRequires:  QtOpenGL-devel
35 BuildRequires:  QtSingleApplication-devel
36 BuildRequires:  QtSql-devel
37 BuildRequires:  QtTest-devel
38 BuildRequires:  boost-devel
39 BuildRequires:  cmake >= 2.6
40 BuildRequires:  desktop-file-utils
41 BuildRequires:  gettext-devel
42 BuildRequires:  gstreamer-devel
43 BuildRequires:  gstreamer-devel >= 0.10
44 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
45 BuildRequires:  gtest-devel
46 BuildRequires:  liblastfm-devel
47 BuildRequires:  libnotify-devel
48 #BuildRequires: libprojectM-devel
49 BuildRequires:  libqxt-devel
50 #BuildRequires: libqxt-devel >= 0.6.0-0.2
51 BuildRequires:  notification-daemon
52 BuildRequires:  phonon-devel
53 BuildRequires:  pkgconfig
54 BuildRequires:  qt4-build
55 BuildRequires:  qt4-linguist
56 BuildRequires:  qt4-qmake
57 BuildRequires:  rpmbuild(macros) >= 1.198
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  sqlite-devel
60 BuildRequires:  sqlite3-devel
61 BuildRequires:  taglib-devel >= 1.6
62 BuildRequires:  vlc-devel
63 BuildRequires:  xine-lib-devel
64 Requires(post,postun):  desktop-file-utils
65 Requires:       QtSql-sqlite3
66 # while we do not link (yet), we use datafiles
67 Requires:       libprojectM
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # see libprojectM.spec for explanation
71 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
72
73 %description
74 Clementine is a modern music player and library organiser. It is
75 largely a port of Amarok 1.4, with some features rewritten to take
76 advantage of Qt4.
77
78 %description -l hu.UTF-8
79 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
80 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
81 a Qt4 előnyeit.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch2 -p1
87
88 # We already don't use these but just to make sure
89 rm -rf 3rdparty/gmock
90 rm -rf 3rdparty/qsqlite
91 rm -rf 3rdparty/qtsingleapplication
92 rm -rf 3rdparty/qxt
93 rm -rf 3rdparty/qtiocompressor
94
95 # Don't build tests. They require gmock
96 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
97
98 %build
99 install -d build
100 cd build
101 %cmake \
102         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
103         -DBUNDLE_PROJECTM_PRESETS=OFF \
104         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
105         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
106         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
107         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
108         ..
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 %{__make} -C build install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 %update_desktop_database_post
121
122 %postun
123 %update_desktop_database_postun
124
125 %files
126 %defattr(644,root,root,755)
127 %doc Changelog TODO
128 %attr(755,root,root) %{_bindir}/clementine
129 %{_desktopdir}/clementine.desktop
130 %{_pixmapsdir}/clementine.png
This page took 0.04381 seconds and 3 git commands to generate.