]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- release 3
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # -- Building engines: gst
4 # -- Skipping engines: vlc xine qt-phonon
5 #    The following engines are NOT supported by clementine developers:
6 #     vlc xine qt-phonon
7 # - apply patches to libprojectM.spec and use
8 # - make engines pluggable not statically linked, then could enable the bconds
9 #
10 # Conditional build:
11 %bcond_with             engine_xine             # without xine engine
12 %bcond_with             engine_vlc              # without vlc engine
13 %bcond_with             engine_qt_phonon        # without qt-phonon engine
14 %bcond_without  engine_gstreamer        # without gstreamer engine
15 %bcond_without  static_sqlite   # with static sqlite3
16 %bcond_with             static_projectm # with static projectM
17
18 %define         qtver   4.5
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.5.3
23 Release:        3
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  3411a0e31bdab7a6693048e934996f40
29 Patch0:         desktop-install.patch
30 Patch1:         unbundle-po.patch
31 Patch2:         build-languages-dynamic.patch
32 Patch3:         qt-ver.patch
33 BuildRequires:  QtCore-devel >= %{qtver}
34 BuildRequires:  QtDBus-devel >= %{qtver}
35 BuildRequires:  QtGui-devel >= %{qtver}
36 BuildRequires:  QtIOCompressor-devel
37 BuildRequires:  QtNetwork-devel >= %{qtver}
38 BuildRequires:  QtOpenGL-devel >= %{qtver}
39 BuildRequires:  QtSingleApplication-devel >= 2.6-4
40 BuildRequires:  QtSql-devel >= %{qtver}
41 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
42 BuildRequires:  QtXml-devel >= %{qtver}
43 BuildRequires:  boost-devel
44 BuildRequires:  cmake >= 2.6
45 #BuildRequires: desktop-file-utils
46 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
47 BuildRequires:  gettext-devel
48 %{?with_static_projectm:BuildRequires:  glew-devel}
49 BuildRequires:  glib2-devel
50 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
51 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
52 BuildRequires:  gtest-devel
53 BuildRequires:  libgpod-devel >= 0.7.92
54 BuildRequires:  libimobiledevice-devel
55 BuildRequires:  liblastfm-devel
56 BuildRequires:  libmtp-devel
57 BuildRequires:  libnotify-devel
58 BuildRequires:  libplist-devel
59 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
60 BuildRequires:  libqxt-devel
61 #BuildRequires: libqxt-devel >= 0.6.0-0.2
62 BuildRequires:  libxml2-devel
63 BuildRequires:  notification-daemon
64 BuildRequires:  phonon
65 %{?with_engine_phonon:BuildRequires:    phonon-devel}
66 BuildRequires:  pkgconfig
67 BuildRequires:  qt4-build >= %{qtver}
68 BuildRequires:  qt4-linguist
69 BuildRequires:  qt4-qmake
70 BuildRequires:  rpmbuild(find_lang) = 1.33
71 BuildRequires:  rpmbuild(macros) >= 1.577
72 BuildRequires:  sed >= 4.0
73 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
74 BuildRequires:  taglib-devel >= 1.6
75 BuildRequires:  usbmuxd-devel
76 %{?with_engine_vlc:BuildRequires:       vlc-devel}
77 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
78 Requires(post,postun):  desktop-file-utils
79 Requires:       QtSingleApplication >= 2.6-4
80 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
81 # while we do not link (yet), we use datafiles
82 Requires:       libprojectM
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # see libprojectM.spec for explanation
86 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
87
88 %description
89 Clementine is a modern music player and library organiser. It is
90 largely a port of Amarok 1.4, with some features rewritten to take
91 advantage of Qt4.
92
93 %description -l hu.UTF-8
94 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
95 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
96 a Qt4 előnyeit.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104
105 # We already don't use these but just to make sure
106 rm -rf 3rdparty/gmock
107 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
108 rm -rf 3rdparty/qtsingleapplication
109 rm -rf 3rdparty/qxt
110 rm -rf 3rdparty/qtiocompressor
111 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
112
113 # Don't build tests. They require gmock
114 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
115
116 %build
117 install -d build
118 install -d build/src/translations
119 cd build
120 %cmake \
121         -DBUNDLE_PROJECTM_PRESETS=OFF \
122         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
123         -DUSE_SYSTEM_QXT=ON \
124         -DUSE_SYSTEM_PROJECTM=ON \
125         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
126         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
127         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
128         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
129         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
130         ..
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 %{__make} -C build install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
139
140 %find_lang %{name} --with-qm
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 %update_desktop_database_post
147
148 %postun
149 %update_desktop_database_postun
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc Changelog TODO
154 %attr(755,root,root) %{_bindir}/clementine
155 %{_desktopdir}/clementine.desktop
156 %{_pixmapsdir}/clementine.png
This page took 0.035345 seconds and 3 git commands to generate.