]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- enable idevice, mpt support, update deps from cmake rules; rel 2
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - add missing BRs
3 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4 # -- Building engines: gst
5 # -- Skipping engines: vlc xine qt-phonon
6 #    The following engines are NOT supported by clementine developers:
7 #     vlc xine qt-phonon
8 # - apply patches to libprojectM.spec and use
9 # - make engines pluggable not statically linked, then could enable the bconds
10 #11:04:19  bs> glen, let me take a look at it [IN]
11 #11:09:13  bs> glen, look at src/CMakeList.txt, remove lines 634-643  [IN]
12 #11:19:32  bs> glen, aaaa, no no, it will them ignore them while building... so you've got another problem then i thought... [IN]
13 #11:20:29  bs> glen, try too look in src/translations in CMakeList.txt and find out where the translations are installed per defualt, and then change the destination [IN]
14 #
15 # Conditional build:
16 %bcond_with             engine_xine             # without xine engine
17 %bcond_with             engine_vlc              # without vlc engine
18 %bcond_with             engine_qt_phonon        # without qt-phonon engine
19 %bcond_without  engine_gstreamer        # without gstreamer engine
20 %bcond_without  static_sqlite   # with static sqlite3
21 %bcond_with             static_projectm # with static projectM
22
23 Summary:        A music player and library organiser
24 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
25 Name:           clementine
26 Version:        0.5.3
27 Release:        2
28 License:        GPL v3 and GPL v2+
29 Group:          Applications/Multimedia
30 URL:            http://www.clementine-player.org/
31 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
32 # Source0-md5:  3411a0e31bdab7a6693048e934996f40
33 Patch0:         desktop-install.patch
34 BuildRequires:  QtCore-devel
35 BuildRequires:  QtDBus-devel
36 BuildRequires:  QtGui-devel
37 BuildRequires:  QtIOCompressor-devel
38 BuildRequires:  QtNetwork-devel
39 BuildRequires:  QtOpenGL-devel
40 BuildRequires:  QtSingleApplication-devel >= 2.6-4
41 BuildRequires:  QtSql-devel
42 %{?with_tests:BuildRequires:    QtTest-devel}
43 BuildRequires:  QtXml-devel
44 BuildRequires:  boost-devel
45 BuildRequires:  cmake >= 2.6
46 #BuildRequires: desktop-file-utils
47 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
48 BuildRequires:  gettext-devel
49 %{?with_static_projectm:BuildRequires:  glew-devel}
50 BuildRequires:  glib2-devel
51 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
52 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
53 BuildRequires:  gtest-devel
54 BuildRequires:  libgpod-devel >= 0.7.92
55 BuildRequires:  libimobiledevice-devel
56 BuildRequires:  liblastfm-devel
57 BuildRequires:  libmtp-devel
58 BuildRequires:  libnotify-devel
59 BuildRequires:  libplist-devel
60 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
61 BuildRequires:  libqxt-devel
62 #BuildRequires: libqxt-devel >= 0.6.0-0.2
63 BuildRequires:  libxml2-devel
64 BuildRequires:  notification-daemon
65 BuildRequires:  phonon
66 %{?with_engine_phonon:BuildRequires:    phonon-devel}
67 BuildRequires:  pkgconfig
68 BuildRequires:  qt4-build
69 BuildRequires:  qt4-linguist
70 BuildRequires:  qt4-qmake
71 BuildRequires:  rpmbuild(macros) >= 1.577
72 BuildRequires:  sed >= 4.0
73 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
74 BuildRequires:  taglib-devel >= 1.6
75 BuildRequires:  usbmuxd-devel
76 %{?with_engine_vlc:BuildRequires:       vlc-devel}
77 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
78 Requires(post,postun):  desktop-file-utils
79 Requires:       QtSingleApplication >= 2.6-4
80 %{!?with_static_sqlite:Requires:        QtSql-sqlite3}
81 # while we do not link (yet), we use datafiles
82 Requires:       libprojectM
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # see libprojectM.spec for explanation
86 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
87
88 %description
89 Clementine is a modern music player and library organiser. It is
90 largely a port of Amarok 1.4, with some features rewritten to take
91 advantage of Qt4.
92
93 %description -l hu.UTF-8
94 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
95 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
96 a Qt4 előnyeit.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 # We already don't use these but just to make sure
103 rm -rf 3rdparty/gmock
104 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
105 rm -rf 3rdparty/qtsingleapplication
106 rm -rf 3rdparty/qxt
107 rm -rf 3rdparty/qtiocompressor
108 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
109
110 # Don't build tests. They require gmock
111 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
112
113 %build
114 install -d build
115 cd build
116 %cmake \
117         -DBUNDLE_PROJECTM_PRESETS=OFF \
118         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
119         -DUSE_SYSTEM_QXT=ON \
120         -DUSE_SYSTEM_PROJECTM=ON \
121         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
122         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
123         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
124         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
125         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
126         ..
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} -C build install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 %update_desktop_database_post
141
142 %postun
143 %update_desktop_database_postun
144
145 %files
146 %defattr(644,root,root,755)
147 %doc Changelog TODO
148 %attr(755,root,root) %{_bindir}/clementine
149 %{_desktopdir}/clementine.desktop
150 %{_pixmapsdir}/clementine.png
This page took 0.059944 seconds and 3 git commands to generate.