]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
add R gstreamer0.10-mad for mp3 playback
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 #
5 # Conditional build:
6 %bcond_without  static_sqlite   # with static sqlite3
7 %bcond_with     static_projectm # with static projectM
8
9 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
10 Summary:        A music player and library organiser
11 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
12 Name:           clementine
13 Version:        1.1.1
14 Release:        3
15 License:        GPL v3 and GPL v2+
16 Group:          Applications/Multimedia
17 URL:            http://www.clementine-player.org/
18 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
19 # Source0-md5:  28e4afb822388bd337a761db8f86febf
20 Patch0:         desktop-install.patch
21 Patch1:         unbundle-po.patch
22 BuildRequires:  QtCore-devel >= %{qtver}
23 BuildRequires:  QtDBus-devel >= %{qtver}
24 BuildRequires:  QtGui-devel >= %{qtver}
25 BuildRequires:  QtIOCompressor-devel
26 BuildRequires:  QtNetwork-devel >= %{qtver}
27 BuildRequires:  QtOpenGL-devel >= %{qtver}
28 BuildRequires:  QtSingleApplication-devel >= 2.6-4
29 BuildRequires:  QtSql-devel >= %{qtver}
30 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
31 BuildRequires:  QtXml-devel >= %{qtver}
32 BuildRequires:  boost-devel
33 BuildRequires:  cmake >= 2.6
34 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
35 BuildRequires:  gettext-devel
36 %{?with_static_projectm:BuildRequires:  glew-devel}
37 BuildRequires:  glib2-devel
38 BuildRequires:  gstreamer0.10-devel
39 BuildRequires:  gstreamer0.10-plugins-base-devel
40 BuildRequires:  gtest-devel
41 BuildRequires:  libgpod-devel >= 0.7.92
42 BuildRequires:  libimobiledevice-devel
43 BuildRequires:  libindicate-qt-devel
44 BuildRequires:  liblastfm-devel >= 0.3.3
45 BuildRequires:  libmtp-devel
46 BuildRequires:  libplist-devel
47 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
48 BuildRequires:  libqxt-devel
49 BuildRequires:  libxml2-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  pkgconfig
52 BuildRequires:  protobuf-devel
53 BuildRequires:  qca-devel
54 BuildRequires:  qjson-devel
55 BuildRequires:  qt4-build >= %{qtver}
56 BuildRequires:  qt4-linguist
57 BuildRequires:  qt4-qmake
58 BuildRequires:  rpmbuild(find_lang) >= 1.33
59 BuildRequires:  rpmbuild(macros) >= 1.596
60 BuildRequires:  sed >= 4.0
61 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
62 BuildRequires:  taglib-devel >= 1.6
63 BuildRequires:  usbmuxd-devel
64 Requires(post,postun):  desktop-file-utils
65 Requires(post,postun):  gtk-update-icon-cache
66 Requires(post,postun):  hicolor-icon-theme
67 Requires:       QtSingleApplication >= 2.6-4
68 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
69 Requires:       gstreamer0.10-audio-effects-base
70 Requires:       gstreamer0.10-mad
71 # while we do not link (yet), we use datafiles
72 Requires:       libprojectM
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # see libprojectM.spec for explanation
76 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
77
78 %description
79 Clementine is a modern music player and library organiser. It is
80 largely a port of Amarok 1.4, with some features rewritten to take
81 advantage of Qt4.
82
83 %description -l hu.UTF-8
84 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
85 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
86 a Qt4 előnyeit.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 # We already don't use these but just to make sure
94 rm -rf 3rdparty/gmock
95 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
96 rm -rf 3rdparty/qtsingleapplication
97 rm -rf 3rdparty/qxt
98 rm -rf 3rdparty/qtiocompressor
99 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
100
101 # Don't build tests. They require gmock
102 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
103 # remove -Wall
104 sed -i -e 's/-Wall//' src/CMakeLists.txt
105
106 %build
107 install -d build
108 install -d build/src/translations
109 cd build
110 %cmake \
111         -DBUNDLE_PROJECTM_PRESETS=OFF \
112         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
113         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
114         -DUSE_SYSTEM_QXT=ON \
115         -DUSE_SYSTEM_PROJECTM=ON \
116         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
117         ..
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 %{__make} -C build install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
126
127 # not in our glibc?
128 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
129
130 %find_lang %{name} --with-qm
131
132 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
133 cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
134 cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 %update_desktop_database_post
141 %update_icon_cache hicolor
142
143 %postun
144 %update_desktop_database_postun
145 %update_icon_cache hicolor
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc Changelog
150 %attr(755,root,root) %{_bindir}/clementine
151 %attr(755,root,root) %{_bindir}/clementine-tagreader
152 %{_desktopdir}/clementine.desktop
153 %{_pixmapsdir}/clementine.png
154 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
155 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.062497 seconds and 3 git commands to generate.