]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- release 3 (by relup.sh)
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 # - package for kde4 stuff (or nuke them):
5 #        /usr/share/kde4/services/clementine-feed.protocol
6 #        /usr/share/kde4/services/clementine-itms.protocol
7 #        /usr/share/kde4/services/clementine-itpc.protocol
8 #        /usr/share/kde4/services/clementine-zune.protocol
9 #
10 # Conditional build:
11 %bcond_without  static_sqlite   # with static sqlite3
12 %bcond_with     static_projectm # with static projectM
13 %bcond_with     libspotify      # build with system libspotify instead of downloading blob
14 %bcond_without  tests           # build without tests
15
16 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
17 Summary:        A music player and library organiser
18 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
19 Name:           clementine
20 Version:        1.2.3
21 Release:        3
22 License:        GPL v3 and GPL v2+
23 Group:          Applications/Multimedia
24 Source0:        https://github.com/clementine-player/Clementine/archive/%{version}.tar.gz?/%{name}-%{version}.tar.gz
25 # Source0-md5:  725b92ad4699de1b2ffdf48fe01ed092
26 Patch0:         desktop-install.patch
27 Patch1:         unbundle-po.patch
28 Patch3:         %{name}-dt_categories.patch
29 Patch4:         %{name}-mygpo.patch
30 Patch5:         %{name}-desktop.patch
31 Patch6:         %{name}-udisks-headers.patch
32 URL:            http://www.clementine-player.org/
33 BuildRequires:  QtCore-devel >= %{qtver}
34 BuildRequires:  QtDBus-devel >= %{qtver}
35 BuildRequires:  QtGui-devel >= %{qtver}
36 BuildRequires:  QtIOCompressor-devel
37 BuildRequires:  QtNetwork-devel >= %{qtver}
38 BuildRequires:  QtOpenGL-devel >= %{qtver}
39 BuildRequires:  QtSingleApplication-devel >= 2.6-4
40 BuildRequires:  QtSql-devel >= %{qtver}
41 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
42 BuildRequires:  QtXml-devel >= %{qtver}
43 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
44 BuildRequires:  boost-devel
45 BuildRequires:  cmake >= 2.6
46 BuildRequires:  desktop-file-utils
47 BuildRequires:  gettext-tools
48 %{?with_static_projectm:BuildRequires:  glew-devel}
49 BuildRequires:  glib2-devel
50 BuildRequires:  gstreamer0.10-devel
51 BuildRequires:  gstreamer0.10-plugins-base-devel
52 BuildRequires:  gtest-devel
53 BuildRequires:  libcdio-devel
54 BuildRequires:  libchromaprint-devel
55 BuildRequires:  libechonest-devel
56 BuildRequires:  libgpod-devel >= 0.7.92
57 BuildRequires:  libimobiledevice-devel >= 1.1.5
58 BuildRequires:  libindicate-qt-devel
59 BuildRequires:  liblastfm-devel >= 0.3.3
60 BuildRequires:  libmtp-devel
61 BuildRequires:  libmygpo-qt-devel >= 1.0.7
62 BuildRequires:  libplist-devel
63 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
64 BuildRequires:  libqxt-devel
65 %{?with_libspotify:BuildRequires:       libspotify-devel >= 12.1.45}
66 BuildRequires:  libusbmuxd-devel
67 BuildRequires:  libxml2-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  pkgconfig
70 BuildRequires:  protobuf-devel
71 BuildRequires:  qca-devel
72 BuildRequires:  qjson-devel
73 BuildRequires:  qt4-build >= %{qtver}
74 BuildRequires:  qt4-linguist
75 BuildRequires:  qt4-qmake
76 BuildRequires:  rpmbuild(find_lang) >= 1.38
77 BuildRequires:  rpmbuild(macros) >= 1.596
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  sparsehash-devel
80 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
81 BuildRequires:  taglib-devel >= 1.6
82 Requires(post,postun):  desktop-file-utils
83 Requires(post,postun):  gtk-update-icon-cache
84 Requires(post,postun):  hicolor-icon-theme
85 Requires:       QtSingleApplication >= 2.6-4
86 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
87 Requires:       gstreamer0.10-audio-effects-base
88 Requires:       gstreamer0.10-mad
89 Suggests:       gstreamer0.10-flac
90 # if we do not link, we use datafiles
91 %{!?with_static_projectm:Requires:      libprojectM}
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 # see libprojectM.spec for explanation
95 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
96
97 %description
98 Clementine is a modern music player and library organiser. It is
99 largely a port of Amarok 1.4, with some features rewritten to take
100 advantage of Qt4.
101
102 %description -l hu.UTF-8
103 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
104 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
105 a Qt4 előnyeit.
106
107 %prep
108 %setup -q -n Clementine-%{version}
109 %patch0 -p1
110 %patch1 -p1
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114 %patch6 -p1
115
116 # Remove all 3rdparty libraries except:
117 # - universalchardet - not available as a separate library.
118 # - libprojectM - see bcond
119 # - sha2 - ?
120 # - qocoa - ?
121 # - qsqlite - see bcond
122 # cleanup vendor. keep only needed libraries.
123 # (the rest are packaged with system packages)
124 mv 3rdparty 3rdparty.dist
125 vendor() {
126         local path dir
127         for path; do
128                 dir=$(dirname $path)
129                 test -d 3rdparty/$dir || mkdir -p 3rdparty/$dir
130                 mv 3rdparty.dist/$path 3rdparty/$path
131         done
132 }
133 vendor sha2 qocoa
134 %{?with_static_sqlite:vendor qsqlite}
135 %{?with_static_projectm:vendor libprojectm}
136
137 # Don't build tests. They require gmock
138 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
139 # remove -Wall
140 sed -i -e 's/-Wall//' src/CMakeLists.txt
141 # ...and -Werror
142 sed -i -e 's/-Werror//' src/CMakeLists.txt
143
144 %build
145 install -d build
146 install -d build/src/translations
147 cd build
148 # as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
149 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
150 %cmake \
151         -DCMAKE_INCLUDE_PATH=%{_includedir}/qt4 \
152         -DBUNDLE_PROJECTM_PRESETS=OFF \
153         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
154         -DUSE_SYSTEM_QXT=ON \
155         -DUSE_SYSTEM_PROJECTM=ON \
156         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
157         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions \
158         ..
159 %{__make}
160
161 %if %{with tests}
162 desktop-file-validate ../dist/%{name}.desktop
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 %{__make} -C build install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
171
172 # not in our glibc?
173 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
174 rm -r $RPM_BUILD_ROOT%{_localedir}/he_IL
175 rm -r $RPM_BUILD_ROOT%{_localedir}/mk_MK
176 rm -r $RPM_BUILD_ROOT%{_localedir}/si_LK
177
178 %find_lang %{name} --with-qm
179
180 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
181 cp -p dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
182 cp -p dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post
188 %update_desktop_database_post
189 %update_icon_cache hicolor
190
191 %postun
192 %update_desktop_database_postun
193 %update_icon_cache hicolor
194
195 %files -f %{name}.lang
196 %defattr(644,root,root,755)
197 %doc Changelog
198 %attr(755,root,root) %{_bindir}/clementine
199 %attr(755,root,root) %{_bindir}/clementine-tagreader
200 %{_desktopdir}/clementine.desktop
201 %{_pixmapsdir}/clementine.png
202 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
203 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.079218 seconds and 3 git commands to generate.