]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- sqlite-devel is definately bogus
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - add missing BRs
3 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4 # -- Building engines: gst
5 # -- Skipping engines: vlc xine qt-phonon
6 #    The following engines are NOT supported by clementine developers:
7 #     vlc xine qt-phonon
8 # - apply patches to libprojectM.spec and use
9 # - make engines pluggable not statically linked, then could enable the bconds
10 #
11 # Conditional build:
12 %bcond_with             engine_xine             # without xine engine
13 %bcond_with             engine_vlc              # without vlc engine
14 %bcond_with             engine_qt_phonon        # without qt-phonon engine
15 %bcond_without  engine_gstreamer        # without gstreamer engine
16
17 Summary:        A music player and library organiser
18 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
19 Name:           clementine
20 Version:        0.4.2
21 Release:        0.2
22 License:        GPL v3 and GPL v2+
23 Group:          Applications/Multimedia
24 URL:            http://code.google.com/p/clementine-player
25 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
26 # Source0-md5:  c6819b0d2a8324f1d686fb5a3b1d287b
27 Patch0:         %{name}-dont-bundle-external-lib.patch
28 Patch2:         desktop-install.patch
29 BuildRequires:  QtCore-devel
30 BuildRequires:  QtDBus-devel
31 BuildRequires:  QtGui-devel
32 BuildRequires:  QtIOCompressor-devel
33 BuildRequires:  QtNetwork-devel
34 BuildRequires:  QtOpenGL-devel
35 BuildRequires:  QtSingleApplication-devel
36 BuildRequires:  QtSql-devel
37 BuildRequires:  QtTest-devel
38 BuildRequires:  boost-devel
39 BuildRequires:  cmake >= 2.6
40 BuildRequires:  desktop-file-utils
41 BuildRequires:  gettext-devel
42 BuildRequires:  gstreamer-devel
43 BuildRequires:  gstreamer-devel >= 0.10
44 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
45 BuildRequires:  gtest-devel
46 BuildRequires:  liblastfm-devel
47 BuildRequires:  libnotify-devel
48 #BuildRequires: libprojectM-devel
49 BuildRequires:  libqxt-devel
50 #BuildRequires: libqxt-devel >= 0.6.0-0.2
51 BuildRequires:  notification-daemon
52 BuildRequires:  phonon-devel
53 BuildRequires:  pkgconfig
54 BuildRequires:  qt4-build
55 BuildRequires:  qt4-linguist
56 BuildRequires:  qt4-qmake
57 BuildRequires:  rpmbuild(macros) >= 1.198
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  sqlite3-devel
60 BuildRequires:  taglib-devel >= 1.6
61 BuildRequires:  vlc-devel
62 BuildRequires:  xine-lib-devel
63 Requires(post,postun):  desktop-file-utils
64 Requires:       QtSql-sqlite3
65 # while we do not link (yet), we use datafiles
66 Requires:       libprojectM
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 # see libprojectM.spec for explanation
70 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
71
72 %description
73 Clementine is a modern music player and library organiser. It is
74 largely a port of Amarok 1.4, with some features rewritten to take
75 advantage of Qt4.
76
77 %description -l hu.UTF-8
78 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
79 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
80 a Qt4 előnyeit.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch2 -p1
86
87 # We already don't use these but just to make sure
88 rm -rf 3rdparty/gmock
89 rm -rf 3rdparty/qsqlite
90 rm -rf 3rdparty/qtsingleapplication
91 rm -rf 3rdparty/qxt
92 rm -rf 3rdparty/qtiocompressor
93
94 # Don't build tests. They require gmock
95 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
96
97 %build
98 install -d build
99 cd build
100 %cmake \
101         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
102         -DBUNDLE_PROJECTM_PRESETS=OFF \
103         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
104         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
105         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
106         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
107         ..
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 %{__make} -C build install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 %update_desktop_database_post
120
121 %postun
122 %update_desktop_database_postun
123
124 %files
125 %defattr(644,root,root,755)
126 %doc Changelog TODO
127 %attr(755,root,root) %{_bindir}/clementine
128 %{_desktopdir}/clementine.desktop
129 %{_pixmapsdir}/clementine.png
This page took 0.069787 seconds and 3 git commands to generate.