]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- unbundle translations, tag with %lang
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # -- Building engines: gst
4 # -- Skipping engines: vlc xine qt-phonon
5 #    The following engines are NOT supported by clementine developers:
6 #     vlc xine qt-phonon
7 # - apply patches to libprojectM.spec and use
8 # - make engines pluggable not statically linked, then could enable the bconds
9 #
10 # Conditional build:
11 %bcond_with             engine_xine             # without xine engine
12 %bcond_with             engine_vlc              # without vlc engine
13 %bcond_with             engine_qt_phonon        # without qt-phonon engine
14 %bcond_without  engine_gstreamer        # without gstreamer engine
15 %bcond_without  static_sqlite   # with static sqlite3
16 %bcond_with             static_projectm # with static projectM
17
18 Summary:        A music player and library organiser
19 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
20 Name:           clementine
21 Version:        0.5.3
22 Release:        2
23 License:        GPL v3 and GPL v2+
24 Group:          Applications/Multimedia
25 URL:            http://www.clementine-player.org/
26 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
27 # Source0-md5:  3411a0e31bdab7a6693048e934996f40
28 Patch0:         desktop-install.patch
29 Patch1:         unbundle-po.patch
30 Patch2:         build-languages-dynamic.patch
31 BuildRequires:  QtCore-devel
32 BuildRequires:  QtDBus-devel
33 BuildRequires:  QtGui-devel
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel
36 BuildRequires:  QtOpenGL-devel
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel
39 %{?with_tests:BuildRequires:    QtTest-devel}
40 BuildRequires:  QtXml-devel
41 BuildRequires:  boost-devel
42 BuildRequires:  cmake >= 2.6
43 #BuildRequires: desktop-file-utils
44 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
45 BuildRequires:  gettext-devel
46 %{?with_static_projectm:BuildRequires:  glew-devel}
47 BuildRequires:  glib2-devel
48 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
49 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
50 BuildRequires:  gtest-devel
51 BuildRequires:  libgpod-devel >= 0.7.92
52 BuildRequires:  libimobiledevice-devel
53 BuildRequires:  liblastfm-devel
54 BuildRequires:  libmtp-devel
55 BuildRequires:  libnotify-devel
56 BuildRequires:  libplist-devel
57 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
58 BuildRequires:  libqxt-devel
59 #BuildRequires: libqxt-devel >= 0.6.0-0.2
60 BuildRequires:  libxml2-devel
61 BuildRequires:  notification-daemon
62 BuildRequires:  phonon
63 %{?with_engine_phonon:BuildRequires:    phonon-devel}
64 BuildRequires:  pkgconfig
65 BuildRequires:  qt4-build
66 BuildRequires:  qt4-linguist
67 BuildRequires:  qt4-qmake
68 BuildRequires:  rpmbuild(find_lang) = 1.33
69 BuildRequires:  rpmbuild(macros) >= 1.577
70 BuildRequires:  sed >= 4.0
71 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
72 BuildRequires:  taglib-devel >= 1.6
73 BuildRequires:  usbmuxd-devel
74 %{?with_engine_vlc:BuildRequires:       vlc-devel}
75 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
76 Requires(post,postun):  desktop-file-utils
77 Requires:       QtSingleApplication >= 2.6-4
78 %{!?with_static_sqlite:Requires:        QtSql-sqlite3}
79 # while we do not link (yet), we use datafiles
80 Requires:       libprojectM
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 # see libprojectM.spec for explanation
84 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
85
86 %description
87 Clementine is a modern music player and library organiser. It is
88 largely a port of Amarok 1.4, with some features rewritten to take
89 advantage of Qt4.
90
91 %description -l hu.UTF-8
92 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
93 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
94 a Qt4 előnyeit.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101
102 # We already don't use these but just to make sure
103 rm -rf 3rdparty/gmock
104 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
105 rm -rf 3rdparty/qtsingleapplication
106 rm -rf 3rdparty/qxt
107 rm -rf 3rdparty/qtiocompressor
108 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
109
110 # Don't build tests. They require gmock
111 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
112
113 %build
114 install -d build
115 install -d build/src/translations
116 cd build
117 %cmake \
118         -DBUNDLE_PROJECTM_PRESETS=OFF \
119         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
120         -DUSE_SYSTEM_QXT=ON \
121         -DUSE_SYSTEM_PROJECTM=ON \
122         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
123         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
124         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
125         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
126         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
127         ..
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 %{__make} -C build install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
136
137 %find_lang %{name} --with-qm
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 %update_desktop_database_post
144
145 %postun
146 %update_desktop_database_postun
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc Changelog TODO
151 %attr(755,root,root) %{_bindir}/clementine
152 %{_desktopdir}/clementine.desktop
153 %{_pixmapsdir}/clementine.png
This page took 0.037999 seconds and 3 git commands to generate.