]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
070faae19d22f3ae6eaa6c70bba25b0395ca9e3a
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 # - package for kde4 stuff (or nuke them):
5 #        /usr/share/kde4/services/clementine-feed.protocol
6 #        /usr/share/kde4/services/clementine-itms.protocol
7 #        /usr/share/kde4/services/clementine-itpc.protocol
8 #        /usr/share/kde4/services/clementine-zune.protocol
9 #
10 # Conditional build:
11 %bcond_without  static_sqlite   # with static sqlite3
12 %bcond_with     static_projectm # with static projectM
13 %bcond_with     libspotify      # build with system libspotify instead of downloading blob
14 %bcond_without  tests           # build without tests
15
16 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
17 Summary:        A music player and library organiser
18 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
19 Name:           clementine
20 Version:        1.2.3
21 Release:        1
22 License:        GPL v3 and GPL v2+
23 Group:          Applications/Multimedia
24 Source0:        https://github.com/clementine-player/Clementine/archive/%{version}.tar.gz?/%{name}-%{version}.tar.gz
25 # Source0-md5:  725b92ad4699de1b2ffdf48fe01ed092
26 Patch0:         desktop-install.patch
27 Patch1:         unbundle-po.patch
28 Patch3:         %{name}-dt_categories.patch
29 Patch4:         %{name}-mygpo.patch
30 Patch5:         %{name}-desktop.patch
31 Patch6:         %{name}-udisks-headers.patch
32 URL:            http://www.clementine-player.org/
33 BuildRequires:  QtCore-devel >= %{qtver}
34 BuildRequires:  QtDBus-devel >= %{qtver}
35 BuildRequires:  QtGui-devel >= %{qtver}
36 BuildRequires:  QtIOCompressor-devel
37 BuildRequires:  QtNetwork-devel >= %{qtver}
38 BuildRequires:  QtOpenGL-devel >= %{qtver}
39 BuildRequires:  QtSingleApplication-devel >= 2.6-4
40 BuildRequires:  QtSql-devel >= %{qtver}
41 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
42 BuildRequires:  QtXml-devel >= %{qtver}
43 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
44 BuildRequires:  boost-devel
45 BuildRequires:  cmake >= 2.6
46 BuildRequires:  desktop-file-utils
47 BuildRequires:  gettext-devel
48 %{?with_static_projectm:BuildRequires:  glew-devel}
49 BuildRequires:  glib2-devel
50 BuildRequires:  gstreamer0.10-devel
51 BuildRequires:  gstreamer0.10-plugins-base-devel
52 BuildRequires:  gtest-devel
53 BuildRequires:  libcdio-devel
54 BuildRequires:  libchromaprint-devel
55 BuildRequires:  libechonest-devel
56 BuildRequires:  libgpod-devel >= 0.7.92
57 BuildRequires:  libimobiledevice-devel >= 1.1.5
58 BuildRequires:  libindicate-qt-devel
59 BuildRequires:  liblastfm-devel >= 0.3.3
60 BuildRequires:  libmtp-devel
61 BuildRequires:  libmygpo-qt-devel >= 1.0.7
62 BuildRequires:  libplist-devel
63 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
64 BuildRequires:  libqxt-devel
65 %{?with_libspotify:BuildRequires:       libspotify-devel >= 12.1.45}
66 BuildRequires:  libxml2-devel
67 BuildRequires:  pkgconfig
68 BuildRequires:  pkgconfig
69 BuildRequires:  protobuf-devel
70 BuildRequires:  qca-devel
71 BuildRequires:  qjson-devel
72 BuildRequires:  qt4-build >= %{qtver}
73 BuildRequires:  qt4-linguist
74 BuildRequires:  qt4-qmake
75 BuildRequires:  rpmbuild(find_lang) >= 1.33
76 BuildRequires:  rpmbuild(macros) >= 1.596
77 BuildRequires:  sed >= 4.0
78 BuildRequires:  sparsehash-devel
79 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
80 BuildRequires:  taglib-devel >= 1.6
81 BuildRequires:  usbmuxd-devel
82 Requires(post,postun):  desktop-file-utils
83 Requires(post,postun):  gtk-update-icon-cache
84 Requires(post,postun):  hicolor-icon-theme
85 Requires:       QtSingleApplication >= 2.6-4
86 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
87 Requires:       gstreamer0.10-audio-effects-base
88 Requires:       gstreamer0.10-mad
89 Suggests:       gstreamer0.10-flac
90 # if we do not link, we use datafiles
91 %{!?with_static_projectm:Requires:      libprojectM}
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 # see libprojectM.spec for explanation
95 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
96
97 %description
98 Clementine is a modern music player and library organiser. It is
99 largely a port of Amarok 1.4, with some features rewritten to take
100 advantage of Qt4.
101
102 %description -l hu.UTF-8
103 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
104 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
105 a Qt4 előnyeit.
106
107 %prep
108 %setup -q -n Clementine-%{version}
109 %patch0 -p1
110 %patch1 -p1
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114 %patch6 -p1
115
116 # Remove all 3rdparty libraries except:
117 # - universalchardet - not available as a separate library.
118 # - libprojectM - see bcond
119 # - sha2 - ?
120 # - qocoa - ?
121 # - qsqlite - see bcond
122 mv 3rdparty 3rdparty.keep
123 install -d 3rdparty
124 mv 3rdparty.keep/{sha2,qocoa%{?with_static_sqlite:,qsqlite}%{?with_static_projectm:,libprojectm}} 3rdparty
125
126 # Don't build tests. They require gmock
127 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
128 # remove -Wall
129 sed -i -e 's/-Wall//' src/CMakeLists.txt
130 # ...and -Werror
131 sed -i -e 's/-Werror//' src/CMakeLists.txt
132
133 %build
134 install -d build
135 install -d build/src/translations
136 cd build
137 # as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
138 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
139 %cmake \
140         -DBUNDLE_PROJECTM_PRESETS=OFF \
141         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
142         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
143         -DUSE_SYSTEM_QXT=ON \
144         -DUSE_SYSTEM_PROJECTM=ON \
145         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
146         ..
147 %{__make}
148
149 %if %{with tests}
150 desktop-file-validate ../dist/%{name}.desktop
151 %endif
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155 %{__make} -C build install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
159
160 # not in our glibc?
161 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
162 rm -r $RPM_BUILD_ROOT%{_localedir}/he_IL
163 rm -r $RPM_BUILD_ROOT%{_localedir}/mk_MK
164 rm -r $RPM_BUILD_ROOT%{_localedir}/si_LK
165
166 %find_lang %{name} --with-qm
167
168 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
169 cp -p dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
170 cp -p dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post
176 %update_desktop_database_post
177 %update_icon_cache hicolor
178
179 %postun
180 %update_desktop_database_postun
181 %update_icon_cache hicolor
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc Changelog
186 %attr(755,root,root) %{_bindir}/clementine
187 %attr(755,root,root) %{_bindir}/clementine-tagreader
188 %{_desktopdir}/clementine.desktop
189 %{_pixmapsdir}/clementine.png
190 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
191 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.068113 seconds and 2 git commands to generate.