]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- disable experimental engines, especially vlc that pulls so many deps
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
2c687024 2# - add missing BRs
f2d911f2
ER
3# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4# -- Building engines: gst
5# -- Skipping engines: vlc xine qt-phonon
6# The following engines are NOT supported by clementine developers:
7# vlc xine qt-phonon
8# - apply patches to libprojectM.spec and use
0b056df0 9# - make engines pluggable not statically linked, then could enable the bconds
2c687024 10#
11# Conditional build:
0b056df0
ER
12%bcond_with engine_xine # without xine engine
13%bcond_with engine_vlc # without vlc engine
14%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 15%bcond_without engine_gstreamer # without gstreamer engine
0b056df0 16
bf1e6952 17Summary: A music player and library organiser
df3c0ac1 18Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 19Name: clementine
f2d911f2 20Version: 0.4.2
0b056df0 21Release: 0.2
bf1e6952
ER
22License: GPL v3 and GPL v2+
23Group: Applications/Multimedia
24URL: http://code.google.com/p/clementine-player
2c687024 25Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
f2d911f2 26# Source0-md5: c6819b0d2a8324f1d686fb5a3b1d287b
bf1e6952 27Patch0: %{name}-dont-bundle-external-lib.patch
7279ad3f 28Patch2: desktop-install.patch
b6199a83 29BuildRequires: QtCore-devel
30BuildRequires: QtDBus-devel
31BuildRequires: QtGui-devel
f2d911f2 32BuildRequires: QtIOCompressor-devel
b6199a83 33BuildRequires: QtNetwork-devel
34BuildRequires: QtOpenGL-devel
88ca6f4b 35BuildRequires: QtSingleApplication-devel
b6199a83 36BuildRequires: QtSql-devel
37BuildRequires: QtTest-devel
bf1e6952 38BuildRequires: boost-devel
7279ad3f 39BuildRequires: cmake >= 2.6
bf1e6952 40BuildRequires: desktop-file-utils
75ec0859 41BuildRequires: gettext-devel
42BuildRequires: gstreamer-devel
f2d911f2
ER
43BuildRequires: gstreamer-devel >= 0.10
44BuildRequires: gstreamer-plugins-base-devel >= 0.10
bf1e6952
ER
45BuildRequires: gtest-devel
46BuildRequires: liblastfm-devel
47BuildRequires: libnotify-devel
f2d911f2 48#BuildRequires: libprojectM-devel
bf1e6952 49BuildRequires: libqxt-devel
f2d911f2 50#BuildRequires: libqxt-devel >= 0.6.0-0.2
bf1e6952 51BuildRequires: notification-daemon
75ec0859 52BuildRequires: phonon-devel
53BuildRequires: pkgconfig
bf1e6952 54BuildRequires: qt4-build
b6199a83 55BuildRequires: qt4-linguist
56BuildRequires: qt4-qmake
726826ed 57BuildRequires: rpmbuild(macros) >= 1.198
bf1e6952
ER
58BuildRequires: sed >= 4.0
59BuildRequires: sqlite-devel
b6199a83 60BuildRequires: sqlite3-devel
f2d911f2 61BuildRequires: taglib-devel >= 1.6
75ec0859 62BuildRequires: vlc-devel
bf1e6952 63BuildRequires: xine-lib-devel
726826ed 64Requires(post,postun): desktop-file-utils
df3c0ac1 65Requires: QtSql-sqlite3
f2d911f2
ER
66# while we do not link (yet), we use datafiles
67Requires: libprojectM
bf1e6952
ER
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
f2d911f2
ER
70# see libprojectM.spec for explanation
71%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
72
bf1e6952
ER
73%description
74Clementine is a modern music player and library organiser. It is
75largely a port of Amarok 1.4, with some features rewritten to take
76advantage of Qt4.
77
df3c0ac1
ZU
78%description -l hu.UTF-8
79Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
80az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
81a Qt4 előnyeit.
82
bf1e6952
ER
83%prep
84%setup -q
f2d911f2 85%patch0 -p1
29df970b 86%patch2 -p1
bf1e6952
ER
87
88# We already don't use these but just to make sure
f2d911f2
ER
89rm -rf 3rdparty/gmock
90rm -rf 3rdparty/qsqlite
91rm -rf 3rdparty/qtsingleapplication
92rm -rf 3rdparty/qxt
93rm -rf 3rdparty/qtiocompressor
bf1e6952 94
7279ad3f 95# Don't build tests. They require gmock
f2d911f2 96sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
97
98%build
99install -d build
100cd build
88ca6f4b
ER
101%cmake \
102 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
f2d911f2 103 -DBUNDLE_PROJECTM_PRESETS=OFF \
2c687024 104 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
105 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
106 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 107 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
88ca6f4b 108 ..
bf1e6952
ER
109%{__make}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113%{__make} -C build install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
726826ed
ER
119%post
120%update_desktop_database_post
121
122%postun
123%update_desktop_database_postun
124
bf1e6952
ER
125%files
126%defattr(644,root,root,755)
127%doc Changelog TODO
128%attr(755,root,root) %{_bindir}/clementine
129%{_desktopdir}/clementine.desktop
7279ad3f 130%{_pixmapsdir}/clementine.png
This page took 0.044956 seconds and 4 git commands to generate.