]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
fdec6408666ad3872d71ec182060f0246a2070f8
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without  gpg             # build without GPG support
4 %bcond_without  ssl             # build without SSL support
5 %bcond_without  ipv6            # build without IPv6 support
6 %bcond_without  ldap            # build without LDAP support
7 %bcond_without  faces           # build without compfaces support
8 %bcond_without  dillo           # build without dillo plugin (html browser)
9 %bcond_without  clamav          # build without clamav plugin
10 %bcond_without  spamassassin    # build without spamassassin plugin
11 %bcond_without  trayicon        # build without trayicon plugin
12 %bcond_with     mathml          # build with mathml plugin
13 #
14 %define         _sname  sylpheed
15 %define         _iconver        20040206
16 Summary:        A bleeding edge branch of Sylpheed, a GTK+ based, lightweight, and fast e-mail client
17 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
18 Name:           %{_sname}-claws
19 Version:        0.9.10
20 Release:        0.1
21 License:        GPL v2
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{_sname}-%{version}claws.tar.bz2
24 # Source0-md5:  53c3f65afe8e1c96e07bf33c7f76ef5a
25 Source1:        %{name}.desktop
26 Source2:        http://dl.sourceforge.net/%{name}/%{_sname}-iconset-%{_iconver}.tar.gz
27 # Source2-md5:  478128ccf00914990f73383692b5cd30
28 URL:            http://sylpheed-claws.sourceforge.net/
29 BuildRequires:  aspell-devel >= 0.50
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  bzip2-devel
33 %{?with_clamav:BuildRequires:   clamav-devel}
34 %{?with_faces:BuildRequires:    faces-devel}
35 BuildRequires:  gdk-pixbuf-devel >= 0.8
36 BuildRequires:  gettext-devel
37 BuildRequires:  gmp-devel
38 %{?with_gpg:BuildRequires:      gpgme-devel >= 0.3.10}
39 %{?with_gpg:BuildRequires:      gpgme-devel < 0.4}
40 BuildRequires:  gtk+-devel >= 1.2.6
41 BuildRequires:  imlib-devel
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libtool
44 # TODO: package gtkmathview: http://helm.cs.unibo.it/mml-widget/ (0.4.3 for gtk1, 0.6.0 for gtk2)
45 %{?with_mathml:BuildRequires:   gtkmathview >= 0.4.2}
46 %{?with_mathml:BuildRequires:   gtkmathview < 0.5}
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
49 BuildRequires:  pkgconfig
50 %{?with_faces:Requires: faces}
51 Obsoletes:      sylpheed
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 This program is an X based fast e-mail client which has features same
56 as orginal Sylpheed but with new/improved features. Some of new stuff
57 is really cool and useable.
58
59 %description -l pl
60 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
61 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
62 ¶wietne i u¿yteczne.
63
64 %package plugins
65 Summary:        Special plugins for Sylpheed-Claws
66 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
67 Group:          X11/Applications/Networking
68 Requires:       %{name} = %{version}-%{release}
69 %{?with_dillo:Requires: dillo}
70
71 %description plugins
72 This is collection of some usefull plugins for Sylpheed-claws.
73
74 %description plugins -l pl
75 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci Sylpheeda.
76
77 %package devel
78 Summary:        Headers from Sylpheed-Claws
79 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
80 Group:          X11/Applications/Networking
81 Requires:       %{name} = %{version}-%{release}
82
83 %description devel
84 Sylpheed-Claws development package.
85
86 %description devel -l pl
87 Pliki nag³ówkowe programu Sylpheed-Claws.
88
89 %package themes
90 Summary:        Themes for Sylpheed-Claws
91 Summary(pl):    Motywy dla programu Sylpheed-Claws
92 Group:          X11/Applications/Networking
93 Requires:       %{name} = %{version}-%{release}
94
95 %description themes
96 Sylpheed-Claws themes package.
97
98 %description themes -l pl
99 Motywy dla programu Sylpheed-Claws.
100
101 %prep
102 %setup -q -n %{_sname}-%{version}claws -a1 -a2
103 mv %{_sname}-iconset-* themes
104 mv -f themes/README README.themes
105
106 %build
107 rm -f missing
108 %{__libtoolize}
109 %{__gettextize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         %{?with_gpg:--enable-gpgme} %{!?with_gpg:--disable-gpgme} \
116         %{?with_ldap:--enable-ldap} \
117         %{?with_ssl:--enable-openssl} \
118         %{?with_ipv6:--enable-ipv6 } \
119         %{!?with_faces:--disable-compface} \
120         %{?with_dillo:--enable-dillo-viewer-plugin } \
121         %{!?with_dillo:--disable-dillo-viewer-plugin } \
122         %{?with_clamav:--enable-clamav-plugin } \
123         %{!?with_clamav:--disable-clamav-plugin } \
124         %{?with_mathml:--enable-mathml-viewer-plugin } \
125         %{!?with_mathml:--disable-mathml-viewer-plugin } \
126         %{?with_trayicon:--enable-trayicon-plugin } \
127         %{!?with_trayicon:--disable-trayicon-plugin } \
128         %{?with_spamassassin:--enable-spamassassin-plugin } \
129         --enable-aspell \
130         --enable-gdk-pixbuf \
131         --enable-threads
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
143 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{_sname}
144
145 install %{_sname}.png $RPM_BUILD_ROOT%{_pixmapsdir}
146
147 %find_lang %{_sname}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files -f %{_sname}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README* TODO
155 %{_mandir}/man1/%{_sname}.1*
156 %attr(755,root,root) %{_bindir}/*
157 %dir %{_datadir}/%{_sname}
158 %dir %{_datadir}/%{_sname}/manual
159 %{_datadir}/%{_sname}/manual/en
160 %lang(de) %{_datadir}/%{_sname}/manual/de
161 %lang(es) %{_datadir}/%{_sname}/manual/es
162 %lang(fr) %{_datadir}/%{_sname}/manual/fr
163 %lang(ja) %{_datadir}/%{_sname}/manual/ja
164 %dir %{_datadir}/%{_sname}/faq
165 %{_datadir}/%{_sname}/faq/en
166 %lang(de) %{_datadir}/%{_sname}/faq/de
167 %lang(es) %{_datadir}/%{_sname}/faq/es
168 %lang(fr) %{_datadir}/%{_sname}/faq/fr
169 %lang(it) %{_datadir}/%{_sname}/faq/it
170 %{_desktopdir}/%{name}.desktop
171 %{_pixmapsdir}/%{_sname}.png
172
173 %files plugins
174 %defattr(644,root,root,755)
175 %dir %{_libdir}/%{_sname}
176 %dir %{_libdir}/%{_sname}/plugins
177 %attr(755,root,root) %{_libdir}/%{_sname}/plugins/*so
178
179 %files devel
180 %defattr(644,root,root,755)
181 %{_includedir}/%{_sname}
182 %{_pkgconfigdir}/*.pc
183
184 %files themes
185 %defattr(644,root,root,755)
186 %{_datadir}/%{_sname}/themes
This page took 0.043187 seconds and 2 git commands to generate.