]> git.pld-linux.org Git - packages/claws-mail.git/blob - claws-mail.spec
025148b743d6f9a0722a92fb1b25da8e9f60b09f
[packages/claws-mail.git] / claws-mail.spec
1 #
2 # Conditional build:
3 %bcond_without  clamav          # build without clamav plugin
4 %bcond_without  compface        # build without compface support
5 %bcond_without  dillo           # build without dillo plugin (html browser)
6 %bcond_without  gnomeprint      # build without gnomeprint support
7 %bcond_without  gpg             # build without GPG support
8 %bcond_without  ipv6            # build without IPv6 support
9 %bcond_without  ldap            # build without LDAP support
10 %bcond_with     mathml          # build with mathml plugin
11 %bcond_without  spamassassin    # build without spamassassin plugin
12 %bcond_without  ssl             # build without SSL support
13 %bcond_without  trayicon        # build without trayicon plugin
14 #
15 %define         _iconver        20040929
16 Summary:        A bleeding edge branch of Sylpheed, a GTK2 based, lightweight, and fast e-mail client
17 Summary(pl):    Rozwojowa wersja Sylpheed z du¿± ilo¶ci± zmian oraz ulepszeñ
18 Name:           sylpheed-claws
19 Version:        2.2.3
20 Release:        1
21 License:        GPL v2
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/sylpheed-claws/%{name}-%{version}.tar.bz2
24 # Source0-md5:  870eb4de8dc242f16171145d8af725b9
25 Source1:        %{name}.desktop
26 Source2:        http://dl.sourceforge.net/sylpheed-claws/sylpheed-iconset-%{_iconver}.tar.gz
27 # Source2-md5:  d72cf03bf3d13cf9e2785eaca3807707
28 URL:            http://sylpheed-claws.sourceforge.net/
29 BuildRequires:  aspell-devel >= 2:0.50
30 BuildRequires:  autoconf >= 2.50
31 BuildRequires:  automake
32 BuildRequires:  bzip2-devel
33 %{?with_clamav:BuildRequires:   clamav-devel}
34 %{?with_compface:BuildRequires: compface-devel}
35 BuildRequires:  gdk-pixbuf-devel >= 0.8
36 BuildRequires:  gettext-devel
37 BuildRequires:  gmp-devel
38 %{?with_gnomeprint:BuildRequires:       libgnomeprintui-devel}
39 %{?with_gpg:BuildRequires:      gpgme-devel >= 1:0.4.5}
40 BuildRequires:  gtk+2-devel >= 2.4.0
41 BuildRequires:  imlib-devel >= 1.9
42 BuildRequires:  libetpan-devel >= 0.45
43 BuildRequires:  libltdl-devel
44 BuildRequires:  libtool
45 # TODO: package gtkmathview: http://helm.cs.unibo.it/mml-widget/ (0.4.3 for gtk1, 0.6.0 for gtk2)
46 %{?with_mathml:BuildRequires:   gtkmathview >= 0.4.2}
47 %{?with_mathml:BuildRequires:   gtkmathview < 0.5}
48 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
49 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
50 BuildRequires:  pkgconfig
51 %{?with_faces:Requires: faces}
52 Obsoletes:      sylpheed
53 Obsoletes:      sylpheed-gtk2
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 This program is an X based fast e-mail client which has features same
58 as orginal Sylpheed but with new/improved features. Some of new stuff
59 is really cool and useable.
60
61 %description -l pl
62 Szybki klient poczty o mo¿liwo¶ciach takich jak oryginalny Sylpheed
63 ale z nowymi/poprawionymi funkcjami. Niektóre dodatki s± naprawdê
64 ¶wietne i u¿yteczne.
65
66 %package plugins
67 Summary:        Special plugins for Sylpheed-Claws
68 Summary(pl):    Dodatkowe pluginy dla Sylpheed-Claws
69 Group:          X11/Applications/Networking
70 Requires:       %{name} = %{version}-%{release}
71 %{?with_dillo:Requires: dillo}
72
73 %description plugins
74 This is collection of some usefull plugins for Sylpheed-claws.
75
76 %description plugins -l pl
77 Jest to zbiór kilku dodatkowych pluginów powiêkszaj±cych mo¿liwo¶ci
78 Sylpheeda.
79
80 %package devel
81 Summary:        Headers from Sylpheed-Claws
82 Summary(pl):    Pliki nag³ówkowe programu Sylpheed-Claws
83 Group:          X11/Applications/Networking
84 Requires:       %{name} = %{version}-%{release}
85
86 %description devel
87 Sylpheed-Claws development package.
88
89 %description devel -l pl
90 Pliki nag³ówkowe programu Sylpheed-Claws.
91
92 %package themes
93 Summary:        Themes for Sylpheed-Claws
94 Summary(pl):    Motywy dla programu Sylpheed-Claws
95 Group:          X11/Applications/Networking
96 Requires:       %{name} = %{version}-%{release}
97
98 %description themes
99 Sylpheed-Claws themes package.
100
101 %description themes -l pl
102 Motywy dla programu Sylpheed-Claws.
103
104 %prep
105 %setup -q -a2
106 mv sylpheed-iconset-* themes
107 mv -f themes/README README.themes
108
109 rm -f po/stamp-po
110
111 %build
112 #%%{__libtoolize}
113 #%%{__gettextize}
114 #%%{__aclocal} -I m4
115 #%%{__autoconf}
116 #%%{__autoheader}
117 #%%{__automake}
118 %configure \
119         --%{?with_clamav:en}%{!?with_clamav:dis}able-clamav-plugin \
120         --%{?with_compface:en}%{!?with_compface:dis}able-compface \
121         --%{?with_dillo:en}%{!?with_dillo:dis}able-dillo-viewer-plugin \
122         --%{?with_gnomeprint:en}%{!?with_gnomeprint:dis}able-gnomeprint \
123         --%{?with_gpg:en}%{!?with_gpg:dis}able-pgpmime-plugin \
124         --%{?with_ipv6:en}%{!?with_ipv6:dis}able-ipv6 \
125         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
126         --%{?with_mathml:en}%{!?with_mathml:dis}able-mathml-viewer-plugin \
127         --%{?with_spamassassin:en}%{!?with_spamassassin:dis}able-spamassassin-plugin \
128         --%{?with_ssl:en}%{!?with_ssl:dis}able-openssl \
129         --%{?with_trayicon:en}%{!?with_trayicon:dis}able-trayicon-plugin \
130         --enable-aspell \
131         --enable-gdk-pixbuf \
132         --enable-pthread \
133         --disable-static \
134         --enable-libetpan \
135         --with-config-dir=.sylpheed
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
147 cp -a themes $RPM_BUILD_ROOT%{_datadir}/%{name}
148
149 install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
150
151 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog NEWS README* TODO
161 %{_mandir}/man1/%{name}.1*
162 %attr(755,root,root) %{_bindir}/*
163 %dir %{_datadir}/%{name}
164 %dir %{_datadir}/%{name}/manual
165 %{_datadir}/%{name}/manual/en
166 %lang(fr) %{_datadir}/%{name}/manual/fr
167 %lang(pl) %{_datadir}/%{name}/manual/pl
168 %{_desktopdir}/%{name}.desktop
169 %{_pixmapsdir}/%{name}.png
170
171 %files plugins
172 %defattr(644,root,root,755)
173 %dir %{_libdir}/%{name}
174 %dir %{_libdir}/%{name}/plugins
175 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
176
177 %files devel
178 %defattr(644,root,root,755)
179 %{_includedir}/%{name}
180 %{_pkgconfigdir}/*.pc
181
182 %files themes
183 %defattr(644,root,root,755)
184 %{_datadir}/%{name}/themes
This page took 0.027539 seconds and 2 git commands to generate.