]> git.pld-linux.org Git - packages/clapack.git/blob - clapack.spec
- adapterized.
[packages/clapack.git] / clapack.spec
1 Summary:        The CLAPACK libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne CLAPACK do algebry liniowej
3 Name:           clapack
4 Version:        3.0
5 Release:        1
6 License:        Freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/clapack/%{name}.tgz
9 #Source1:       http://www.netlib.org/clapack/manpages.tgz
10 Patch0:         %{name}-automake_support.patch
11 URL:            http://www.netlib.org/lapack/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  ed
15 BuildRequires:  gcc-g77
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Requires:       cblas
19
20 %description
21 CLAPACK (Linear Algebra PACKage) is a standard library for numerical
22 linear algebra. CLAPACK provides routines for solving systems of
23 simultaneous linear equations, least-squares solutions of linear
24 systems of equations, eigenvalue problems, and singular value
25 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
26 Schur, and generalized Schur) and related computations (i.e.,
27 reordering of Schur factorizations and estimating condition numbers)
28 are also included. CLAPACK can handle dense and banded matrices, but
29 not general sparse matrices. Similar functionality is provided for
30 real and complex matrices in both single and double precision. CLAPACK
31 is coded in Fortran77 and translated to C using f2c.
32
33 %description -l pl
34 CLAPACK (Linear Algebra PACKage) jest standardow± bibliotek±
35 numeryczn± do algebry liniowej. Dostarcza funkcje rozwi±zywania:
36 uk³adów równañ liniowych, uk³adów równañ metod± najmniejszych
37 kwadratów, problemów w³asnych. Zawiera algorytmy faktoryzacji macierzy
38 (LU, Cholesky'ego, QR, SVD, Schura, uogólnion± Schura) i zwi±zanych z
39 tym obliczeñ (np. przenumerowywanie w faktoryzacji Schura i estymacjê
40 uwarunkowania). CLAPACK mo¿e obs³ugiwaæ macierze blokowe i pasmowe,
41 ale nie rzadkie w ogólnym przypadku. Zapewnia funkcjonalno¶æ dla
42 macierzy rzeczywistych i zespolonych, dla liczb pojedynczej i
43 podwójnej precyzji. CLAPACK jest napisany w Fortranie 77 i
44 przetlumaczony na C przy u¿yciu f2c.
45
46 %package devel
47 Summary:        CLAPACK header files
48 Summary(pl):    Pliki nag³ówkowe CLAPACK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}
51
52 %description devel
53 CLAPACK header files.
54
55 %description devel -l pl
56 Pliki nag³ówkowe CLAPACK.
57
58 %package static
59 Summary:        Static CLAPACK libraries
60 Summary(pl):    Biblioteki statyczne CLAPACK
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}
63
64 %description static
65 Static CLAPACK libraries.
66
67 %description static -l pl
68 Biblioteki statyczne CLAPACK.
69
70 %package -n cblas
71 Summary:        The CBLAS (Basic Linear Algebra Subprograms) library for Linux
72 Summary(pl):    Biblioteka CBLAS (Basic Linear Algebra Subprograms) dla Linuksa
73 Group:          Development/Libraries
74
75 %description -n cblas
76 CBLAS (Basic Linear Algebra Subprograms) is a standard library for
77 numerical algebra. CBLAS provides a number of basic algorithms for
78 linear algebra. CBLAS is fast and well-tested, was written in FORTRAN
79 77.
80
81 %description -n cblas -l pl
82 CBLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
83 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
84 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
85 w Fortranie 77.
86
87 %package -n cblas-devel
88 Summary:        CBLAS header files
89 Summary(pl):    Pliki nag³ówkowe CBLAS
90 Group:          Development/Libraries
91 Requires:       blas = %{version}
92
93 %description -n cblas-devel
94 CBLAS header files.
95
96 %description -n cblas-devel -l pl
97 Pliki nag³ówkowe CBLAS.
98
99 %package -n cblas-static
100 Summary:        Static CBLAS libraries
101 Summary(pl):    Biblioteki statyczne CBLAS
102 Group:          Development/Libraries
103 Requires:       cblas-devel = %{version}
104
105 %description -n cblas-static
106 Static CBLAS libraries.
107
108 %description -n cblas-static -l pl
109 Biblioteki statyczne CBLAS.
110
111 %prep
112 %setup -q -n CLAPACK
113 %patch0 -p1
114 # directory INSTALL conflicts with file INSTALL needed by automake
115 mv -f INSTALL install
116 >INSTALL
117 >AUTHORS
118 >ChangeLog
119 >NEWS
120 >COPYING
121 #>config.h.in
122
123 %build
124 rm -f ltmain.sh
125 libtoolize --copy --force
126 aclocal
127 autoheader
128 automake --add-missing
129 autoconf
130 %configure
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 #workaround libtool
136 ed SRC/libclapack.la <<EOF
137 s/relink_command=.*/relink_command=''/
138 w
139 q
140 EOF
141 %{__make} install DESTDIR=$RPM_BUILD_ROOT
142
143 %clean
144 rm -fr $RPM_BUILD_ROOT
145
146 %post           -p /sbin/ldconfig
147 %postun         -p /sbin/ldconfig
148
149 %post   -n cblas -p /sbin/ldconfig
150 %postun -n cblas -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc README*
155 %attr(755,root,root) %{_libdir}/libclapack.so.*.*.*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %{_libdir}/libclapack.so
160 %{_includedir}/clapack.h
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libclapack.a
165
166 %files -n cblas
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libcblas.so.*.*.*
169
170 %files -n cblas-devel
171 %defattr(644,root,root,755)
172 %{_libdir}/libcblas.so
173
174 %files -n cblas-static
175 %defattr(644,root,root,755)
176 %{_libdir}/libcblas.a
This page took 0.044852 seconds and 3 git commands to generate.