]> git.pld-linux.org Git - packages/clapack.git/blob - clapack.spec
11a4a73faf71eeb41146d0cf4998fcb03c4c4965
[packages/clapack.git] / clapack.spec
1 Summary:        The CLAPACK libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne CLAPACK do algebry liniowej
3 Name:           clapack
4 Version:        3.0
5 Release:        3
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/clapack/%{name}.tgz
9 # Source0-md5:  1b6d89b3352d0c678e50a03724458053
10 #Source1:       http://www.netlib.org/clapack/manpages.tgz
11 Patch0:         %{name}-automake_support.patch
12 URL:            http://www.netlib.org/clapack/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gcc-g77
16 BuildRequires:  libtool >= 1:1.4.2-9
17 Requires:       cblas = %{version}-%{release}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 CLAPACK (Linear Algebra PACKage) is a standard library for numerical
22 linear algebra. CLAPACK provides routines for solving systems of
23 simultaneous linear equations, least-squares solutions of linear
24 systems of equations, eigenvalue problems, and singular value
25 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
26 Schur, and generalized Schur) and related computations (i.e.,
27 reordering of Schur factorizations and estimating condition numbers)
28 are also included. CLAPACK can handle dense and banded matrices, but
29 not general sparse matrices. Similar functionality is provided for
30 real and complex matrices in both single and double precision. CLAPACK
31 is coded in Fortran77 and translated to C using f2c.
32
33 %description -l pl
34 CLAPACK (Linear Algebra PACKage) jest standardow± bibliotek±
35 numeryczn± do algebry liniowej. Dostarcza funkcje rozwi±zywania:
36 uk³adów równañ liniowych, uk³adów równañ metod± najmniejszych
37 kwadratów, problemów w³asnych. Zawiera algorytmy faktoryzacji macierzy
38 (LU, Cholesky'ego, QR, SVD, Schura, uogólnion± Schura) i zwi±zanych z
39 tym obliczeñ (np. przenumerowanie w faktoryzacji Schura i estymacjê
40 uwarunkowania). CLAPACK mo¿e obs³ugiwaæ macierze blokowe i pasmowe,
41 ale nie rzadkie w ogólnym przypadku. Zapewnia funkcjonalno¶æ dla
42 macierzy rzeczywistych i zespolonych, dla liczb pojedynczej i
43 podwójnej precyzji. CLAPACK jest napisany w Fortranie 77 i
44 przet³umaczony na C przy u¿yciu f2c.
45
46 %package devel
47 Summary:        CLAPACK header files
48 Summary(pl):    Pliki nag³ówkowe CLAPACK
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 CLAPACK header files.
54
55 %description devel -l pl
56 Pliki nag³ówkowe CLAPACK.
57
58 %package static
59 Summary:        Static CLAPACK libraries
60 Summary(pl):    Biblioteki statyczne CLAPACK
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static CLAPACK libraries.
66
67 %description static -l pl
68 Biblioteki statyczne CLAPACK.
69
70 %package -n cblas
71 Summary:        The CBLAS (Basic Linear Algebra Subprograms) library for Linux
72 Summary(pl):    Biblioteka CBLAS (Basic Linear Algebra Subprograms) dla Linuksa
73 Group:          Development/Libraries
74
75 %description -n cblas
76 CBLAS (Basic Linear Algebra Subprograms) is a standard library for
77 numerical algebra. CBLAS provides a number of basic algorithms for
78 linear algebra. CBLAS is fast and well-tested, was written in FORTRAN
79 77.
80
81 %description -n cblas -l pl
82 CBLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
83 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
84 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
85 w Fortranie 77.
86
87 %package -n cblas-devel
88 Summary:        CBLAS header files
89 Summary(pl):    Pliki nag³ówkowe CBLAS
90 Group:          Development/Libraries
91 Requires:       cblas = %{version}-%{release}
92
93 %description -n cblas-devel
94 CBLAS header files.
95
96 %description -n cblas-devel -l pl
97 Pliki nag³ówkowe CBLAS.
98
99 %package -n cblas-static
100 Summary:        Static CBLAS libraries
101 Summary(pl):    Biblioteki statyczne CBLAS
102 Group:          Development/Libraries
103 Requires:       cblas-devel = %{version}-%{release}
104
105 %description -n cblas-static
106 Static CBLAS libraries.
107
108 %description -n cblas-static -l pl
109 Biblioteki statyczne CBLAS.
110
111 %prep
112 %setup -q -n CLAPACK
113 %patch0 -p1
114 # directory INSTALL conflicts with file INSTALL needed by automake
115 mv -f INSTALL install
116
117 %build
118 rm -f ltmain.sh missing
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoheader}
122 %{__automake}
123 %{__autoconf}
124 %configure
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install BLAS/WRAP/cblas.h $RPM_BUILD_ROOT%{_includedir}
134
135 %clean
136 rm -fr $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %post   -n cblas -p /sbin/ldconfig
142 %postun -n cblas -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc README*
147 %attr(755,root,root) %{_libdir}/libclapack.so.*.*.*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %{_libdir}/libclapack.so
152 %{_libdir}/libclapack.la
153 %{_includedir}/clapack.h
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libclapack.a
158
159 %files -n cblas
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libcblas.so.*.*.*
162
163 %files -n cblas-devel
164 %defattr(644,root,root,755)
165 %{_libdir}/libcblas.so
166 %{_libdir}/libcblas.la
167 %{_includedir}/cblas.h
168
169 %files -n cblas-static
170 %defattr(644,root,root,755)
171 %{_libdir}/libcblas.a
This page took 0.061938 seconds and 2 git commands to generate.