]> git.pld-linux.org Git - packages/clamav.git/commitdiff
Up to 1.1.0. auto/th/clamav-1.1.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 May 2023 20:41:13 +0000 (22:41 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 May 2023 20:41:13 +0000 (22:41 +0200)
clamav.spec
x32.patch [deleted file]

index 85f091685230f4d475ba9c8e1b7c19b44e54f675..fb8ac53ebec50fe28bf7114981882f12d73559e3 100644 (file)
 Summary:       An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
-Version:       1.0.1
+Version:       1.1.0
 Release:       1
 License:       GPL v2+
 Group:         Daemons
 #Source0Download: http://www.clamav.net/download
 Source0:       http://www.clamav.net/downloads/production/%{name}-%{version}.tar.gz
-# Source0-md5: a04c129b15af305c2af7d3573f134a73
+# Source0-md5: a04158b89b2142b9f5527500988a79bd
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}-milter.init
@@ -42,7 +42,6 @@ Source11:     clamd.service
 Source12:      cronjob-clamav.timer
 Source13:      cronjob-clamav.service.in
 Patch0:                %{name}-pld_config.patch
-Patch4:                x32.patch
 URL:           http://www.clamav.net/
 BuildRequires: bzip2-devel >= 1.0.5
 BuildRequires: cargo
@@ -222,8 +221,6 @@ Dokumentacja do ClamAVa.
 %setup -q
 %patch0 -p1
 
-%patch4 -p1
-
 %build
 install -d build
 cd build
@@ -437,17 +434,17 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libclamav.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamav.so.11
+%attr(755,root,root) %ghost %{_libdir}/libclamav.so.12
 %if %{without system_libmspack}
 %attr(755,root,root) %{_libdir}/libclammspack.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libclammspack.so.0
 %endif
 %attr(755,root,root) %{_libdir}/libclamunrar.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.11
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.12
 %attr(755,root,root) %{_libdir}/libclamunrar_iface.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.11
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.12
 %attr(755,root,root) %{_libdir}/libfreshclam.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libfreshclam.so.2
+%attr(755,root,root) %ghost %{_libdir}/libfreshclam.so.3
 
 %files devel
 %defattr(644,root,root,755)
diff --git a/x32.patch b/x32.patch
deleted file mode 100644 (file)
index 78df1ad..0000000
--- a/x32.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- clamav-0.100.1/libclamav/bytecode_vm.c~    2018-06-27 21:12:10.000000000 +0200
-+++ clamav-0.100.1/libclamav/bytecode_vm.c     2018-07-26 10:48:10.316153596 +0200
-@@ -1248,7 +1248,11 @@ int cli_vm_execute(const struct cli_bc *
-         gettimeofday(&tv1, NULL);
-         tv1.tv_sec -= tv0.tv_sec;
-         tv1.tv_usec -= tv0.tv_usec;
-+#ifdef __ILP32__
-+        cli_dbgmsg("intepreter bytecode run finished in %lluus, after executing %u opcodes\n",
-+#else
-         cli_dbgmsg("interpreter bytecode run finished in %luus, after executing %u opcodes\n",
-+#endif
-                    tv1.tv_sec * 1000000 + tv1.tv_usec, pc);
-     }
-     if (stop == CL_EBYTECODE) {
---- clamav-0.104.1/libclamav/tomsfastmath/headers/tfm.h.orig   2021-11-02 20:09:25.000000000 +0100
-+++ clamav-0.104.1/libclamav/tomsfastmath/headers/tfm.h        2021-12-11 10:43:55.832213985 +0100
-@@ -118,7 +118,7 @@
- #endif
- /* autodetect x86-64 and make sure we are using 64-bit digits with x86-64 asm */
--#if defined(__x86_64__)
-+#if defined(__x86_64__) && !defined(__ILP32__)
-    #if defined(TFM_X86) || defined(TFM_SSE2) || defined(TFM_ARM)
-        #error x86-64 detected, x86-32/SSE2/ARM optimizations are not valid!
-    #endif
-@@ -133,7 +133,7 @@
- #endif
- /* try to detect x86-32 */
--#if defined(__i386__) && !defined(TFM_SSE2)
-+#if (defined(__i386__) || defined(__ILP32__)) && !defined(TFM_SSE2)
-    #if defined(TFM_X86_64) || defined(TFM_ARM)
-        #error x86-32 detected, x86-64/ARM optimizations are not valid!
-    #endif
---- clamav-0.104.1/libclamav/tomsfastmath/mont/fp_montgomery_reduce.c.orig     2021-12-11 10:41:02.011008906 +0100
-+++ clamav-0.104.1/libclamav/tomsfastmath/mont/fp_montgomery_reduce.c  2021-12-11 10:41:23.713556450 +0100
-@@ -42,7 +42,7 @@ asm(
- : "%eax", "cc")
- /******************************************************************/
--#elif defined(TFM_X86_64)
-+#elif defined(TFM_X86_64) && !defined(__ILP32__)
- /* x86-64 code */
- #define MONT_START
-
This page took 0.208687 seconds and 4 git commands to generate.