]> git.pld-linux.org Git - packages/clamav.git/blobdiff - clamav.spec
- fixed Group
[packages/clamav.git] / clamav.spec
index 7f4d9e473ba1f18fabe3ef5045cd7f7454f4bd92..452b83f59ecc21fa5b96e4083148084f3bb9848a 100644 (file)
@@ -1,20 +1,20 @@
 # TODO:
 # - Make freshclam package (script and daemon)
+# - restart amavis in triggers if group membership was modified?
 #
 # Conditional build:
 %bcond_without milter          # build without milter subpackage
-%bcond_with    curl            # enable curl support
 #
 Summary:       An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
-Version:       0.91.1
+Version:       0.96.1
 Release:       1
 Epoch:         0
-License:       GPL
-Group:         Applications
-Source0:       http://dl.sourceforge.net/clamav/%{name}-%{version}.tar.gz
-# Source0-md5: 60152bf1e24b3fbdf0473794199e5215
+License:       GPL v2+
+Group:         Daemons
+Source0:       http://downloads.sourceforge.net/clamav/0.96rc1/%{name}-%{version}.tar.gz
+# Source0-md5: 38e7870db6e9ad0e569518499a6f3651
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}-milter.init
@@ -23,20 +23,20 @@ Source5:    %{name}.logrotate
 Source8:       %{name}-post-updatedb
 Source9:       %{name}-milter.sysconfig
 Patch0:                %{name}-pld_config.patch
-Patch1:                %{name}-no_auto_libwrap.patch
-Patch2:                %{name}-nolibs.patch
-Patch3:                %{name}-find_milter.patch
-Patch4:                %{name}-valid_pp_exp.patch
+Patch1:                %{name}-nolibs.patch
+Patch2:                am-nosilentrules.patch
 URL:           http://www.clamav.net/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
-%{?with_curl:BuildRequires:    curl-devel}
 BuildRequires: gmp-devel
+BuildRequires: libltdl-devel
 %{?with_milter:BuildRequires:  libmilter-devel}
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
 %{?with_milter:BuildRequires:  libwrap-devel}
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: ncurses-devel
+BuildRequires: rpmbuild(macros) >= 1.514
 BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -49,18 +49,38 @@ Requires(pre):      /usr/sbin/useradd
 Requires(triggerpostun):       sed >= 4.0
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      /usr/sbin/usermod
-Requires:      bc
-Requires:      rc-scripts
+Requires:      rc-scripts >= 0.4.1.23
 Provides:      group(clamav)
 Provides:      user(clamav)
+Conflicts:     logrotate < 3.7-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
-AMaViS, compressed files, on-access scanning and includes a program
-for auto-updating with support for digital signatures. The virus
-database has over 90000 viruses, worms and trojans signatures. The
-scanner is multithreaded, written in C, and POSIX compliant.
+Clam AntiVirus is an open source anti-virus toolkit for UNIX, designed
+especially for e-mail scanning on mail gateways. It provides a number
+of utilities including a flexible and scalable multi-threaded daemon,
+a command line scanner and advanced tool for automatic database
+updates. The core of the package is an anti-virus engine available in
+a form of shared library.
+
+Here is a list of the main features:
+- command-line scanner
+- fast, multi-threaded daemon with support for on-access scanning
+- milter interface for sendmail
+- advanced database updater with support for scripted updates and
+  digital signatures
+- virus scanner C library
+- on-access scanning (Linux® and FreeBSD®)
+- virus database updated multiple times per day (see home page for
+  total number of signatures)
+- built-in support for various archive formats, including Zip, RAR,
+  Tar, Gzip, Bzip2, OLE2, Cabinet, CHM, BinHex, SIS and others
+- built-in support for almost all mail file formats
+- built-in support for ELF executables and Portable Executable files
+  compressed with UPX, FSG, Petite, NsPack, wwpack32, MEW, Upack and
+  obfuscated with SUE, Y0da Cryptor and others
+- built-in support for popular document formats including MS Office
+  and MacOffice files, HTML, RTF and PDF
 
 %description -l pl.UTF-8
 Clam Antivirus jest potężnym skanerem antywirusowym dla systemów
@@ -85,7 +105,11 @@ Summary:    ClamAV filter using milter interface
 Summary(pl.UTF-8):     Filtr ClamAV korzystający z interfejsu milter
 Group:         Daemons
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+%if "%{pld_release}" == "ti"
+Requires:      postfix
+%else
 Requires:      sendmail >= 8.11
+%endif
 Requires:      tcp_wrappers
 
 %description milter
@@ -124,25 +148,27 @@ clamav static libraries.
 Biblioteki statyczne clamav.
 
 %prep
-%setup -q %{?_rc:-n %{name}-%{version}%{_rc}}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p0
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
        --disable-clamav \
-       %{!?with_curl:--without-libcurl} \
        %{?with_milter:--enable-milter} \
-       --with-dbdir=/var/lib/%{name}
-%{__make}
+       --with-dbdir=/var/lib/%{name} \
+       --with-no-cache \
+       --with-ltdl-include=/usr/include \
+       --with-ltdl-lib=%{_libdir}
+
+%{__make} \
+       LIBTOOL=/usr/bin/libtool
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -150,6 +176,7 @@ install -d $RPM_BUILD_ROOT/etc/{cron.d,logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT%{_var}/{log,spool/clamav}
 
 %{__make} install \
+       LIBTOOL=/usr/bin/libtool \
        DESTDIR=$RPM_BUILD_ROOT
 %{!?with_milter:rm -f $RPM_BUILD_ROOT%{_mandir}/man8/clamav-milter.8*}
 
@@ -180,40 +207,18 @@ install -d $RPM_BUILD_ROOT/var/run/%{name}
 rm -rf $RPM_BUILD_ROOT
 
 %triggerin -- amavis-ng
-AMAVIS=$(/usr/bin/getgid amavis)
-RESULT=$?
-if [ $RESULT -eq 0 ]; then
-       echo "Adding clamav to amavis group GID=$AMAVIS"
-       /usr/sbin/usermod -G amavis clamav 1>&2 > /dev/null
-fi
+%addusertogroup -q clamav amavis
 
 %triggerin -- amavisd-new
-AMAVIS=$(/usr/bin/getgid amavis)
-RESULT=$?
-if [ $RESULT -eq 0 ]; then
-       echo "Adding clamav to amavis group GID=$AMAVIS"
-       /usr/sbin/usermod -G amavis clamav 1>&2 > /dev/null
-fi
+%addusertogroup -q clamav amavis
 
 %triggerin -- amavisd
-AMAVIS=$(/usr/bin/getgid amavis)
-RESULT=$?
-if [ $RESULT -eq 0 ]; then
-       echo "Adding clamav to amavis group GID=$AMAVIS"
-       /usr/sbin/usermod -G amavis clamav 1>&2
-fi
+%addusertogroup -q clamav amavis
 
 %pre
 %groupadd -g 43 clamav
 %useradd -u 43 -d /tmp -s /bin/false -c "Clam Anti Virus Checker" -g clamav clamav
 
-# FIXME: check this. is it proper after useradd macro?
-# TODO: use addusertogroup macro?
-if [ -n "`/usr/bin/getgid amavis`" ]; then
-       echo "Adding clamav to amavis group"
-       /usr/sbin/usermod -G amavis clamav 1>&2
-fi
-
 %post
 /sbin/chkconfig --add clamd
 %service clamd restart "Clam Antivirus daemon"
@@ -233,7 +238,7 @@ if [ "$1" = "0" ]; then
        %groupremove clamav
 fi
 
-%triggerpostun -- %{name} <= 0.75.1
+%triggerpostun -- %{name} < 0.80
 if [ -f /etc/clamav.conf.rpmsave ]; then
        echo "Renaming config to new name /etc/clamd.conf"
        mv -f /etc/clamd.conf /etc/clamd.conf.rpmnew
@@ -280,7 +285,9 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog FAQ NEWS README docs/*.pdf
+%attr(755,root,root) %{_bindir}/clambc
 %attr(755,root,root) %{_bindir}/clamdscan
+%attr(755,root,root) %{_bindir}/clamdtop
 %attr(755,root,root) %{_bindir}/clamscan
 %attr(755,root,root) %{_bindir}/freshclam
 %attr(755,root,root) %{_bindir}/sigtool
@@ -289,7 +296,7 @@ fi
 %attr(755,root,root) %{_sbindir}/clamav-cron-updatedb
 %attr(755,root,root) %{_sbindir}/clamav-post-updatedb
 %attr(755,clamav,root) %dir /var/lib/%{name}
-%ghost %attr(644,clamav,root) %verify(not md5 mtime size) /var/lib/clamav/*.cvd
+%attr(644,clamav,root) %ghost %verify(not md5 mtime size) /var/lib/clamav/*.cvd
 %attr(640,clamav,root) %ghost /var/log/freshclam.log
 %attr(750,clamav,clamav) %dir /var/run/%{name}
 
@@ -307,6 +314,7 @@ fi
 %files milter
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clamav-milter
+%config(noreplace) %verify(not md5 mtime size) /etc/clamav-milter.conf
 %attr(754,root,root) /etc/rc.d/init.d/clamav-milter
 #%attr(755,root,root) %{_sysconfdir}/cron.daily/clamav-milter
 #%attr(755,root,root) %{_sysconfdir}/log.d/scripts/services/clamav-milter
@@ -319,6 +327,9 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libclamav.so.6
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.6
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.6
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.051795 seconds and 4 git commands to generate.