]> git.pld-linux.org Git - packages/clamav.git/blobdiff - clamav.spec
- revert SOURCE0 url
[packages/clamav.git] / clamav.spec
index b494a6bf707733c0a6f46ce52c2ddf93dfa9e7ad..17c036a68ee9650d38a2ce214ff9d57ac4371d98 100644 (file)
@@ -2,28 +2,30 @@
 #   Make freshclam (script and daemon)
 #
 # Conditional build:
-%bcond_with    milter  # without milter subpackage
+%bcond_with    milter  # build milter subpackage
+%bcond_with    curl    # enable curl support
 #
 Summary:       An anti-virus utility for Unix
 Summary(pl):   Antywirusowe narzêdzie dla Uniksów
 Name:          clamav
-Version:       0.75.1
-Release:       3
+Version:       0.85.1
+Release:       1
+Epoch:         0
 License:       GPL
 Group:         Applications
 Source0:       http://dl.sourceforge.net/clamav/%{name}-%{version}.tar.gz
-# Source0-md5: 2c85b7957eba9fd9e9ff8c2537ae006f
+# Source0-md5: b0675c3273785d61eefc1afa304745c0
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}-milter.init
 Source4:       %{name}-cron-updatedb
 Source5:       %{name}.logrotate
 # Remember to update date after databases upgrade
-%define                database_version        20040731
-Source6:       http://www.clamav.net/database/daily.cvd
-# Source6-md5: 8aa799fff39b3dd7c36a7dd796890b66
-Source7:       http://www.clamav.net/database/main.cvd
-# Source7-md5: fb569320447dff5b22acdbec2dbc5772
+%define                database_version        20050517
+Source6:       http://db.local.clamav.net/daily.cvd
+# Source6-md5: 8164332a039b31ed17cbda4408bd9b5c
+Source7:       http://db.local.clamav.net/main.cvd
+# Source7-md5: 8771a3301a0781d7897b98e435df26f3
 Source8:       %{name}-post-updatedb
 Source9:       %{name}-milter.sysconfig
 Patch0:                %{name}-pld_config.patch
@@ -32,28 +34,41 @@ Patch2:             %{name}-nolibs.patch
 URL:           http://www.clamav.net/
 BuildRequires: autoconf
 BuildRequires: automake
+%{?with_curl:BuildRequires:    curl-devel}
 BuildRequires: gmp-devel
 %{?with_milter:BuildRequires:  libwrap-devel}
 BuildRequires: libtool
+#BuildRequires:        rpmbuild(macros) >= 1.159
 %{?with_milter:BuildRequires:  sendmail-devel >= 8.11}
 BuildRequires: zlib-devel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(postun):      sed >= 4.0
+Requires(postun,pre):  /usr/sbin/usermod
 Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      /usr/sbin/usermod
+Requires:      %{name}-libs = %{epoch}%{version}-%{release}
 Requires:      bc
+Provides:      group(clamav)
+Provides:      user(clamav)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
 AMaViS, compressed files, on-access scanning and includes a program
 for auto-updating with support for digital signatures. The virus
-database has over 20000 viruses, worms and trojans signatures. The
+database has over 25000 viruses, worms and trojans signatures. The
 scanner is multithreaded, written in C, and POSIX compliant.
 
 %description -l pl
 Clam Antivirus jest potê¿nym skanerem antywirusowym dla systemów
 uniksowych. Wspiera on AMaViSa, skompresowane pliki, skanowanie
 "on-access" i posiada system bezpiecznej, automatycznej aktualizacji.
-Baza wirusów zawiera ponad 20000 sygnatur. Skaner jest wielow±tkowy,
+Baza wirusów zawiera ponad 25000 sygnatur. Skaner jest wielow±tkowy,
 napisany w C i zgodny z POSIXem.
 
 %package libs
@@ -85,7 +100,7 @@ Filtr ClamAV dla sendmaila korzystaj
 Summary:       clamav - Development header files and libraries
 Summary(pl):   clamav - Pliki nag³ówkowe i biblioteki dla programistów
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      bzip2-devel
 Requires:      gmp-devel
 Requires:      zlib-devel
@@ -102,7 +117,7 @@ klienckich clamav.
 Summary:       clamav static libraris
 Summary(pl):   Biblioteki statyczne clamav
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 clamav static libraries.
@@ -131,7 +146,7 @@ Bazy wirus
 
 # kill old libtool.m4 copy
 head -n 489 acinclude.m4 > acinclude.m4.tmp
-tail -n +4064 acinclude.m4 >> acinclude.m4.tmp
+tail -n +4089 acinclude.m4 >> acinclude.m4.tmp
 mv -f acinclude.m4.tmp acinclude.m4
 
 %build
@@ -142,6 +157,7 @@ mv -f acinclude.m4.tmp acinclude.m4
 %{__automake}
 %configure \
        --disable-clamav \
+       %{!?with_curl:--without-libcurl} \
        %{?with_milter:--enable-milter} \
        --with-dbdir=/var/lib/%{name}
 %{__make}
@@ -202,28 +218,33 @@ fi
 AMAVIS=$(/usr/bin/getgid amavis)
 RESULT=$?
 if [ $RESULT -eq 0 ]; then
-       /usr/sbin/usermod -G amavis clamav 1>&2 > /dev/null
        echo "adding clamav to amavis group GID=$AMAVIS"
+       /usr/sbin/usermod -G amavis clamav 1>&2
 fi
 
 %pre
-if [ -n "`getgid clamav`" ]; then
-       if [ "`getgid clamav`" != "43" ]; then
+if [ -n "`/usr/bin/getgid clamav`" ]; then
+       if [ "`/usr/bin/getgid clamav`" != 43 ]; then
                echo "Warning: group clamav doesn't have gid=43. Correct this before installing clamav" 1>&2
                exit 1
        fi
 else
        echo "Adding group clamav GID=43"
-       /usr/sbin/groupadd -g 43 -r -f clamav
+       /usr/sbin/groupadd -g 43 clamav
 fi
-if [ -n "`id -u clamav 2>/dev/null`" ]; then
-       if [ "`id -u clamav`" != "43" ]; then
+if [ -n "`/bin/id -u clamav 2>/dev/null`" ]; then
+       if [ "`/bin/id -u clamav`" != 43 ]; then
                echo "Warning: user clamav doesn't have uid=43. Correct this before installing clamav" 1>&2
                exit 1
        fi
 else
        echo "Adding user clamav UID=43"
-       /usr/sbin/useradd -u 43 -r -d /tmp -s /bin/false -c "Clam Anti Virus Checker" -g clamav clamav 1>&2
+       /usr/sbin/useradd -u 43 -d /tmp -s /bin/false \
+               -c "Clam Anti Virus Checker" -g clamav clamav 1>&2
+       if [ -n "`/usr/bin/getgid amavis`" ]; then
+               echo "adding clamav to amavis group"
+               /usr/sbin/usermod -G amavis clamav 1>&2
+       fi
 fi
 
 %post
@@ -253,6 +274,15 @@ if [ "$1" = "0" ]; then
        /usr/sbin/groupdel clamav
 fi
 
+%triggerpostun -- %{name} <= 0.75.1
+if [ -f /etc/clamav.conf.rpmsave ]; then
+       echo "Renaming config to new name /etc/clamd.conf"
+       mv -f /etc/clamd.conf /etc/clamd.conf.rpmnew
+       mv -f /etc/clamav.conf.rpmsave /etc/clamd.conf
+       echo "Changing config location in freshclam config"
+       sed -i -e 's/clamav.conf/clamd.conf/' /etc/freshclam.conf
+fi
+
 %if %{with milter}
 %post milter
 /sbin/chkconfig --add clamav-milter
@@ -277,15 +307,19 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog FAQ NEWS README TODO docs/html/
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_sbindir}/*
+%doc AUTHORS ChangeLog FAQ NEWS README TODO docs/*.pdf docs/html/
+%attr(755,root,root) %{_bindir}/clamdscan
+%attr(755,root,root) %{_bindir}/clamscan
+%attr(755,root,root) %{_bindir}/freshclam
+%attr(755,root,root) %{_bindir}/sigtool
+%attr(755,root,root) %{_sbindir}/clamd
+%attr(755,root,root) %{_sbindir}/clamav-cron-updatedb
 %attr(755,clamav,root) %dir /var/lib/%{name}
 %attr(640,clamav,root) %ghost %{_var}/log/freshclam.log
 %attr(750,clamav,clamav) %dir %{_var}/run/%{name}
 
 %attr(640,root,root) %{_sysconfdir}/cron.d/%{name}
-%attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/clamav.conf
+%attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/clamd.conf
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/freshclam.conf
 
 %attr(754,root,root) /etc/rc.d/init.d/clamd
@@ -313,6 +347,7 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/clamav-config
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/*.h
@@ -324,4 +359,5 @@ fi
 
 %files database
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/clamav-post-updatedb
 %attr(644,clamav,root) %verify(not md5 size mtime) /var/lib/%{name}/*.cvd
This page took 0.08119 seconds and 4 git commands to generate.