]> git.pld-linux.org Git - packages/clamav.git/blobdiff - clamav.spec
correct epoch
[packages/clamav.git] / clamav.spec
index 4e42d37df98294dc61fccd7a72d7d1da7d63d814..0140c4502167d9de51b0fadfee897641da80dd72 100644 (file)
@@ -3,22 +3,28 @@
 # - restart amavis in triggers if group membership was modified?
 #
 # Conditional build:
-%bcond_without milter          # build without milter subpackage
+%bcond_without milter          # milter interface subpackage
 %if "%{pld_release}" == "ac"
-%bcond_with            llvm            # build without llvm support
+%bcond_with    llvm            # LLVM support
 %else
-%bcond_without llvm            # build without llvm support
+%bcond_without llvm            # LLVM support
 %endif
 
+%ifarch x32
+%undefine with_llvm
+%endif
+
+%bcond_with    system_llvm
+
 Summary:       An anti-virus utility for Unix
 Summary(pl.UTF-8):     Narzędzie antywirusowe dla Uniksów
 Name:          clamav
-Version:       0.97.6
-Release:       3
+Version:       0.99.1
+Release:       1
 License:       GPL v2+
 Group:         Daemons
 Source0:       http://downloads.sourceforge.net/clamav/%{name}-%{version}.tar.gz
-# Source0-md5: 1dbdd803b37c0d9d222e4316049f46a2
+# Source0-md5: cf1f3cbe62a08c9165801f79239166ff
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}-milter.init
@@ -27,24 +33,32 @@ Source5:    %{name}.logrotate
 Source8:       %{name}-post-updatedb
 Source9:       %{name}-milter.sysconfig
 Source10:      %{name}.tmpfiles
+Source11:      clamd.service
 Patch0:                %{name}-pld_config.patch
 Patch1:                %{name}-nolibs.patch
+%if "%{pld_release}" == "ac"
 Patch2:                am-nosilentrules.patch
+%endif
 Patch3:                ac2.68.patch
+Patch4:                %{name}-openssl.patch
+Patch5:                %{name}-major.patch
+Patch6:                x32.patch
 URL:           http://www.clamav.net/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
+BuildRequires: curl-devel
 BuildRequires: gmp-devel
 BuildRequires: libltdl-devel
 %{?with_milter:BuildRequires:  libmilter-devel}
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 5:3.4
 BuildRequires: libtool
 %{?with_milter:BuildRequires:  libwrap-devel}
-%{?with_llvm:BuildRequires:    llvm-devel}
+%{?with_llvm:%{?with_system_llvm:BuildRequires:        llvm-devel < 3.7}}
 BuildRequires: ncurses-devel
+BuildRequires: openssl-devel
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.514
+BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -54,11 +68,14 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      systemd-units >= 38
 Requires(triggerpostun):       sed >= 4.0
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      /usr/sbin/usermod
 Requires:      rc-scripts >= 0.4.1.23
 Suggests:      clamav-database
+Suggests:      crondaemon
 Provides:      group(clamav)
 Provides:      user(clamav)
 Conflicts:     logrotate < 3.7-4
@@ -130,7 +147,9 @@ Summary(pl.UTF-8):  clamav - Pliki nagłówkowe i biblioteki dla programistów
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      bzip2-devel
+Requires:      curl-devel
 Requires:      gmp-devel
+Requires:      openssl-devel
 Requires:      zlib-devel
 
 %description devel
@@ -157,19 +176,27 @@ Biblioteki statyczne clamav.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%if "%{pld_release}" == "ac"
 %patch2 -p1
+%endif
+%if "%{pld_release}" != "ac"
 %patch3 -p1
+%endif
+#%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %build
-# automake 1.12+ needs configure.ac not .in
-mv configure.{in,ac}
 %{__libtoolize}
 %{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
+       --disable-silent-rules \
        --disable-clamav \
+       --enable-clamdtop \
+       %{?with_llvm:--enable-llvm %{?with_system_llvm:--with-system-llvm}} \
        %{?with_milter:--enable-milter} \
        --with-dbdir=/var/lib/%{name} \
        --with-no-cache \
@@ -183,7 +210,8 @@ mv configure.{in,ac}
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{cron.d,logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT%{_var}/{log,spool/clamav,lib/clamav} \
-       $RPM_BUILD_ROOT%{systemdtmpfilesdir}
+       $RPM_BUILD_ROOT%{systemdtmpfilesdir} \
+       $RPM_BUILD_ROOT%{systemdunitdir}
 
 %{__make} install \
        LIBTOOL=%{_bindir}/libtool \
@@ -201,15 +229,16 @@ cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/clamav-milter
 %endif
 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/clamd
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sbindir}/clamav-cron-updatedb
-cp -p etc/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
+for i in $RPM_BUILD_ROOT%{_sysconfdir}/*.conf.sample; do
+       mv $i ${i%%.sample}
+done
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 install -p %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}
 
-install %{SOURCE10} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
+cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
-# Not packaged/installed anymore, but we want it ghosted
-touch $RPM_BUILD_ROOT/var/lib/clamav/{daily,main}.cvd
+cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 
 # NOTE: clamd uses sane rights to it's clamd.pid file
 # So better keep it dir
@@ -240,18 +269,21 @@ rm -rf $RPM_BUILD_ROOT
 touch /var/log/freshclam.log
 chown clamav:root /var/log/freshclam.log
 chmod 640 /var/log/freshclam.log
+%systemd_post clamd.service
 
 %preun
 if [ "$1" = "0" ]; then
        %service clamd stop
        /sbin/chkconfig --del clamd
 fi
+%systemd_preun clamd.service
 
 %postun
 if [ "$1" = "0" ]; then
        %userremove clamav
        %groupremove clamav
 fi
+%systemd_reload
 
 %triggerpostun -- %{name} < 0.80
 if [ -f /etc/clamav.conf.rpmsave ]; then
@@ -284,6 +316,9 @@ EOF
 touch /var/lock/subsys/clamd
 %service -q clamd restart
 
+%triggerpostun -- %{name} < 0.97.7-4
+%systemd_trigger clamd.service
+
 %post milter
 /sbin/chkconfig --add clamav-milter
 %service clamav-milter restart "Clam Antivirus daemon"
@@ -304,6 +339,7 @@ fi
 %attr(755,root,root) %{_bindir}/clamdscan
 %attr(755,root,root) %{_bindir}/clamdtop
 %attr(755,root,root) %{_bindir}/clamscan
+%attr(755,root,root) %{_bindir}/clamsubmit
 %attr(755,root,root) %{_bindir}/freshclam
 %attr(755,root,root) %{_bindir}/sigtool
 %attr(755,root,root) %{_bindir}/clamconf
@@ -311,8 +347,8 @@ fi
 %attr(755,root,root) %{_sbindir}/clamav-cron-updatedb
 %attr(755,root,root) %{_sbindir}/clamav-post-updatedb
 %{systemdtmpfilesdir}/%{name}.conf
+%{systemdunitdir}/clamd.service
 %attr(755,clamav,root) %dir /var/lib/%{name}
-%attr(644,clamav,root) %ghost %verify(not md5 mtime size) /var/lib/clamav/*.cvd
 %attr(640,clamav,root) %ghost /var/log/freshclam.log
 %attr(750,clamav,clamav) %dir /var/run/%{name}
 
@@ -342,19 +378,27 @@ fi
 
 %files libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libclamav.so.6
-%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.6
-%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.6
+%attr(755,root,root) %{_libdir}/libclamav.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libclamav.so.7
+%attr(755,root,root) %{_libdir}/libclamunrar.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.7
+%attr(755,root,root) %{_libdir}/libclamunrar_iface.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.7
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/clamav-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/*.h
-%{_pkgconfigdir}/*.pc
+%attr(755,root,root) %{_libdir}/libclamav.so
+%attr(755,root,root) %{_libdir}/libclamunrar.so
+%attr(755,root,root) %{_libdir}/libclamunrar_iface.so
+%{_libdir}/libclamav.la
+%{_libdir}/libclamunrar.la
+%{_libdir}/libclamunrar_iface.la
+%{_includedir}/clamav.h
+%{_pkgconfigdir}/libclamav.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libclamav.a
+%{_libdir}/libclamunrar.a
+%{_libdir}/libclamunrar_iface.a
This page took 0.15387 seconds and 4 git commands to generate.