]> git.pld-linux.org Git - packages/ckeditor.git/blame - ckeditor.spec
- release 4 (by relup.sh)
[packages/ckeditor.git] / ckeditor.spec
CommitLineData
d19573b0 1# TODO
538747fe 2# - separate packages for plugins?
0562beca 3# - uicolor for example bundles yui framework (30% of the whole plugins dir)
d19573b0
ER
4Summary: The text editor for Internet
5Summary(pl.UTF-8): Edytor tekstowy dla Internetu
6Name: ckeditor
20fe3b1a 7Version: 3.2.1
a4200b93 8Release: 4
0562beca 9License: LGPL v2.1+ / GPL v2+ / MPL
d19573b0
ER
10Group: Applications/WWW
11Source0: http://download.cksource.com/CKEditor/CKEditor/CKEditor%20%{version}/%{name}_%{version}.tar.gz
20fe3b1a 12# Source0-md5: 793ad3d32b15f88b71db72573710a926
d19573b0
ER
13URL: http://www.ckeditor.com/
14Source1: find-lang.sh
0562beca
ER
15Source2: apache.conf
16Source3: lighttpd.conf
17BuildRequires: lynx
12e60af2 18BuildRequires: rpmbuild(macros) >= 1.268
d19573b0 19BuildRequires: sed >= 4.0
3913c22e
ER
20Requires: webapps
21Requires: webserver
d19573b0
ER
22Requires: webserver(access)
23Requires: webserver(alias)
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define _webapps /etc/webapps
28%define _webapp %{name}
29%define _sysconfdir %{_webapps}/%{_webapp}
30%define _appdir %{_datadir}/%{name}
31
32%define find_lang sh %{SOURCE1}
33
34%description
35This HTML text editor brings to the web many of the powerful
36functionalities of desktop editors like MS Word. It's lightweight and
37doesn't require any kind of installation on the client computer.
38
39%description -l pl.UTF-8
40Ten edytor tekstu HTML udostępnia stronom WWW wiele potężnych funkcji
41edytorów biurowych, takich jak MS Word. Jest lekki i nie wymaga żadnej
42inicjalizacji na komputerze klienckim.
43
0562beca
ER
44%package -n php-%{name}
45Summary: PHP class to create editors instances
46Group: Development/Languages/PHP
47
48%description -n php-%{name}
49CKEditor class that can be used to create editor instances in PHP
50pages on server side.
51
d19573b0
ER
52%prep
53%setup -qc
54mkdir config
55mv ckeditor/* .
56mv ckeditor/.htaccess config/htaccess
57rmdir ckeditor
d19573b0
ER
58
59# force php5 only
60rm ckeditor_php4.php
61mv ckeditor_php5.php ckeditor.php
62
20fe3b1a
ER
63# collect source for reference
64mv *_source.js _source
d19573b0
ER
65
66rm lang/_translationstatus.txt
67
0562beca
ER
68# used only in samples
69mv lang/_languages.js _samples
70%{__sed} -i -e 's,\.\./lang/_languages\.js,_languages.js,' _samples/ui_languages.html
71
d19573b0
ER
72# undos the files
73%{__sed} -i -e 's,\r$,,' ckeditor*
74find '(' -name '*.js' -o -name '*.css' -o -name '*.txt' -o -name '*.html' -o -name '*.php' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
75
0562beca
ER
76%build
77lynx -dump -nolist -width 1024 CHANGES.html | sed -e '/___/,$d' > CHANGES
d19573b0
ER
78
79%install
80rm -rf $RPM_BUILD_ROOT
81install -d $RPM_BUILD_ROOT%{_appdir}
82
0562beca 83cp -a ckeditor.js config.js contents.css $RPM_BUILD_ROOT%{_appdir}
de1bd76f 84cp -a adapters plugins skins themes lang $RPM_BUILD_ROOT%{_appdir}
d19573b0 85
0562beca
ER
86install -d $RPM_BUILD_ROOT%{php_data_dir}
87cp -a ckeditor.php $RPM_BUILD_ROOT%{php_data_dir}
88
d19573b0 89install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
0562beca 90cp -a _samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
d19573b0
ER
91
92install -d $RPM_BUILD_ROOT%{_sysconfdir}
0562beca 93cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
3024a7d4 94cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
0562beca 95cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
d19573b0
ER
96
97%find_lang %{name}.lang
98
538747fe
ER
99# always include
100%{__sed} -i -e '/en\.js/d' %{name}.lang
101
0562beca
ER
102# already listed by plugin dir
103%{__sed} -i -e '/plugins/d' %{name}.lang
538747fe 104
d19573b0
ER
105%triggerin -- apache1 < 1.3.37-3, apache1-base
106%webapp_register apache %{_webapp}
107
108%triggerun -- apache1 < 1.3.37-3, apache1-base
109%webapp_unregister apache %{_webapp}
110
3024a7d4 111%triggerin -- apache < 2.2.0, apache-base
d19573b0
ER
112%webapp_register httpd %{_webapp}
113
3024a7d4 114%triggerun -- apache < 2.2.0, apache-base
d19573b0
ER
115%webapp_unregister httpd %{_webapp}
116
117%triggerin -- lighttpd
118%webapp_register lighttpd %{_webapp}
119
120%triggerun -- lighttpd
121%webapp_unregister lighttpd %{_webapp}
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files -f %{name}.lang
127%defattr(644,root,root,755)
0562beca 128%doc CHANGES
d19573b0
ER
129%dir %attr(750,root,http) %{_sysconfdir}
130%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
131%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
132%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
133%dir %{_appdir}
134%{_appdir}/*.js
538747fe 135%{_appdir}/lang/en.js
0562beca 136%{_appdir}/*.css
de1bd76f
ER
137
138%dir %{_appdir}/adapters
139%{_appdir}/adapters/jquery.js
140
0562beca
ER
141%dir %{_appdir}/themes
142%{_appdir}/themes/default
143
144%dir %{_appdir}/skins
145%{_appdir}/skins/kama
146%{_appdir}/skins/office2003
147%{_appdir}/skins/v2
148
149%dir %{_appdir}/plugins
20fe3b1a 150%{_appdir}/plugins/a11yhelp
0562beca
ER
151%{_appdir}/plugins/about
152%{_appdir}/plugins/clipboard
153%{_appdir}/plugins/colordialog
154%{_appdir}/plugins/dialog
155%{_appdir}/plugins/div
156%{_appdir}/plugins/find
157%{_appdir}/plugins/flash
158%{_appdir}/plugins/forms
159%{_appdir}/plugins/iframedialog
160%{_appdir}/plugins/image
161%{_appdir}/plugins/link
162%{_appdir}/plugins/pagebreak
163%{_appdir}/plugins/pastefromword
164%{_appdir}/plugins/pastetext
165%{_appdir}/plugins/scayt
166%{_appdir}/plugins/showblocks
167%{_appdir}/plugins/smiley
168%{_appdir}/plugins/specialchar
20fe3b1a 169%{_appdir}/plugins/styles
0562beca
ER
170%{_appdir}/plugins/table
171%{_appdir}/plugins/tabletools
172%{_appdir}/plugins/templates
173%{_appdir}/plugins/uicolor
174%{_appdir}/plugins/wsc
d19573b0
ER
175
176%{_examplesdir}/%{name}-%{version}
0562beca
ER
177
178%files -n php-%{name}
179%defattr(644,root,root,755)
180%{php_data_dir}/ckeditor.php
This page took 0.088801 seconds and 4 git commands to generate.