]> git.pld-linux.org Git - packages/cjs.git/blame - cjs.spec
- up to 4.2.0
[packages/cjs.git] / cjs.spec
CommitLineData
9f107e75
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5Summary: Javascript Bindings for Cinnamon
6Name: cjs
131922ab
AM
7Version: 4.2.0
8Release: 1
9f107e75
ER
9Group: Libraries
10# The following files contain code from Mozilla which
11# is triple licensed under MPL1.1/LGPLv2+/GPLv2+:
12# The console module (modules/console.c)
13# Stack printer (gjs/stack.c)
14License: MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
15Source0: https://github.com/linuxmint/cjs/archive/%{version}/%{name}-%{version}.tar.gz
131922ab 16# Source0-md5: af9e59943aba0974359e76202abd89b8
9f107e75 17URL: http://cinnamon.linuxmint.com/
15932ebb
ER
18BuildRequires: autoconf >= 2.53
19BuildRequires: automake >= 1.7.2
9f107e75 20BuildRequires: cairo-gobject-devel
15932ebb 21BuildRequires: gnome-common
9f107e75
ER
22BuildRequires: gobject-introspection-devel >= 1.38.0
23BuildRequires: gtk+3-devel
24BuildRequires: intltool
15932ebb 25BuildRequires: libtool
131922ab 26BuildRequires: mozjs52-devel
15932ebb 27BuildRequires: pkgconfig >= 0.14.0
9f107e75
ER
28BuildRequires: readline-devel
29BuildRequires: sed >= 4.0
9f107e75
ER
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Cjs allows using Cinnamon libraries from Javascript. It's based on the
34Spidermonkey Javascript engine from Mozilla and the GObject
35introspection framework.
36
37%package devel
38Summary: Development package for %{name}
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Files for development with %{name}.
44
45%package tests
46Summary: Tests for the cjs package
47Group: Development/Libraries
48Requires: %{name}-devel = %{version}-%{release}
49
50%description tests
51The cjs-tests package contains tests that can be used to verify the
52functionality of the installed cjs package.
53
54%prep
55%setup -q
56sed -i -e 's@{ACLOCAL_FLAGS}@{ACLOCAL_FLAGS} -I m4@g' Makefile.am
57echo "AC_CONFIG_MACRO_DIR([m4])" >> configure.ac
58
59%build
60NOCONFIGURE=1 ./autogen.sh
61%configure \
62 --disable-silent-rules \
63 --disable-static \
64 --enable-installed-tests \
65
66%{__make}
67
68%if %{with tests}
69%{__make} check
70%endif
71
72%install
73rm -rf $RPM_BUILD_ROOT
74%{__make} install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcjs.la
78%{__rm} $RPM_BUILD_ROOT%{_libdir}/cjs/lib*.la
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84%postun -p /sbin/ldconfig
85
86%files
87%defattr(644,root,root,755)
88%doc COPYING COPYING.LGPL NEWS README
89%attr(755,root,root) %{_bindir}/cjs
90%attr(755,root,root) %{_bindir}/cjs-console
91%attr(755,root,root) %{_libdir}/libcjs.so.*.*.*
92%ghost %{_libdir}/libcjs.so.0
93%dir %{_libdir}/cjs
94%dir %{_libdir}/cjs/girepository-1.0
95%{_libdir}/cjs/girepository-1.0/CjsPrivate-1.0.typelib
96
97%files devel
98%defattr(644,root,root,755)
99%doc examples/*
100%{_includedir}/cjs-1.0
101%{_libdir}/libcjs.so
102%{_pkgconfigdir}/cjs-1.0.pc
9f107e75
ER
103%attr(755,root,root) %{_libdir}/cjs/libgimarshallingtests.so
104%attr(755,root,root) %{_libdir}/cjs/libregress.so
105%attr(755,root,root) %{_libdir}/cjs/libwarnlib.so
106
107%files tests
108%defattr(644,root,root,755)
131922ab
AM
109%dir %{_libexecdir}/cjs
110%{_libexecdir}/cjs/installed-tests
9f107e75 111%{_datadir}/installed-tests
This page took 0.22311 seconds and 4 git commands to generate.