]> git.pld-linux.org Git - packages/cipe.git/blob - cipe.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/cipe.git] / cipe.spec
1 %define         _kernel_ver %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
2 %define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
3 %define         smpstr          %{?_with_smp:-smp}
4 %define         smp             %{?_with_smp:1}%{!?_with_smp:0}
5
6 Summary:        CIPE - encrypted IP over UDP tunneling
7 Summary(pl):    CIPE - szyfrowany tunel IP po UDP
8 Name:           cipe
9 Version:        1.5.2
10 Release:        3
11 License:        GPL
12 Group:          Networking/Daemons
13 Source0:        http://sites.inka.de/bigred/sw/%{name}-%{version}.tar.gz
14 Source1:        %{name}.inetd
15 Patch0:         %{name}-autoconf.patch
16 Patch1:         %{name}-makefile.patch
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  openssl-devel >= 0.9.6
20 BuildRequires:  %{_bindir}/openssl
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc
24
25 %description
26 CIPE (the name is shortened from *Crypto IP Encapsulation*) is a
27 package for an encrypting IP tunnel device. This can be used to build
28 encrypting routers for VPN (Virtual Private Networks) and similar
29 applications.
30
31 %description -l pl
32 CIPE (nazwa to skrót od *Crypto IP Encapsulation*) to pakiet do
33 tworzenia szyfrowanych tuneli IP. Mo¿na je wykorzystaæ do budowania
34 routerów szyfruj±cych w VPNach (Prywatnych Sieciach Wirtualnych) i
35 podobnych zastosowaniach.
36
37 %package pkcipe
38 Summary:        The PKCIPE public key tool for CIPE
39 Summary(pl):    PKCIPE - narzêdzie do wykorzystania kluczy publicznych w CIPE
40 Group:          Networking/Daemons
41 Prereq:         %{_bindir}/openssl
42 Requires:       %{name} = %{version}
43
44 %description pkcipe
45 CIPE (the name is shortened from *Crypto IP Encapsulation*) is a
46 package for an encrypting IP tunnel device. This can be used to build
47 encrypting routers for VPN (Virtual Private Networks) and similar
48 applications.
49 This package contains PKCIPE, which simplifies setup of CIPE tunnels by
50 using autoconfiguration and public/private key mechanisms.
51
52 %description pkcipe -l pl
53 CIPE (nazwa to skrót od *Crypto IP Encapsulation*) to pakiet do
54 tworzenia szyfrowanych tuneli IP. Mo¿na je wykorzystaæ do budowania
55 routerów szyfruj±cych w VPNach (Prywatnych Sieciach Wirtualnych) i
56 podobnych zastosowaniach.
57 Ten pakiet zawiera PKCIPE, który uprasza ustawienie tuneli CIPE przez
58 korzystanie z autokonfiguracji oraz mechanizmów kluczy
59 publicznych/prywatnych.
60
61 %package -n kernel%{smpstr}-cipe
62 Summary:        CIPE kernel module
63 Summary(pl):    Modu³ j±dra CIPE
64 Release:        %{release}@%{_kernel_ver_str}
65 Group:          Base/Kernel
66 Prereq:         /sbin/depmod
67
68 %description -n kernel%{smpstr}-cipe
69 CIPE (the name is shortened from *Crypto IP Encapsulation*) is a
70 package for an encrypting IP tunnel device. This can be used to build
71 encrypting routers for VPN (Virtual Private Networks) and similar
72 applications. This package contains a kernel module compiled for
73 %{_kernel_ver}%{smpstr}.
74
75 %description -n kernel%{smpstr}-cipe -l pl
76 CIPE (nazwa to skrót od *Crypto IP Encapsulation*) to pakiet do
77 tworzenia szyfrowanych tuneli IP. Mo¿na je wykorzystaæ do budowania
78 routerów szyfruj±cych w VPNach (Prywatnych Sieciach Wirtualnych) i
79 podobnych zastosowaniach. Ten pakiet zawiera modu³ kernela
80 skompilowany dla %{_kernel_ver}%{smpstr}.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 %build
88 mv -f conf/aclocal.m4 conf/acinclude.m4
89 aclocal -I conf --output=conf/aclocal.m4
90 autoconf -l conf/
91 %if %{smp}
92 DEFS="-D__SMP__ -D__KERNEL_SMP=1" \
93 %endif
94 %configure \
95         --with-linux=%{_kernelsrcdir} \
96         --with-ciped=%{_sbindir}/ciped-cb \
97 %if %{smp}
98         --enable-smp
99 %endif
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_infodir}} \
107         $RPM_BUILD_ROOT%{_sysconfdir}/cipe/pk \
108         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc \
109         $RPM_BUILD_ROOT%{_var}/run/cipe \
110         $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd
111
112 install pkcipe/pkcipe $RPM_BUILD_ROOT%{_sbindir}
113 install pkcipe/rsa-keygen $RPM_BUILD_ROOT%{_bindir}
114 install */cipcb.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
115 install */ciped-cb $RPM_BUILD_ROOT%{_sbindir}
116 install cipe.info $RPM_BUILD_ROOT%{_infodir}
117 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/pkcipe
118
119 gzip -9nf README* tcpdump.patch CHANGES
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post
125 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
126
127 %postun
128 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
129
130 %post pkcipe
131 [ ! -f %{_sysconfdir}/cipe/identity.priv ] && %{_bindir}/rsa-keygen %{_sysconfdir}/cipe/identity
132 if [ -f /var/lock/subsys/rc-inetd ]; then
133         /etc/rc.d/init.d/rc-inetd reload 1>&2
134 else
135         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
136 fi
137
138 %postun pkcipe
139 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
140         /etc/rc.d/init.d/rc-inetd reload
141 fi
142
143 %post -n kernel%{smpstr}-cipe
144 /sbin/depmod -a
145
146 %postun -n kernel%{smpstr}-cipe
147 /sbin/depmod -a
148
149 %files
150 %defattr(644,root,root,755)
151 %doc *.gz samples
152 %{_infodir}/*
153 %attr(755,root,root) %{_sbindir}/ciped-cb
154 %dir %{_sysconfdir}/cipe
155 %attr(755,root,root) %dir %{_var}/run/cipe
156
157 %files pkcipe
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/rsa-keygen
160 %attr(755,root,root) %{_sbindir}/pkcipe
161 %attr(700,root,root) %dir %{_sysconfdir}/cipe/pk
162 %attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/rc-inetd/pkcipe
163
164 %files -n kernel%{smpstr}-cipe
165 %defattr(644,root,root,755)
166 %attr(600,root,root) /lib/modules/*/misc/cipcb.o
This page took 0.039742 seconds and 3 git commands to generate.