]> git.pld-linux.org Git - packages/cinelerra.git/commitdiff
- updated for 1.2.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 22 Aug 2004 20:36:24 +0000 (20:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cinelerra-strip.patch -> 1.4
    cinelerra-system-libs.patch -> 1.7

cinelerra-strip.patch
cinelerra-system-libs.patch

index 211cee631aecdb953f259eaed642fc1aa7413803..5372996c368f683712dfe17a18d4d5fa39bbe37e 100644 (file)
@@ -1,12 +1,12 @@
---- cinelerra-1.1.5/plugins/defaulttheme/Makefile.orig Sun Dec 22 11:37:27 2002
-+++ cinelerra-1.1.5/plugins/defaulttheme/Makefile      Mon Mar 24 10:23:13 2003
-@@ -6,7 +6,7 @@
+--- cinelerra-1.2.1/plugins/defaulttheme/Makefile.orig 2004-05-11 18:14:51.000000000 +0200
++++ cinelerra-1.2.1/plugins/defaulttheme/Makefile      2004-08-22 20:38:29.715608048 +0200
+@@ -9,7 +9,7 @@
  
OUTPUT_THEME: $(OBJS)
-       $(LDLINKER) -o $(OUTPUT_THEME) $(OBJS)
$(OUTPUT_THEME): $(OBJS) $(THEME_DATA)
+       $(LDLINKER) -o $(OUTPUT_THEME) $(OBJS) $(THEME_DATA)
 -      strip $(OUTPUT_THEME)
 +      $(STRIP) $(OUTPUT_THEME)
-       ../../guicast/$(OBJDIR)/bootstrap $(OUTPUT_THEME) data/*.png
  
  
 --- cinelerra-1.1.5/plugins/microtheme/Makefile.orig   Fri Jun 21 14:35:25 2002
        ../../cinelerra/$(OBJDIR)/bootstrap $(OUTPUT_THEME) data/*.png
  
  include ../../plugin_config
---- cinelerra-1.2.0/cinelerra/Makefile.orig    2004-06-05 01:31:27.950366992 +0200
-+++ cinelerra-1.2.0/cinelerra/Makefile 2004-06-05 01:34:43.197684888 +0200
-@@ -404,7 +404,7 @@
+--- cinelerra-1.2.1/cinelerra/Makefile.orig    2004-08-22 20:32:29.566359056 +0200
++++ cinelerra-1.2.1/cinelerra/Makefile 2004-08-22 20:47:51.109263240 +0200
+@@ -412,7 +412,7 @@
        @echo LD $(OUTPUT)
        @$(LINKER) `cat $(OBJDIR)/objs`
        @echo STRIP $(OUTPUT)
 -      @strip $(OUTPUT)
 +      @$(STRIP) $(OUTPUT)
-       @echo BOOTSTRAP $(OUTPUT)
-       @../guicast/$(OBJDIR)/bootstrap $(OUTPUT) data/mode_*.png
  
+ $(OBJDIR)/test: 
+       $(CC) -shared -o $(OBJDIR)/test.so \
index 2c082aca6b4bb505ea403d1924cc9c279404b333..c63d24c7b4c9a13da6e119c993e08e46ce409749 100644 (file)
@@ -1,6 +1,6 @@
---- cinelerra-1.2.0/cinelerra/Makefile.orig    2004-04-06 08:27:21.000000000 +0200
-+++ cinelerra-1.2.0/cinelerra/Makefile 2004-06-05 01:28:18.814120072 +0200
-@@ -1,17 +1,6 @@
+--- cinelerra-1.2.1/cinelerra/Makefile.orig    2004-07-12 01:07:17.000000000 +0200
++++ cinelerra-1.2.1/cinelerra/Makefile 2004-08-22 20:29:36.344692752 +0200
+@@ -1,18 +1,6 @@
  include ../global_config
  
 -ALSA_DIR := ../alsa-lib-1.0.2
  TOOLAME_DIR := ../toolame-02l
 -UUID_DIR := ../uuid
 -VORBIS_DIR := ../quicktime/libvorbis-1.0
+-EXR_DIR := ../OpenEXR-1.2.1/
  
  OBJS = \
        $(OBJDIR)/aattachmentpoint.o \
-@@ -279,26 +268,19 @@
+@@ -285,24 +273,17 @@
  
  
  #ifeq ($(HAVE_AVIFILE), y)
 -      $(AVC_DIR)/$(OBJDIR)/libavc.a \
 -      ../quicktime/$(OBJDIR)/libquicktime.a \
          $(ESOUNDLIBS) \
+-      $(EXR_DIR)/$(OBJDIR)/libexr.a \
 -      $(TIFF_DIR)/$(OBJDIR)/libtiff.a \
        ../guicast/$(OBJDIR)/libguicast.a \
 -      ../libmpeg3/$(OBJDIR)/libmpeg3.a \
 -      $(SNDFILE_DIR)/$(OBJDIR)/libsndfile.a \
 -      $(UUID_DIR)/$(OBJDIR)/libuuid.a \
        ../mpeg2enc/$(OBJDIR)/mpeg2enc.a \
-       $(TOOLAME_DIR)/$(OBJDIR)/toolame.a
--#     ../libavc/$(OBJDIR)/libavc.a \
- LIBS := \
-       -L./ \
-@@ -316,7 +298,13 @@
+       $(TOOLAME_DIR)/$(OBJDIR)/toolame.a \
+       $(THEME_DATA)
+@@ -323,7 +304,14 @@
  
  LIBS += \
        $(ALSA_LIBS) \
 -      $(LIBRAW_DIR)/$(OBJDIR)/libraw1394.a \
 +      -lavc1394 -lrom1394 \
 +      -lquicktime -lvorbisfile \
++      -lIlmImf -lImath -lHalf -lIex \
 +      -ltiff \
 +      -lmpeg3 \
 +      -lsndfile \
@@ -63,7 +63,7 @@
        $(GLLIBS) \
        -lX11 \
        -lXext \
-@@ -335,23 +323,17 @@
+@@ -342,23 +330,17 @@
  
  CFLAGS += \
        -I../guicast \
  
  
  # Speed up linking with this linking sequence
+@@ -463,7 +445,7 @@
+ $(FILEEXR): fileexr.C
+       @echo C++ $*.o
+-      @$(CC) -c `cat $(OBJDIR)/c_flags` -I$(EXR_DIR)IlmImf -I$(EXR_DIR)Imath -I$(EXR_DIR)Iex -I$(EXR_DIR)Half $(subst $(OBJDIR)/,, $*.C) -o $*.o
++      @$(CC) -c `cat $(OBJDIR)/c_flags` -I/usr/include/OpenEXR $(subst $(OBJDIR)/,, $*.C) -o $*.o
+ $(THEME_DATA):
+       cd $(OBJDIR) && \
 --- cinelerra-1.1.8/cinelerra/jpegwrapper.h.orig       2003-10-14 09:54:01.000000000 +0200
 +++ cinelerra-1.1.8/cinelerra/jpegwrapper.h    2003-11-12 22:28:31.358423944 +0100
 @@ -7,7 +7,7 @@
  #include <sys/types.h>
  #include <stdio.h>
  #include <errno.h>
+--- cinelerra-1.2.1/cinelerra/device1394input.h.orig   2004-07-06 06:32:42.000000000 +0200
++++ cinelerra-1.2.1/cinelerra/device1394input.h        2004-08-22 21:26:29.328840296 +0200
+@@ -7,7 +7,7 @@
+ #include "condition.inc"
+ #include "libdv.h"
+-#include "libdv/dv1394.h"
++#include "dv1394.h"
+ #include "mutex.inc"
+ #include "libraw1394/raw1394.h"
+ #include "thread.h"
+--- cinelerra-1.2.1/cinelerra/device1394output.h.orig  2004-04-13 00:52:55.000000000 +0200
++++ cinelerra-1.2.1/cinelerra/device1394output.h       2004-08-22 21:23:11.293946176 +0200
+@@ -8,7 +8,7 @@
+ #include "audiodevice.inc"
+ #include "condition.inc"
+ #include "libdv.h"
+-#include "libdv/dv1394.h"
++#include "dv1394.h"
+ #include "ieee1394-ioctl.h"
+ #include "mutex.inc"
+ #include "thread.h"
This page took 0.074411 seconds and 4 git commands to generate.