]> git.pld-linux.org Git - packages/cinelerra.git/blob - cinelerra.spec
- converted to UTF-8
[packages/cinelerra.git] / cinelerra.spec
1 #
2 # TODO:
3 # - build guicast as separate, shared library to use in xmovie,
4 #   mix2005 and cinelerra
5 # - get rid of bootstrap stuff:
6 #   https://init.linpro.no/pipermail/skolelinux.no/cinelerra/2004-April/001413.html
7 #
8 Summary:        Cinelerra - capturing, editing and production of audio/video material
9 Summary(pl.UTF-8):   Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
10 Name:           cinelerra
11 Version:        2.1
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications
15 Source0:        http://dl.sourceforge.net/heroines/%{name}-%{version}-src.tar.bz2
16 # Source0-md5:  0f0523ef1aa94efb5152dcc494009b56
17 Patch0:         %{name}-system-libs.patch
18 Patch1:         %{name}-strip.patch
19 Patch2:         %{name}-fontsdir.patch
20 Patch3:         %{name}-locale_h.patch
21 Patch4:         %{name}-guicast_bootstrap.patch
22 Patch5:         %{name}-fix.patch
23 URL:            http://heroinewarrior.com/cinelerra.php3
24 BuildRequires:  OpenEXR-devel >= 1.2.1
25 #BuildRequires: OpenGL-devel >= 2.0
26 BuildRequires:  alsa-lib-devel >= 1.0.8
27 BuildRequires:  esound-devel
28 BuildRequires:  freetype-devel >= 2.1.4
29 BuildRequires:  lame-libs-devel >= 3.93.1
30 BuildRequires:  libavc1394-devel >= 0.5.1
31 BuildRequires:  libiec61883-devel >= 1.0.0
32 BuildRequires:  libmpeg3-devel >= 1.7
33 BuildRequires:  libraw1394-devel >= 1.2.0
34 BuildRequires:  libsndfile-devel >= 1.0.11
35 BuildRequires:  libstdc++-devel >= 5:3.2.2
36 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
37 BuildRequires:  libtiff-devel >= 3.5.7
38 BuildRequires:  libuuid-devel
39 %ifarch %{ix86}
40 BuildRequires:  nasm
41 %endif
42 BuildRequires:  quicktime4linux-devel >= 2.2
43 BuildRequires:  xorg-lib-libX11-devel
44 BuildRequires:  xorg-lib-libXext-devel
45 BuildRequires:  xorg-lib-libXv-devel
46 BuildRequires:  xorg-lib-libXxf86vm-devel
47 Requires:       OpenEXR-devel >= 1.2.1
48 Requires:       alsa-lib >= 1.0.8
49 Requires:       freetype >= 2.1.4
50 Requires:       libavc1394 >= 0.5.1
51 Requires:       libiec61883 >= 1.0.0
52 Requires:       libmpeg3 >= 1.7
53 Requires:       libraw1394 >= 1.2.0
54 Requires:       libsndfile >= 1.0.11
55 Requires:       libtheora >= 1.0-0.alpha4
56 Requires:       quicktime4linux >= 2.2
57 Obsoletes:      bcast
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _noautostrip    .*/microtheme.plugin
61
62 %description
63 There are two types of moviegoers: producers who create new content,
64 going back over their content at future points for further refinement,
65 and consumers who want to acquire the content and watch it. Cinelerra
66 is not intended for consumers. Cinelerra has many features for
67 uncompressed content, high resolution processing, and compositing,
68 with very few shortcuts. Producers need these features because of the
69 need to retouch many generations of footage with alterations to the
70 format, which makes Cinelerra very complex.
71
72 Cinelerra was meant to be a Broadcast 2000 replacement.
73
74 %description -l pl.UTF-8
75 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
76 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
77 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
78 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
79 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
80 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
81 potrzebują tych możliwości ze względu na konieczność retuszowania
82 oraz modyfikacji formatu, co czyni program bardzo złożonym.
83
84 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93 %patch5 -p1
94
95 # assume we have <linux/videodev2.h> and <linux/dvb/*> (present in llh)
96 # don't define HAVE_GL as Mesa doesn't support OpenGL 2.0 (e.g. glUseProgram()) yet
97 cat > hvirtual_config.h <<EOF
98 #define HAVE_VIDEO4LINUX2
99 #define HAVE_DVB
100 #define PACKAGE_STRING "cinelerra"
101 EOF
102
103 rm -rf OpenEXR-* alsa-lib-* audiofile esound fftw-* freetype-* libavc1394-* libiec61883-* libmpeg3 libraw1394-* libsndfile-* libtheora-* mjpegtools-* quicktime tiff-* uuid
104
105 %build
106 CFLAGS="%{rpmcflags}"; export CFLAGS
107 %{__make} -f build/Makefile.toolame
108 %{__make} -C mpeg2enc
109 %{__make} -C mplexlo
110 %{__make} -C guicast
111 # cinelerra, defaulttheme and microtheme are stripped before running "bootstrap"
112 %{__make} -C cinelerra \
113         STRIP="%{?debug:true}%{!?debug:strip -R.note -R.comment}"
114 %{__make} -C plugins \
115         STRIP="%{?debug:true}%{!?debug:strip -R.note -R.comment}"
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/cinelerra}
120
121 install cinelerra/*/cinelerra $RPM_BUILD_ROOT%{_bindir}
122 install plugins/`uname -m`/*.plugin $RPM_BUILD_ROOT%{_libdir}/cinelerra
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc doc/{*.png,*.html,press} cinelerra/{CHANGELOG*,TODO}
130 %attr(755,root,root) %{_bindir}/*
131 %attr(755,root,root) %{_libdir}/cinelerra
This page took 0.150623 seconds and 4 git commands to generate.