]> git.pld-linux.org Git - packages/cinelerra.git/blob - cinelerra.spec
- updated
[packages/cinelerra.git] / cinelerra.spec
1 #
2 # TODO:
3 # - build guicast as separate, shared library to use in xmovie,
4 #   mix2005 and cinelerra
5 # - get rid of bootstrap stuff:
6 #   https://init.linpro.no/pipermail/skolelinux.no/cinelerra/2004-April/001413.html
7 #
8 Summary:        Cinelerra - capturing, editing and production of audio/video material
9 Summary(pl.UTF-8):      Cinelerra - nagrywanie, obróbka i produkcja materiału audio/video
10 Name:           cinelerra
11 Version:        4
12 Release:        3
13 License:        GPL v2+
14 Group:          X11/Applications
15 Source0:        http://dl.sourceforge.net/heroines/%{name}-%{version}-src.tar.bz2
16 # Source0-md5:  0faf7158859646c5ea6181283594b19a
17 Patch0:         %{name}-system-libs.patch
18 Patch1:         %{name}-strip.patch
19 Patch2:         %{name}-fontsdir.patch
20 Patch3:         %{name}-locale_h.patch
21 Patch4:         %{name}-guicast_bootstrap.patch
22 Patch5:         %{name}-fix.patch
23 Patch6:         %{name}-plugindir.patch
24 Patch7:         %{name}-ffmpeg.patch
25 Patch8:         %{name}-fade_error.patch
26 URL:            http://www.heroinewarrior.com/cinelerra.php
27 BuildRequires:  OpenEXR-devel >= 1.6.1
28 BuildRequires:  OpenGL-devel >= 2.0
29 BuildRequires:  alsa-lib-devel >= 1.0.8
30 BuildRequires:  esound-devel
31 BuildRequires:  flac-devel >= 1.1.4
32 BuildRequires:  freetype-devel >= 2.1.4
33 BuildRequires:  lame-libs-devel >= 3.93.1
34 BuildRequires:  libavc1394-devel >= 0.5.1
35 BuildRequires:  libiec61883-devel >= 1.0.0
36 BuildRequires:  libmpeg3-devel >= 1.8
37 BuildRequires:  libraw1394-devel >= 1.2.0
38 BuildRequires:  libsndfile-devel >= 1.0.11
39 BuildRequires:  libstdc++-devel >= 5:3.2.2
40 BuildRequires:  libtheora-devel >= 1.0-0.alpha4
41 BuildRequires:  libtiff-devel >= 3.5.7
42 BuildRequires:  libuuid-devel
43 %ifarch %{ix86}
44 BuildRequires:  nasm
45 %endif
46 BuildRequires:  quicktime4linux-devel >= 2.3
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xorg-lib-libXext-devel
49 BuildRequires:  xorg-lib-libXv-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 Requires:       OpenEXR >= 1.6.1
52 Requires:       alsa-lib >= 1.0.8
53 Requires:       freetype >= 2.1.4
54 Requires:       libavc1394 >= 0.5.1
55 Requires:       libiec61883 >= 1.0.0
56 Requires:       libmpeg3 >= 1.8
57 Requires:       libraw1394 >= 1.2.0
58 Requires:       libsndfile >= 1.0.11
59 Requires:       libtheora >= 1.0-0.alpha4
60 Requires:       quicktime4linux >= 2.3
61 Obsoletes:      bcast
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _noautostrip    .*/microtheme.plugin
65
66 %description
67 There are two types of moviegoers: producers who create new content,
68 going back over their content at future points for further refinement,
69 and consumers who want to acquire the content and watch it. Cinelerra
70 is not intended for consumers. Cinelerra has many features for
71 uncompressed content, high resolution processing, and compositing,
72 with very few shortcuts. Producers need these features because of the
73 need to retouch many generations of footage with alterations to the
74 format, which makes Cinelerra very complex.
75
76 Cinelerra was meant to be a Broadcast 2000 replacement.
77
78 %description -l pl.UTF-8
79 Są dwa rodzaje użytkowników zajmujących się filmami: producenci
80 tworzący nowe filmy, wracający do nich w przyszłości w celu dalszego
81 wygładzenia, oraz konsumenci, którzy chcą tylko zdobyć film i go
82 obejrzeć. Cinelerra nie jest dla konsumentów. Program ma wiele
83 możliwości do edycji nieskompresowanej zawartości, obróbki w wysokiej
84 rozdzielczości oraz montażu, z bardzo małą liczbą skrótów. Producenci
85 potrzebują tych możliwości ze względu na konieczność retuszowania oraz
86 modyfikacji formatu, co czyni program bardzo złożonym.
87
88 Cinelerra była tworzona z myślą o zastąpieniu programu Broadcast 2000.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96 %patch4 -p1
97 %patch5 -p1
98 %patch6 -p1
99 %patch7 -p1
100 %patch8 -p1
101
102 # assume we have <linux/videodev2.h> and <linux/dvb/*> (present in llh)
103 cat > hvirtual_config.h <<EOF
104 #define HAVE_VIDEO4LINUX2
105 #define HAVE_DVB
106 #define HAVE_GL
107 #define PACKAGE_STRING "cinelerra"
108 EOF
109
110 %{__rm} -r libmpeg3 quicktime \
111         thirdparty/{audiofile,esound,fftw-*,flac-*,freetype-*,ilmbase-*,libavc1394-*,libiec61883-*,libraw1394-*,libsndfile-*,libtheora-*,mjpegtools-*,openexr-*,tiff-*,uuid}
112
113 %build
114 export CFLAGS="%{rpmcflags}"
115 %{__make} -f build/Makefile.toolame \
116         GCC="%{__cc}"
117 %{__make} -C mpeg2enc \
118         CC="%{__cc}"
119 %{__make} -C mplexlo \
120         CC="%{__cc}"
121 %{__make} -C guicast \
122         GCC="%{__cc}" \
123         CC="%{__cxx}"
124 # cinelerra, defaulttheme and microtheme are stripped before running "bootstrap"
125 %{__make} -C cinelerra \
126         GCC="%{__cc}" \
127         CC="%{__cxx}" \
128         LINKER='%{__cxx} -o $(OUTPUT)' \
129         STRIP="%{?debug:true}%{!?debug:strip -R.note -R.comment}"
130 %{__make} -C plugins \
131         CC="%{__cxx}" \
132         STRIP="%{?debug:true}%{!?debug:strip -R.note -R.comment}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/cinelerra}
137
138 install cinelerra/*/cinelerra $RPM_BUILD_ROOT%{_bindir}
139 install plugins/`uname -m`/*.plugin $RPM_BUILD_ROOT%{_libdir}/cinelerra
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc doc/{*.png,*.html,press} cinelerra/{CHANGELOG*,TODO}
147 %attr(755,root,root) %{_bindir}/*
148 %attr(755,root,root) %{_libdir}/cinelerra
This page took 0.376739 seconds and 3 git commands to generate.