]> git.pld-linux.org Git - packages/cilk.git/blob - cilk.spec
- pl fix
[packages/cilk.git] / cilk.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        Cilk compiler
6 Summary(pl):    Kompilator Cilka
7 Name:           cilk
8 Version:        5.4.2.2
9 %define _rev    1708
10 Release:        0.1
11 License:        GPL v2 and LGPL
12 Group:          Development/Languages
13 Source0:        http://bradley.csail.mit.edu/~bradley/cilk/downloads/%{name}-%{version}_%{_rev}.tar.bz2
14 # Source0-md5:  1046f684ac72076106574fcc8326e612
15 URL:            http://supertech.lcs.mit.edu/cilk/
16 BuildRequires:  bison
17 BuildRequires:  flex
18 Requires:       gcc
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Cilk is a language for multithreaded parallel programming based on
23 ANSI C. Cilk is designed for general-purpose parallel programming, but
24 it is especially effective for exploiting dynamic, highly asynchronous
25 parallelism, which can be difficult to write in data-parallel or
26 message-passing style.
27
28 #%%description -l pl
29 #TODO
30
31 %package static
32 Summary:        Static cilk libraries
33 Summary(pl):    Statyczne biblioteki cilka
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description static
38 Static cilk libraries.
39
40 %description static -l pl
41 Statyczne biblioteki cilka.
42
43 %prep
44 %setup -q -n %{version}
45 %{!?with_tests:sed 's/ examples / /' -i Makefile.in}
46
47 %build
48 #%%{__libtoolize}
49 #%%{__aclocal} -I m4dir
50 #%%{__autoconf}
51 #%%{__autoheader}
52 #%%{__automake}
53
54 %configure
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS ChangeLog NEWS README THANKS
72 %attr(755,root,root) %{_bindir}/*
73 %attr(755,root,root) %{_libdir}/*.so.*.*.*
74 %{_includedir}/%{name}
75 %attr(755,root,root) %{_libdir}/*.so
76 %{_libdir}/*.la
77 # contains libcilkrt0*.a
78 %{_libdir}/%{name}
79
80 %files static
81 %defattr(644,root,root,755)
82 %{_libdir}/*.a
This page took 0.071414 seconds and 3 git commands to generate.