]> git.pld-linux.org Git - packages/cifs-utils.git/commitdiff
- updated to 5.5
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 24 Jun 2012 18:51:13 +0000 (18:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added heimdal patch (fixes some -Werror issues with heimdal kerberos)
- added configure hacks for samba not providing pkgconfig file for libwbclient
- pl

Changed files:
    cifs-utils-heimdal.patch -> 1.1
    cifs-utils.spec -> 1.4

cifs-utils-heimdal.patch [new file with mode: 0644]
cifs-utils.spec

diff --git a/cifs-utils-heimdal.patch b/cifs-utils-heimdal.patch
new file mode 100644 (file)
index 0000000..505aa14
--- /dev/null
@@ -0,0 +1,38 @@
+--- cifs-utils-5.5/cifs.upcall.c.orig  2012-05-30 12:12:16.000000000 +0200
++++ cifs-utils-5.5/cifs.upcall.c       2012-06-24 20:47:02.372423189 +0200
+@@ -76,7 +76,7 @@
+  *
+  */
+-static char *cifs_krb5_principal_get_realm(krb5_context context __attribute__ ((unused)),
++static const char *cifs_krb5_principal_get_realm(krb5_context context __attribute__ ((unused)),
+                                          krb5_principal principal)
+ {
+ #ifdef HAVE_KRB5_PRINCIPAL_GET_REALM  /* Heimdal */
+@@ -84,7 +84,7 @@
+ #elif defined(krb5_princ_realm)       /* MIT */
+       krb5_data *realm;
+       realm = krb5_princ_realm(context, principal);
+-      return (char *)realm->data;
++      return (const char *)realm->data;
+ #else
+       return NULL;
+ #endif
+@@ -116,7 +116,7 @@
+       krb5_creds creds;
+       krb5_principal principal;
+       time_t credtime = 0;
+-      char *realm = NULL;
++      const char *realm = NULL;
+       if (krb5_init_context(&context)) {
+               syslog(LOG_DEBUG, "%s: unable to init krb5 context", __func__);
+@@ -162,7 +162,7 @@
+                   && creds.times.endtime > time(NULL))
+                       credtime = creds.times.endtime;
+               krb5_free_cred_contents(context, &creds);
+-              krb5_free_unparsed_name(context, name);
++              krb5_xfree(name);
+       }
+ err_endseq:
+       krb5_cc_end_seq_get(context, ccache, &cur);
index c28a160bc95c7773624ac9499d6db2dd69d81b9a..932cc6be8ef0091b09a1385443120abd0e9228f2 100644 (file)
@@ -1,19 +1,19 @@
 Summary:       Utilities for mounting and managing CIFS mounts
 Summary:       Utilities for mounting and managing CIFS mounts
+Summary(pl.UTF-8):     Narzędzia do montowania i zarządzania montowaniami CIFS
 Name:          cifs-utils
 Name:          cifs-utils
-Version:       5.2
+Version:       5.5
 Release:       1
 License:       GPL v3
 Group:         Daemons
 Release:       1
 License:       GPL v3
 Group:         Daemons
-URL:           http://linux-cifs.samba.org/cifs-utils/
 Source0:       ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/%{name}-%{version}.tar.bz2
 Source0:       ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/%{name}-%{version}.tar.bz2
-# Source0-md5: 2ca839553cccd0c3042f7dd8737cc9de
-BuildRequires: autoconf
-BuildRequires: automake
+# Source0-md5: 4de6c660ccdb9506d0e2cff4f37b8707
+Patch0:                %{name}-heimdal.patch
+URL:           http://linux-cifs.samba.org/cifs-utils/
 BuildRequires: heimdal-devel >= 1.5.1-3
 BuildRequires: keyutils-devel
 BuildRequires: libcap-ng-devel
 BuildRequires: heimdal-devel >= 1.5.1-3
 BuildRequires: keyutils-devel
 BuildRequires: libcap-ng-devel
+BuildRequires: libsmbclient-devel
 BuildRequires: libtalloc-devel
 BuildRequires: libtalloc-devel
-BuildRequires: samba-devel
 Requires:      keyutils
 Obsoletes:     mount-cifs
 Conflicts:     samba-client < 1:3.6.0
 Requires:      keyutils
 Obsoletes:     mount-cifs
 Conflicts:     samba-client < 1:3.6.0
@@ -27,11 +27,23 @@ this package work in conjunction with support in the kernel to allow
 one to mount a SMB/CIFS share onto a client and use it as if it were a
 standard Linux file system.
 
 one to mount a SMB/CIFS share onto a client and use it as if it were a
 standard Linux file system.
 
+%description -l pl.UTF-8
+Protokół SMB/CIFS to standardowy protokół współdzielenia plików
+szeroko wykorzystywany na komputerach z systemem Microsoft Windows.
+Ten pakiet zawiera narzędzia do montowania pod Linuksem udziałów
+udostępnionych poprzez protokół SMB/CIFS. Narzędzia z tego pakietu
+współpracując z obsługą w jądrze pozwalają na montowanie udziałów
+SMB/CIFS na systemie klienckim tak, jakby był to standardowy
+linuksowy system plików.
+
 %prep
 %setup -q
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure \
 
 %build
 %configure \
+       WBCLIENT_CFLAGS=" " \
+       WBCLIENT_LIBS="-lwbclient" \
        --with-libcap-ng=yes \
        --enable-cifsupcall \
        --enable-cifsidmap \
        --with-libcap-ng=yes \
        --enable-cifsupcall \
        --enable-cifsidmap \
@@ -51,10 +63,12 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) /sbin/mount.cifs
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) /sbin/mount.cifs
+%attr(755,root,root) %{_bindir}/cifscreds
 %attr(755,root,root) %{_bindir}/getcifsacl
 %attr(755,root,root) %{_bindir}/setcifsacl
 %attr(755,root,root) %{_sbindir}/cifs.upcall
 %attr(755,root,root) %{_sbindir}/cifs.idmap
 %attr(755,root,root) %{_bindir}/getcifsacl
 %attr(755,root,root) %{_bindir}/setcifsacl
 %attr(755,root,root) %{_sbindir}/cifs.upcall
 %attr(755,root,root) %{_sbindir}/cifs.idmap
+%{_mandir}/man1/cifscreds.1*
 %{_mandir}/man1/getcifsacl.1*
 %{_mandir}/man1/setcifsacl.1*
 %{_mandir}/man8/cifs.upcall.8*
 %{_mandir}/man1/getcifsacl.1*
 %{_mandir}/man1/setcifsacl.1*
 %{_mandir}/man8/cifs.upcall.8*
This page took 0.143912 seconds and 4 git commands to generate.