]> git.pld-linux.org Git - packages/chrony.git/blobdiff - chrony.spec
- release 3, rebuild against libnettle.so.6 (nettle-3.5)
[packages/chrony.git] / chrony.spec
index 57c15bf1bcc4690707ae98994de92e6aed52facc..c724edb02b1be3ba614fa0c4d29142f138d5be8b 100644 (file)
@@ -1,24 +1,26 @@
-%define                subver  pre1
-%define                rel     1
+%define                nettle_ver      3.4
+
 Summary:       An NTP client/server
 Name:          chrony
-Version:       1.24
-Release:       0.%{subver}.%{rel}
+Version:       3.3
+Release:       3
 License:       GPL v2
 Group:         Daemons
-URL:           http://chrony.tuxfamily.org/
-Source0:       http://download.tuxfamily.org/chrony/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: e1f0d15bc0830f5f6bf80da2d72eb16a
+Source0:       http://download.tuxfamily.org/chrony/%{name}-%{version}.tar.gz
+# Source0-md5: 81ab62cf5d60b4b3fa8cd2c1b267ffd9
 Source1:       %{name}.conf
 Source2:       %{name}.keys
 Source3:       %{name}d.sysconfig
 Source4:       %{name}d.init
 Source5:       %{name}.logrotate
+URL:           http://chrony.tuxfamily.org/
+BuildRequires: asciidoc
 BuildRequires: bison
 BuildRequires: libcap-devel
+BuildRequires: nettle-devel >= %{nettle_ver}
+BuildRequires: nss-devel
 BuildRequires: readline-devel
-BuildRequires: rpmbuild(macros) >= 1.202
-BuildRequires: texinfo
+BuildRequires: rpmbuild(macros) >= 1.453
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
@@ -28,11 +30,18 @@ Requires(pre):      /usr/sbin/useradd
 Provides:      group(ntp)
 Provides:      ntpdaemon
 Provides:      user(ntp)
+Requires:      nettle >= %{nettle_ver}
 Obsoletes:     ntpdaemon
+Conflicts:     logrotate < 3.8.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/ntp
 
+# assume gcc 3.4 has it
+%if "%{cc_version}" >= "3.4"
+%define                specflags       -pie -fpie
+%endif
+
 %description
 A client/server for the Network Time Protocol, this program keeps your
 computer's clock accurate. It was specially designed to support
@@ -40,21 +49,21 @@ systems with dial-up Internet connections, and also supports computers
 in permanently connected environments.
 
 %prep
-%setup -q -n %{name}-%{version}-%{subver}
+%setup -q
 
 %build
 # NOTE: It is not autoconf generated configre
 CC="%{__cc}" \
-CFLAGS="%{rpmcflags} -pie -fpie -Wmissing-prototypes -Wall" \
+CFLAGS="%{rpmcflags} -Wmissing-prototypes -Wall" \
 CPPFLAGS="%{rpmcppflags}" \
 ./configure \
        --prefix=%{_prefix} \
        --sysconfdir=%{_sysconfdir} \
        --docdir=%{_docdir} \
-       --with-readline \
        --without-editline \
 
-%{__make} getdate all docs
+%{__make} getdate all docs \
+       ADOC=asciidoc
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -67,7 +76,7 @@ install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} \
 rm -rf $RPM_BUILD_ROOT%{_docdir}
 
 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
+cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/keys
 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/chronyd
 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/chrony
 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/chronyd
@@ -82,7 +91,6 @@ rm -rf $RPM_BUILD_ROOT
 %useradd -u 246 -d %{_localstatedir}/lib/ntp -g ntp -c "NTP Daemon" ntp
 
 %post
-/usr/sbin/fix-info-dir -c %{_infodir}
 /sbin/chkconfig --add chronyd
 %service chronyd restart
 
@@ -90,7 +98,6 @@ rm -rf $RPM_BUILD_ROOT
 if [ "$1" = "0" ]; then
        %service chronyd stop
        /sbin/chkconfig --del chronyd
-       /usr/sbin/fix-info-dir -c %{_infodir}
 fi
 
 %postun
@@ -101,20 +108,18 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc NEWS README chrony.txt faq.txt examples/*
+%doc NEWS README FAQ examples/* doc/{faq,installation}.html
 %dir %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.conf
-%attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.keys
+%attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/keys
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/chronyd
 %config(noreplace) /etc/logrotate.d/chrony
 %attr(754,root,root) /etc/rc.d/init.d/chronyd
 %attr(755,root,root) %{_bindir}/chronyc
 %attr(755,root,root) %{_sbindir}/chronyd
-%{_mandir}/man1/chrony.1*
 %{_mandir}/man1/chronyc.1*
 %{_mandir}/man5/chrony.conf.5*
 %{_mandir}/man8/chronyd.8*
-%{_infodir}/chrony.info*
 
 %dir %attr(770,root,ntp) /var/lib/ntp
 %attr(640,ntp,ntp) %ghost /var/lib/ntp/drift
This page took 0.068648 seconds and 4 git commands to generate.