]> git.pld-linux.org Git - packages/chromium-bsu.git/blob - chromium-bsu.spec
- just a rename to chromium-fix-openal-configurecall.patch
[packages/chromium-bsu.git] / chromium-bsu.spec
1 Summary:        Chromium B.S.U. is a fast paced, arcade-style space shooter
2 Summary(pl):    Chromium B.S.U. to szybko tocz±ca siê strzelanina
3 Name:           chromium
4 Version:        0.9.12
5 Release:        8
6 License:        Artistic
7 Group:          X11/Applications/Games
8 Group(de):      X11/Applikationen/Spiele
9 Group(pl):      X11/Aplikacje/Gry
10 Source0:        http://www.reptilelabour.com/software/files/chromium/%{name}-src-%{version}.tar.gz
11 Source1:        http://www.reptilelabour.com/software/files/chromium/%{name}-data-%{version}.tar.gz
12 Source2:        %{name}.desktop
13 Source3:        %{name}-setup.desktop
14 Source4:        %{name}.png
15
16 # This one allows definitions of all compile flags directly in .spec
17 # by just commenting out those settings in Makefiles
18 # This is patch from Mandrake Cooker
19 Patch0:         chromium-0.9.12-fix-flags.patch
20 # To be further investigated if this patch is needed
21 # This is patch from Mandrake Cooker
22 Patch1:         chromium-0.9.11-glibc-2.2.2.patch
23 #Patch0 from RH obsoleted by much better idea from Mandrake
24 #to setup OPENAL_OPT_FLAGS in spec (patch3 below)
25 # This is patch from Mandrake Cooker
26 #Patch0:        %{name}-config.patch
27 Patch3:         chromium-0.9.12-fix-openal-configurecall.patch
28 # This one fixes problems with ./configure (/bin/sh is NOT a link
29 # to /bin/bash in PLD
30 # This is patch from fastviper
31 Patch4:         %{name}-configure_needs_bash.patch
32 # As PLD doesn't have any QTDIR it's necessary to change Makefile
33 # so that /usr/X11R6 could be one.
34 # This is patch from fastviper
35 Patch5:         %{name}-qt.patch
36 # This patch comments out CC and CCX settings in Makefile allowing
37 # use of nondefault compiler/linker. export CC from .spec
38 # This is patch from fastviper
39 Patch6:         %{name}-use_proper_CC.patch
40
41 BuildRequires:  libogg-devel qt-devel SDL-devel libvorbis-devel
42 URL:            http://www.reptilelabour.com/software/chromium/
43 BuildPrereq:    SDL-devel >= 1.1.6
44 BuildRequires:  OpenGL-devel
45 #BuildPrereq:   kdelibs-sound-devel
46 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48
49 %define         _prefix         /usr/X11R6/
50 %define         _mandir         %{_prefix}/man
51 %define         _bindir         %{_prefix}/bin
52 %define         _gamesbindir    %{_bindir}
53 %define         _gamesdatadir   %{_prefix}/share/games
54 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
55 %define         _noreqdep       libGL.so.1 libGLU.so.1 libGLcore.so.1
56
57
58 %description
59 You are captain of the cargo ship Chromium B.S.U., responsible for
60 delivering supplies to our troops on the front line. Your ship has a
61 small fleet of robotic fighters which you control from the relative
62 safety of the Chromium vessel.
63 - Do not let ANY enemy ships get past your fighters! Each enemy ship
64   that makes it past the bottom of the screen will attack the Chromium,
65   and you lose a fighter.
66 - Use your fighters as weapons! Crash into enemies to destroy them
67   before they can get past you.
68 - Strategic suicide is a powerful tactic! When the Chromium launches a
69   new fighter, it releases a high energy burst which destroys all
70   enemies in range.
71 - Self-destruct to preserve your ammunition! A double-right-click will
72   cause your current fighter to self-destruct. Before the ship blows up,
73   it ejects its ammunition so that the next fighter can pick it up.
74
75 %description -l pl
76 Jeste¶ kapitanem statku Chromium B.S.U, odpowiedzialnego za
77 dostarczenie zapasów do oddzia³ów na linii frontu. Statek ma ma³±
78 flotê automatycznych my¶liwców, którymi mo¿esz kierowaæ ze statku.
79 - Nie pozwól ¯ADNEMU wrogowi przej¶æ za swoje my¶liwce! Ka¿dy statek
80   który dotrze na dó³ ekranu zaatakuje Chromium i stracisz my¶liwca.
81 - U¿ywaj my¶liwców jako broni! Uderzaj we wrogów aby zniszczyæ ich
82   zanim oni przedostan± siê do ciebie.
83 - Strategiczne samobójstwo to dobra taktyka! Kiedy Chromium odpala
84   nowego my¶liwca, wytwarza du¿o energii, która niszczy wszystkich
85   wrogów w zasiêgu.
86 - Autodestrukcja pozwala zachowaæ amunicjê - przed wysadzeniem siê
87   my¶liwiec zwraca amunicjê tak, ¿e nastêpny mo¿e j± przej±æ.
88
89
90 %package setup
91 Summary:        Setup frontend for Chromium
92 Summary(pl):    Graficzny konfigurator Chromium
93 Group:          X11/Applications/Games
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       qt
96
97 %description setup
98 This package contains the setup frontend (using QT) to ease
99 configuration of Chromium, especially for its playlist features.
100
101 %description setup -l pl
102 Ten pakiet zawiera graficzny konfigurator (napisany w QT) u³atwiaj±cy
103 ustalanie parametrów dla gry Chromium, szczególnie je¶li chodzi o 
104 listê muzyki do odtwarzania.
105
106 %prep
107 %setup -q -n Chromium-0.9
108 %patch0 -p0
109 %patch1 -p0
110 %patch3 -p0
111 %patch4 -p1
112 %patch5 -p1
113 %patch6 -p1
114 find . -type d -name .xvpics -exec rm -rf {} \; ||:
115
116
117 %build
118 export CFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
119 export CXXFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
120 export CC=%{__cc}
121 export CXX=%{__cc}
122 export LINK=%{__cc}
123 export DEFS="%{rpmcflags} -DGAMESBINDIR=\\\"%{_gamesbindir}\\\" \
124             -DPKGDATADIR=\\\"%{_gamesdatadir}/Chromium-0.9\\\" -DUSE_SDL \
125             `sdl-config --cflags` -DOLD_OPENAL -DAUDIO_OPENAL -D_REENTRANT \
126             -I../../include -I../support/openal/linux/include -I../support/openal/include"
127 export OPENAL_CONFIG_OPTS="./configure %{_target_platform} --with-gcc=%{__cc}"
128 export QTDIR=%{_prefix}
129 ./configure --enable-vorbis
130 %{__make}
131
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{%{_applnkdir}/{Games/Arcade,Settings},%{_pixmapsdir},%{_gamesbindir},%{_gamesdatadir}}
136
137 # It is enough to install one file
138 #%{__make} install DESTDIR=RPM_BUILD_ROOT
139 install bin/* $RPM_BUILD_ROOT/%{_gamesbindir}
140
141 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games/Arcade/%{name}.desktop
142 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Settings/%{name}.desktop
143 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
144
145 #This installs datafiles
146 tar zxvf %{SOURCE1} -C $RPM_BUILD_ROOT/%{_gamesdatadir}
147
148 %files
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/*
151 %{_pixmapsdir}/chromium.png
152 %{_applnkdir}/Games/Arcade/*
153 %{_applnkdir}/Settings/*
154 #%{_prefix}/games/chromium
155 %{_gamesdatadir}/*
156
157 %files setup
158 %defattr(644,root,root,755)
159 %doc README
160 %attr(755,root,root) %{_bindir}/chromium-setup
161  
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
This page took 0.05429 seconds and 3 git commands to generate.