]> git.pld-linux.org Git - packages/chromium-bsu.git/blob - chromium-bsu.spec
54ac29099d39177d5470e3ac527965b8896b4377
[packages/chromium-bsu.git] / chromium-bsu.spec
1 Summary:        Chromium B.S.U. is a fast paced, arcade-style space shooter
2 Summary(pl):    Chromium B.S.U. to szybko tocz±ca siê strzelanina
3 Name:           chromium
4 Version:        0.9.12
5 Release:        8
6 License:        Artistic
7 Group:          X11/Applications/Games
8 Source0:        http://www.reptilelabour.com/software/files/chromium/%{name}-src-%{version}.tar.gz
9 Source1:        http://www.reptilelabour.com/software/files/chromium/%{name}-data-%{version}.tar.gz
10 Source2:        %{name}.desktop
11 Source3:        %{name}-setup.desktop
12 Source4:        %{name}.png
13 Patch0:         %{name}-fix-flags.patch
14 Patch1:         %{name}-glibc-2.2.2.patch
15 Patch3:         %{name}-fix-openal-configurecall.patch
16 Patch4:         %{name}-configure_needs_bash.patch
17 Patch5:         %{name}-qt.patch
18 Patch6:         %{name}-use_proper_CC.patch
19 URL:            http://www.reptilelabour.com/software/chromium/
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  SDL-devel >= 1.1.6
22 BuildRequires:  libogg-devel libvorbis-devel
23 BuildRequires:  smpeg >= 0.4.2
24 BuildRequires:  qt-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/X11R6/
28 %define         _mandir         %{_prefix}/man
29 %define         _bindir         %{_prefix}/bin
30 %define         _datadir        %{_prefix}/share/games
31 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
32 %define         _noreqdep       libGL.so.1 libGLU.so.1 libGLcore.so.1
33
34 %description
35 You are captain of the cargo ship Chromium B.S.U., responsible for
36 delivering supplies to our troops on the front line. Your ship has a
37 small fleet of robotic fighters which you control from the relative
38 safety of the Chromium vessel.
39 - Do not let ANY enemy ships get past your fighters! Each enemy ship
40   that makes it past the bottom of the screen will attack the Chromium,
41   and you lose a fighter.
42 - Use your fighters as weapons! Crash into enemies to destroy them
43   before they can get past you.
44 - Strategic suicide is a powerful tactic! When the Chromium launches a
45   new fighter, it releases a high energy burst which destroys all
46   enemies in range.
47 - Self-destruct to preserve your ammunition! A double-right-click will
48   cause your current fighter to self-destruct. Before the ship blows up,
49   it ejects its ammunition so that the next fighter can pick it up.
50
51 %description -l pl
52 Jeste¶ kapitanem statku Chromium B.S.U, odpowiedzialnego za
53 dostarczenie zapasów do oddzia³ów na linii frontu. Statek ma ma³±
54 flotê automatycznych my¶liwców, którymi mo¿esz kierowaæ ze statku.
55 - Nie pozwól ¯ADNEMU wrogowi przej¶æ za swoje my¶liwce! Ka¿dy statek
56   który dotrze na dó³ ekranu zaatakuje Chromium i stracisz my¶liwca.
57 - U¿ywaj my¶liwców jako broni! Uderzaj we wrogów aby zniszczyæ ich
58   zanim oni przedostan± siê do ciebie.
59 - Strategiczne samobójstwo to dobra taktyka! Kiedy Chromium odpala
60   nowego my¶liwca, wytwarza du¿o energii, która niszczy wszystkich
61   wrogów w zasiêgu.
62 - Autodestrukcja pozwala zachowaæ amunicjê - przed wysadzeniem siê
63   my¶liwiec zwraca amunicjê tak, ¿e nastêpny mo¿e j± przej±æ.
64
65 %package setup
66 Summary:        Setup frontend for Chromium
67 Summary(pl):    Graficzny konfigurator Chromium
68 Group:          X11/Applications/Games
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       qt
71
72 %description setup
73 This package contains the setup frontend (using QT) to ease
74 configuration of Chromium, especially for its playlist features.
75
76 %description setup -l pl
77 Ten pakiet zawiera graficzny konfigurator (napisany w QT) u³atwiaj±cy
78 ustalanie parametrów dla gry Chromium, szczególnie je¶li chodzi o
79 listê muzyki do odtwarzania.
80
81 %prep
82 %setup -q -n Chromium-0.9
83 %patch0 -p0
84 %patch1 -p0
85 %patch3 -p0
86 %patch4 -p1
87 %patch5 -p1
88 %patch6 -p1
89 find . -type d -name .xvpics -exec rm -rf {} \; ||:
90
91 %build
92 export CFLAGS="%{rpmcflags} -fno-omit-frame-pointer -pipe"
93 export CXXFLAGS="%{rpmcflags} -fno-omit-frame-pointer -pipe"
94 export CC=%{__cc}
95 export CXX=%{__cc}
96 export LINK=%{__cc}
97 export DEFS="%{rpmcflags} -DGAMESBINDIR=\\\"%{_bindir}\\\" \
98             -DPKGDATADIR=\\\"%{_datadir}/Chromium-0.9\\\" -DUSE_SDL \
99             `sdl-config --cflags` -DOLD_OPENAL -DAUDIO_OPENAL -D_REENTRANT \
100             -I../../include -I../support/openal/linux/include -I../support/openal/include"
101 #export OPENAL_CONFIG_OPTS="./configure %{_target_platform} --with-gcc=%{__cc}"
102 export OPENAL_CONFIG_OPTS="./configure --with-gcc=%{__cc}"
103 export QTDIR=%{_prefix}
104 ./configure --enable-vorbis
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_applnkdir}/{Games/Arcade,Settings},%{_pixmapsdir},%{_bindir},%{_datadir}}
110
111 # It is enough to install one file
112 #%{__make} install DESTDIR=RPM_BUILD_ROOT
113 install bin/* $RPM_BUILD_ROOT/%{_bindir}
114
115 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games/Arcade/%{name}.desktop
116 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Settings/%{name}.desktop
117 install %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
118
119 gzip -9nf README LICENSE
120
121 #This installs datafiles
122 tar zxvf %{SOURCE1} -C $RPM_BUILD_ROOT/%{_datadir}
123 find . -type d -name CVS -exec rm -rf {} \; ||:
124
125 %files
126 %defattr(644,root,root,755)
127 %doc LICENSE.gz
128 %attr(755,root,root) %{_bindir}/*
129 %{_datadir}/*
130 %{_pixmapsdir}/chromium.png
131 %{_applnkdir}/Games/Arcade/*
132
133 %files setup
134 %defattr(644,root,root,755)
135 %doc README.gz
136 %attr(755,root,root) %{_bindir}/chromium-setup
137 %{_applnkdir}/Settings/*
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
This page took 0.057592 seconds and 2 git commands to generate.