]> git.pld-linux.org Git - packages/chromium-browser.git/commitdiff
fix nacl building auto/th/chromium-browser-21.0.1180.57-1
authorElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 19:40:29 +0000 (22:40 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 19:40:29 +0000 (22:40 +0300)
fix depending on glibc nacl toolchain
https://bugs.gentoo.org/show_bug.cgi?id=417019

chromium-browser.sh [changed mode: 0644->0755]
chromium-browser.spec
chromium-ppapi.patch [new file with mode: 0644]
clean-source.sh [changed mode: 0644->0755]
find-lang.sh [changed mode: 0644->0755]
get-source.sh [changed mode: 0644->0755]
update-source.sh [changed mode: 0644->0755]

old mode 100644 (file)
new mode 100755 (executable)
index 228330a1ebf35bc04504c2147208c45b986bb5e7..322a2a31a20085e6777f671f0b4d92cc975bb586 100644 (file)
@@ -52,7 +52,7 @@
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
 Version:       21.0.1180.57
-Release:       0.1
+Release:       1
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
 Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
@@ -73,6 +73,7 @@ Patch5:               options-support.patch
 Patch6:                get-webkit_revision.patch
 Patch7:                dlopen_sonamed_gl.patch
 Patch8:                chromium_useragent.patch.in
+Patch9:                chromium-ppapi.patch
 # https://bugs.gentoo.org/show_bug.cgi?id=393471
 # libjpeg-turbo >= 1.1.90 supports that feature
 Patch11:       chromium-revert-jpeg-swizzle-r2.patch
@@ -222,6 +223,7 @@ ln -s %{SOURCE7} src
 %patch6 -p1
 %patch7 -p1
 cd src
+%patch9 -p0
 %{!?with_libjpegturbo:%patch11 -p0}
 %patch15 -p1
 %patch16 -p1
@@ -243,6 +245,8 @@ install -d linux_x86_newlib/x86_64-nacl/lib32
 install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
 install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
 install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
+# link newlib toolchain to glibc as well, see gentoo bug #417019
+#ln -s linux_x86_newlib linux_x86
 cd linux_x86_newlib/x86_64-nacl/bin
 ln -s %{_bindir}/x86_64-nacl-gcc gcc
 ln -s %{_bindir}/x86_64-nacl-g++ g++
@@ -280,7 +284,12 @@ test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
        -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
        -Dffmpeg_branding=Chrome \
        -Dproprietary_codecs=1 \
-       %{!?with_nacl:-Ddisable_nacl=1} \
+%if %{with nacl}
+       %{?_:# Disable glibc Native Client toolchain, we don't need it (gentoo bug #417019).} \
+       -Ddisable_glibc=1 \
+%else
+       -Ddisable_nacl=1 \
+%endif
        %{!?with_sse2:-Ddisable_sse2=1} \
        %{?with_selinux:-Dselinux=1} \
        %{gyp_with cups} \
@@ -338,6 +347,8 @@ install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 %endif
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
 
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
+
 %if %{with nacl}
 # Install Native Client files on platforms that support it.
 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
@@ -408,8 +419,6 @@ fi
 %{_libdir}/%{name}/locales/en-US.pak
 %dir %{_libdir}/%{name}/resources
 %{_libdir}/%{name}/resources/inspector
-%dir %{_libdir}/%{name}/resources/extension
-%{_libdir}/%{name}/resources/extension/demo
 %dir %{_libdir}/%{name}/themes
 %dir %{_libdir}/%{name}/extensions
 %dir %{_libdir}/%{name}/plugins
diff --git a/chromium-ppapi.patch b/chromium-ppapi.patch
new file mode 100644 (file)
index 0000000..d0dcf99
--- /dev/null
@@ -0,0 +1,13 @@
+from gentoo chromium-ppapi-r0.patch
+
+--- ppapi/ppapi_untrusted.gyp.orig     2012-06-12 10:20:16.000000000 +0200
++++ ppapi/ppapi_untrusted.gyp  2012-06-12 10:20:52.000000000 +0200
+@@ -80,7 +80,7 @@
+         ],
+       },
+       'conditions': [
+-        ['target_arch!="arm"', {
++        ['target_arch!="arm" and disable_glibc==0', {
+           'variables': {
+             'build_glibc': 1,
+             # NOTE: Use /lib, not /lib64 here; it is a symbolic link which
old mode 100644 (file)
new mode 100755 (executable)
index a0b2a0c..9674043
@@ -106,6 +106,7 @@ remove_nonessential_dirs() {
        tools/stats_viewer \
        tools/symsrc \
        tools/valgrind \
+       tools/gyp/test \
        ; do
                rm -vfr "$dir"
        done
old mode 100644 (file)
new mode 100755 (executable)
old mode 100644 (file)
new mode 100755 (executable)
old mode 100644 (file)
new mode 100755 (executable)
This page took 0.04166 seconds and 4 git commands to generate.