]> git.pld-linux.org Git - packages/chromium-browser.git/commitdiff
up to 45.0.2454.26
authorElan Ruusamäe <glen@delfi.ee>
Wed, 16 Sep 2015 15:08:23 +0000 (18:08 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 16 Sep 2015 15:08:23 +0000 (18:08 +0300)
chromium-browser.spec
clean-source.sh
nacl-verbose.patch

index b2c5d43bc3f8d64479ba0fce0809824b5b9c1cf2..128e4d26aae3825d224114b212bed7b61a21043c 100644 (file)
@@ -18,7 +18,7 @@
 %bcond_without system_flac             # system flac
 %bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
 %bcond_without system_harfbuzz # system harfbuzz
-%bcond_with    system_icu      # system icu, disabled: http://bugs.icu-project.org/trac/ticket/11358
+%bcond_without system_icu      # system icu
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
@@ -34,9 +34,9 @@
 %bcond_without system_snappy   # system snappy
 %bcond_without system_speex    # system speex
 %bcond_with    system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
-%bcond_without system_libsrtp  # system srtp (can be used if using bundled libjingle)
+%bcond_without system_libsrtp  # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
 %bcond_with            system_v8               # system v8
-%bcond_without system_libvpx   # system libvpx
+%bcond_without system_libvpx   # system libvpx, http://crbug.com/494939
 %bcond_without system_yasm             # system yasm
 %bcond_without system_zlib             # system zlib
 %bcond_with    tcmalloc                # use tcmalloc
@@ -72,9 +72,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          44.0.2403
-%define                basever         107
-%define                patchver        130
+%define                branch          45.0.2454
+%define                basever         26
+#define                patchver        130
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -86,8 +86,8 @@ Version:      %{branch}.%{basever}
 Release:       1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: 8686c4033cb1d25d0c60c9b6e09c65e1
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
+# Source0-md5: 4cc5d5b965f1bfc99fb387828ef48295
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
 # Patch0-md5:  02973b87b9564ed36220497b4bf83109
index 1e5576753635549c3cb4dc2d4de77c108c308637..0bba878005653c8e7646b1ad741e001b1269c250 100755 (executable)
@@ -606,6 +606,7 @@ clean_third_party() {
                '!' -path 'third_party/angle/src/compiler/*' \
                '!' -path 'third_party/angle/src/enumerate_files.py' \
                '!' -path 'third_party/angle/src/third_party/compiler/*' \
+               '!' -path 'third_party/boringssl/*' \
                '!' -path 'third_party/brotli/*' \
                '!' -path 'third_party/cacheinvalidation/*' \
                '!' -path 'third_party/cld/*' \
@@ -613,6 +614,7 @@ clean_third_party() {
                '!' -path 'third_party/cros_system_api/*' \
                '!' -path 'third_party/cython/python_flags.py' \
                '!' -path 'third_party/dom_distiller_js/*' \
+               '!' -path 'third_party/devscripts/*' \
                '!' -path 'third_party/ffmpeg/*' \
                '!' -path 'third_party/fips181/*' \
                '!' -path 'third_party/flot/*.js' \
@@ -631,6 +633,7 @@ clean_third_party() {
                '!' -path 'third_party/libaddressinput/*' \
                '!' -path 'third_party/libjingle/*' \
                '!' -path 'third_party/libphonenumber/*' \
+               '!' -path 'third_party/libsecret/*' \
                '!' -path 'third_party/libusb/*' \
                '!' -path 'third_party/libva/*' \
                '!' -path 'third_party/libvpx/*' \
@@ -1061,8 +1064,7 @@ remove_bundled_libraries() {
                third_party/adobe/flash/flapper_version.h \
                third_party/jinja2 \
                third_party/markupsafe/ \
-               third_party/ply \
-               third_party/fips181 \
+               third_party/ply/ \
                'base/third_party/dmg_fp' \
                'base/third_party/dynamic_annotations' \
                'base/third_party/icu' \
@@ -1082,11 +1084,13 @@ remove_bundled_libraries() {
                'third_party/analytics' \
                'third_party/angle' \
                'third_party/angle/src/third_party/compiler' \
+               'third_party/boringssl' \
                'third_party/brotli' \
                'third_party/cacheinvalidation' \
                'third_party/cld_2' \
                'third_party/cros_system_api' \
                'third_party/cython/python_flags.py' \
+               'third_party/devscripts' \
                'third_party/dom_distiller_js' \
                'third_party/dom_distiller_js/dist/proto_gen/third_party/dom_distiller_js' \
                'third_party/ffmpeg' \
@@ -1097,20 +1101,20 @@ remove_bundled_libraries() {
                'third_party/google_input_tools/third_party/closure_library/third_party/closure' \
                'third_party/hunspell' \
                'third_party/iccjpeg' \
-               'third_party/icu' \
                'third_party/jstemplate' \
                'third_party/khronos' \
                'third_party/leveldatabase' \
+               'third_party/libXNVCtrl' \
                'third_party/libaddressinput' \
                'third_party/libjingle' \
                'third_party/libphonenumber' \
+               'third_party/libsecret' \
                'third_party/libsrtp' \
                'third_party/libudev' \
                'third_party/libusb' \
                'third_party/libvpx' \
                'third_party/libvpx/source/libvpx/third_party/x86inc' \
                'third_party/libxml/chromium' \
-               'third_party/libXNVCtrl' \
                'third_party/libyuv' \
                'third_party/lss' \
                'third_party/lzma_sdk' \
@@ -1123,9 +1127,14 @@ remove_bundled_libraries() {
                'third_party/opus' \
                'third_party/ots' \
                'third_party/pdfium' \
+               'third_party/pdfium/third_party/agg23' \
                'third_party/pdfium/third_party/base' \
                'third_party/pdfium/third_party/bigint' \
                'third_party/pdfium/third_party/freetype' \
+               'third_party/pdfium/third_party/lcms2-2.6' \
+               'third_party/pdfium/third_party/libjpeg' \
+               'third_party/pdfium/third_party/libopenjpeg20' \
+               'third_party/pdfium/third_party/zlib_v128' \
                'third_party/polymer' \
                'third_party/protobuf' \
                'third_party/qcms' \
@@ -1136,15 +1145,14 @@ remove_bundled_libraries() {
                'third_party/sqlite' \
                'third_party/tcmalloc' \
                'third_party/trace-viewer' \
-               'third_party/trace-viewer/third_party/components/polymer' \
-               'third_party/trace-viewer/third_party/d3' \
-               'third_party/trace-viewer/third_party/gl-matrix' \
-               'third_party/trace-viewer/third_party/jszip' \
-               'third_party/trace-viewer/third_party/tvcm' \
-               'third_party/trace-viewer/third_party/tvcm/third_party/beautifulsoup/polymer_soup.py' \
-               'third_party/trace-viewer/third_party/tvcm/third_party/rcssmin' \
-               'third_party/trace-viewer/third_party/tvcm/third_party/rjsmin' \
-               'third_party/undoview' \
+               'third_party/trace-viewer/tracing/third_party/components/polymer' \
+               'third_party/trace-viewer/tracing/third_party/d3' \
+               'third_party/trace-viewer/tracing/third_party/gl-matrix' \
+               'third_party/trace-viewer/tracing/third_party/jszip' \
+               'third_party/trace-viewer/tracing/third_party/tvcm' \
+               'third_party/trace-viewer/tracing/third_party/tvcm/third_party/beautifulsoup/polymer_soup.py' \
+               'third_party/trace-viewer/tracing/third_party/tvcm/third_party/rcssmin' \
+               'third_party/trace-viewer/tracing/third_party/tvcm/third_party/rjsmin' \
                'third_party/usrsctp' \
                'third_party/web-animations-js' \
                'third_party/webdriver' \
@@ -1154,7 +1162,6 @@ remove_bundled_libraries() {
                'third_party/zlib/google' \
                'url/third_party/mozilla' \
                'v8/src/third_party/fdlibm' \
-               'v8/src/third_party/kernel' \
                'v8/src/third_party/valgrind' \
                --do-print \
                --do-remove
index bfb411ded2a7fbc85e0e389eb522fe5b36b792a6..8fcd123d8c0e8b198ff0ac5c15aafbbfea069297 100644 (file)
@@ -1,5 +1,5 @@
---- chromium-browser-35.0.1916.114/native_client/build/untrusted.gypi~ 2014-05-14 22:23:54.000000000 +0300
-+++ chromium-browser-35.0.1916.114/native_client/build/untrusted.gypi  2014-05-25 23:39:02.438068697 +0300
+--- chromium-browser-45.0.2454.26/native_client/build/untrusted.gypi~  2015-08-09 15:45:16.000000000 +0300
++++ chromium-browser-45.0.2454.26/native_client/build/untrusted.gypi   2015-08-09 19:39:50.812639234 +0300
 @@ -57,7 +57,7 @@
            'build_irt': 0,
            'disable_glibc%': 0,
            'enable_x86_32': 0,
            'enable_x86_64': 0,
            'enable_arm': 1,
-@@ -166,7 +166,7 @@
-           'build_irt': 0,
-           'disable_glibc%': 1,
+@@ -153,7 +153,7 @@
+           'build_nonsfi_helper': 0,
+           'disable_glibc%': 0,
            'disable_bionic%': 1,
 -          'extra_args': [],
 +          'extra_args': ['--verbose'],
            'enable_x86_32': 0,
            'enable_x86_64': 0,
-           'enable_arm': 0,
+           'enable_arm': 1,
This page took 0.062644 seconds and 4 git commands to generate.