]> git.pld-linux.org Git - packages/chromium-browser.git/commitdiff
updated/added patches
authorElan Ruusamäe <glen@delfi.ee>
Sat, 12 Apr 2014 11:13:08 +0000 (14:13 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 12 Apr 2014 11:13:08 +0000 (14:13 +0300)
chromium-browser.spec
depot-tools.patch [new file with mode: 0644]
gn.patch
system-ffmpeg.patch [deleted file]
system-libxnvctrl.patch [deleted file]
system-mesa.patch
system-ply.patch

index 12937f46ba668f7ff8eeb9ccccb8c4939c496c3d..60da4b7c08fefba9160a7b2b5dc7d61730b6ecbf 100644 (file)
@@ -93,11 +93,9 @@ Patch2:              enable-video-decode-accel.patch
 Patch4:                path-libpdf.patch
 Patch7:                dlopen_sonamed_gl.patch
 Patch8:                chromium_useragent.patch.in
-Patch10:       system-libxnvctrl.patch
 # https://bugs.gentoo.org/show_bug.cgi?id=393471
 # libjpeg-turbo >= 1.1.90 supports that feature
 Patch11:       chromium-revert-jpeg-swizzle-r2.patch
-Patch12:       system-ffmpeg.patch
 Patch15:       nacl-build-irt.patch
 Patch16:       nacl-linkingfix.patch
 Patch18:       nacl-no-untar.patch
@@ -109,6 +107,7 @@ Patch30:    system-ply.patch
 Patch31:       system-jinja.patch
 Patch32:       remove_bundled_libraries-stale.patch
 Patch33:       gn.patch
+Patch34:       depot-tools.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -272,11 +271,11 @@ zh-TW
 %prep
 %setup -qc
 %if "%{?patchver}" != ""
-cd %{name}-%{branch}.%{basever}
+cd chromium*-%{branch}.%{basever}
 %patch0 -p1
 cd ..
 %endif
-mv %{name}-%{branch}.%{basever}/* .
+mv chromium*-%{branch}.%{basever}/* .
 
 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
@@ -287,9 +286,6 @@ test "$chrome" = %{version}
 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
 test "$gyp_rev" = %{gyp_rev} || :
 
-. ./v8.sh
-v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
-
 # add chromium and pld to useragent
 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
@@ -304,20 +300,19 @@ ln -s %{SOURCE7} .
 #%patch2 -p1 NOT COMPILING
 %patch4 -p3
 %patch7 -p1
-%patch10 -p1
 %patch15 -p2
 %{!?with_libjpegturbo:%patch11 -p0}
-%patch12 -p1
 %patch16 -p1
 %patch28 -p1
 %patch25 -p1
 %{?with_nacl:%patch18 -p1}
 %patch24 -p2
 %patch26 -p2
-%patch30 -p1
-%patch31 -p0
+#%patch30 -p1
+#%patch31 -p0
 %patch32 -p1
-%patch33 -p0
+%patch33 -p1
+%patch34 -p0
 
 sh -x clean-source.sh \
        %{!?with_nacl:nacl=0} \
@@ -393,7 +388,7 @@ flags="
        %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
        %{?with_shared_libs:-Dlibrary=shared_library} \
        %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
-       -Dinclude_tests=0 \
+       -Dinclude_tests__=0 \
 %if %{with nacl}
        -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
        -Ddisable_glibc_untar=1 \
diff --git a/depot-tools.patch b/depot-tools.patch
new file mode 100644 (file)
index 0000000..19b92ce
--- /dev/null
@@ -0,0 +1,11 @@
+--- build/gyp_chromium.orig    2014-01-29 01:22:52.527247671 +0000
++++ build/gyp_chromium 2014-01-29 01:23:49.857623290 +0000
+@@ -38,8 +38,6 @@
+ sys.path.insert(1, os.path.join(chrome_src, 'third_party', 'WebKit',
+     'Source', 'build', 'scripts'))
+-import find_depot_tools
+-
+ # On Windows, Psyco shortens warm runs of build/gyp_chromium by about
+ # 20 seconds on a z600 machine with 12 GB of RAM, from 90 down to 70
+ # seconds.  Conversely, memory usage of build/gyp_chromium with Psyco
index 5cb8c0ebc82ab46c9aeb2c8c639a0c0593bfd25c..6fd32cb99867f33aab876f72e913f19582bbd8ba 100644 (file)
--- a/gn.patch
+++ b/gn.patch
@@ -1,12 +1,12 @@
---- build/gyp_chromium.orig    2013-12-11 03:07:03.941915587 +0000
-+++ build/gyp_chromium 2013-12-11 03:07:29.812073301 +0000
-@@ -221,9 +221,6 @@
+--- chromium-browser-34.0.1847.116/build/gyp_chromium~ 2014-04-02 22:03:54.000000000 +0300
++++ chromium-browser-34.0.1847.116/build/gyp_chromium  2014-04-12 01:46:51.740436678 +0300
+@@ -477,8 +477,7 @@
+     args.append('--check')
  
    supplemental_includes = GetSupplementalFiles()
 -  if not RunGN(supplemental_includes):
 -    sys.exit(1)
--
++
    args.extend(
        ['-I' + i for i in additional_include_files(supplemental_includes, args)])
  
diff --git a/system-ffmpeg.patch b/system-ffmpeg.patch
deleted file mode 100644 (file)
index da7ea1c..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-Fix HOST_OS detection in build_ffpeg.sh
-https://bugs.gentoo.org/show_bug.cgi?id=491466
-
-Enable gold linker
-https://bugs.gentoo.org/show_bug.cgi?id=491850
-
---- a/third_party/ffmpeg/chromium/scripts/build_ffmpeg.sh
-+++ b/third_party/ffmpeg/chromium/scripts/build_ffmpeg.sh
-@@ -75,7 +75,7 @@
- LIBAVUTIL_VERSION_MAJOR=52
- case $(uname -sm) in
--  Linux\ i386)
-+  Linux\ i?86)
-     HOST_OS=linux
-     HOST_ARCH=ia32
-     JOBS=$(grep processor /proc/cpuinfo | wc -l)
-@@ -85,6 +85,11 @@
-     HOST_ARCH=x64
-     JOBS=$(grep processor /proc/cpuinfo | wc -l)
-     ;;
-+  Linux\ arm*)
-+    HOST_OS=linux
-+    HOST_ARCH=arm
-+    JOBS=$(grep processor /proc/cpuinfo | wc -l)
-+    ;;
-   Darwin\ i386)
-     HOST_OS=mac
-     HOST_ARCH=ia32
-@@ -117,14 +122,6 @@
- echo "LD          = $(ld --version | head -n1)"
- echo
--# As of this writing gold 2.20.1-system.20100303 is unable to link FFmpeg.
--if ld --version | grep -q gold; then
--  echo "gold is unable to link FFmpeg"
--  echo
--  echo "Switch /usr/bin/ld to the regular binutils ld and try again"
--  exit 1
--fi
--
- # We want to use a sufficiently recent version of yasm on Windows.
- if [[ "$TARGET_OS" == "win" || "$TARGET_OS" == "win-vs2013" ]]; then
-   if !(which yasm 2>&1 > /dev/null); then
-@@ -292,14 +289,16 @@
-     add_flag_common --extra-cflags=-m32
-     add_flag_common --extra-ldflags=-m32
-   elif [ "$TARGET_ARCH" = "arm" ]; then
--    # This if-statement essentially is for chroot tegra2.
--    add_flag_common --enable-cross-compile
-+    if [ "$HOST_ARCH" != "arm" ]; then
-+      # This if-statement essentially is for chroot tegra2.
-+      add_flag_common --enable-cross-compile
--    # Location is for CrOS chroot. If you want to use this, enter chroot
--    # and copy ffmpeg to a location that is reachable.
--    add_flag_common --cross-prefix=/usr/bin/armv7a-cros-linux-gnueabi-
--    add_flag_common --target-os=linux
--    add_flag_common --arch=arm
-+      # Location is for CrOS chroot. If you want to use this, enter chroot
-+      # and copy ffmpeg to a location that is reachable.
-+      add_flag_common --cross-prefix=/usr/bin/armv7a-cros-linux-gnueabi-
-+      add_flag_common --target-os=linux
-+      add_flag_common --arch=arm
-+    fi
-     # TODO(ihf): ARM compile flags are tricky. The final options
-     # overriding everything live in chroot /build/*/etc/make.conf
-@@ -322,11 +321,13 @@
-     # NOTE: softfp/hardfp selected at gyp time.
-     add_flag_common --extra-cflags=-mfloat-abi=hard
-   elif [ "$TARGET_ARCH" = "arm-neon" ]; then
--    # This if-statement is for chroot arm-generic.
--    add_flag_common --enable-cross-compile
--    add_flag_common --cross-prefix=/usr/bin/armv7a-cros-linux-gnueabi-
--    add_flag_common --target-os=linux
--    add_flag_common --arch=arm
-+    if [ "$HOST_ARCH" != "arm" ]; then
-+      # This if-statement is for chroot arm-generic.
-+      add_flag_common --enable-cross-compile
-+      add_flag_common --cross-prefix=/usr/bin/armv7a-cros-linux-gnueabi-
-+      add_flag_common --target-os=linux
-+      add_flag_common --arch=arm
-+    fi
-     add_flag_common --enable-armv6
-     add_flag_common --enable-armv6t2
-     add_flag_common --enable-vfp
diff --git a/system-libxnvctrl.patch b/system-libxnvctrl.patch
deleted file mode 100644 (file)
index 8d063f0..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
---- /dev/null  2008-07-21 16:46:52.000000000 +0300
-+++ chromium-browser-28.0.1500.20/build/linux/unbundle/libXNVCtrl.gyp  2013-05-31 13:26:23.840330832 +0300
-@@ -0,0 +1,35 @@
-+# Copyright (c) 2013 The Chromium Authors. All rights reserved.
-+# Use of this source code is governed by a BSD-style license that can be
-+# found in the LICENSE file.
-+
-+{
-+  'targets': [
-+    {
-+      'target_name': 'libXNVCtrl',
-+      'type': 'none',
-+      'variables': {
-+        'headers_root_path': '.',
-+        'header_filenames': [
-+          'NVCtrlLib.h',
-+          'NVCtrl.h',
-+        ],
-+      },
-+      'includes': [
-+        '../../build/shim_headers.gypi',
-+      ],
-+      'direct_dependent_settings': {
-+        'cflags': [
-+            '<!@(pkg-config --cflags libXNVCtrl)',
-+        ],
-+      },
-+      'link_settings': {
-+        'ldflags': [
-+          '<!@(pkg-config --libs-only-L --libs-only-other libXNVCtrl)',
-+        ],
-+        'libraries': [
-+          '<!@(pkg-config --libs-only-l libXNVCtrl)',
-+        ],
-+      },
-+    }
-+  ],
-+}
---- chromium-browser-28.0.1500.20/build/linux/unbundle/replace_gyp_files.py~   2013-05-21 05:47:31.000000000 +0300
-+++ chromium-browser-28.0.1500.20/build/linux/unbundle/replace_gyp_files.py    2013-05-29 23:15:43.738468072 +0300
-@@ -29,6 +29,7 @@
-   'use_system_libvpx': 'third_party/libvpx/libvpx.gyp',
-   'use_system_libwebp': 'third_party/libwebp/libwebp.gyp',
-   'use_system_libxml': 'third_party/libxml/libxml.gyp',
-+  'use_system_libxnvctrl' : 'third_party/libXNVCtrl/libXNVCtrl.gyp',
-   'use_system_libxslt': 'third_party/libxslt/libxslt.gyp',
-   'use_system_opus': 'third_party/opus/opus.gyp',
-   'use_system_re2': 'third_party/re2/re2.gyp',
index 61f0d80397899b6088d00e6fa128a6a02f7120a0..0b4a2087ef24007e0f0b59f0570517b9e8d0deb0 100644 (file)
@@ -1,13 +1,13 @@
 in PLD Linux, windows includes are not packaged
 http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2013-February/023459.html
---- chromium-browser-26.0.1410.12/ui/gl/generate_bindings.py~  2013-02-21 12:18:08.000000000 +0200
-+++ chromium-browser-26.0.1410.12/ui/gl/generate_bindings.py   2013-02-28 11:54:36.763395432 +0200
-@@ -1172,7 +1172,7 @@
+--- chromium-browser-34.0.1847.116/ui/gl/generate_bindings.py~ 2014-04-02 22:04:03.000000000 +0300
++++ chromium-browser-34.0.1847.116/ui/gl/generate_bindings.py  2014-04-12 01:25:38.714510242 +0300
+@@ -1283,7 +1283,7 @@
        'EGL_ANGLE_surface_d3d_texture_2d_share_handle',
      ],
    ],
--  [WGL_FUNCTIONS, 'wgl', ['GL/wglext.h'], []],
-+  #[WGL_FUNCTIONS, 'wgl', ['GL/wglext.h'], []],
-   [GLX_FUNCTIONS, 'glx', ['GL/glx.h', 'GL/glxext.h'], []],
+-  [WGL_FUNCTIONS, [], 'wgl', ['GL/wglext.h'], []],
++#  [WGL_FUNCTIONS, [], 'wgl', ['GL/wglext.h'], []],
+   [GLX_FUNCTIONS, [], 'glx', ['GL/glx.h', 'GL/glxext.h'], []],
  ]
  
index 787bee8675bcb4548ebde05e0dc5a91233b9f24d..068eaadfba75919cb2ba566f31feb3f73fd10528 100644 (file)
@@ -1,11 +1,11 @@
---- chromium-browser-31.0.1650.48/third_party/WebKit/Source/bindings/derived_sources.gyp~      2013-11-08 08:50:07.000000000 +0200
-+++ chromium-browser-31.0.1650.48/third_party/WebKit/Source/bindings/derived_sources.gyp       2013-11-13 19:07:02.379771691 +0200
-@@ -44,8 +44,6 @@
+--- ./third_party/WebKit/Source/bindings/derived_sources.gyp.orig      2013-09-09 17:53:37.709978765 +0000
++++ ./third_party/WebKit/Source/bindings/derived_sources.gyp   2013-09-09 17:53:50.540054303 +0000
+@@ -57,8 +57,6 @@
      ],
      'compiler_module_files': [
          'scripts/idl_compiler.py',
 -        '<(DEPTH)/third_party/ply/lex.py',
 -        '<(DEPTH)/third_party/ply/yacc.py',
-         # jinja2/__init__.py contains version string, so sufficient for package
-         '<(DEPTH)/third_party/jinja2/__init__.py',
-         '<(DEPTH)/third_party/markupsafe/__init__.py',  # jinja2 dep
+         '<(DEPTH)/tools/idl_parser/idl_lexer.py',
+         '<(DEPTH)/tools/idl_parser/idl_node.py',
+         '<(DEPTH)/tools/idl_parser/idl_parser.py',
This page took 0.0671 seconds and 4 git commands to generate.