]> git.pld-linux.org Git - packages/chromium-browser.git/commitdiff
update cleaned up files rules
authorElan Ruusamäe <glen@delfi.ee>
Sun, 17 Nov 2013 11:47:56 +0000 (13:47 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 17 Nov 2013 11:47:56 +0000 (13:47 +0200)
clean-source.sh

index 03f0ed99c913144ef300ca9844dced8d64798497..eb58cdd1d822d5f35e07e517f34488d215a36e68 100755 (executable)
@@ -21,14 +21,17 @@ eval "$@"
 # suffix with _ those that we can't remove (just yet) because of the gclient
 # hooks (see build/all.gyp) or of some unneeded deps/includes
 remove_nonessential_dirs() {
-       # need to keep remoting/host/continue_window_mac.mm
        find -type f '(' \
                -name 'Android.mk' -o \
                -name '*.vcproj' -o \
                -name '*.sln' -o \
-               -name '*.mm_' -o \
+               -name '*.mm' -o \
                -name '*.m' \
-       ')' | xargs rm -vf
+       ')' '!' -type d '(' \
+               '!' -path './remoting/host/continue_window_mac.mm' \
+               '!' -path './remoting/host/disconnect_window_mac.mm' \
+       ')' \
+               -print -delete
 
        find -regextype posix-extended \
                -regex '.*_(win|cros|mac)_.*.xtb' \
@@ -866,7 +869,9 @@ remove_tests() {
        for dir in \
                chrome/browser/nacl_host/test \
                chrome/test/data \
-               testing_ \
+               testing/gtest \
+               testing/gtest_ios \
+               testing/gmock \
                third_party/webrtc/modules/audio_coding/codecs/cng/test \
                third_party/webrtc/modules/audio_coding/codecs/g711/test \
                third_party/webrtc/modules/audio_coding/codecs/g722/test \
@@ -904,6 +909,7 @@ remove_tests() {
                -o -name '*_unittest' \
                -o -name 'test_*.*' \
                -o -name '*_test.*' \
+               -o -path './testing/' \
        ')' '!' -name '*.gyp*' \
                '!' -name '*.isolate' \
                '!' -name '*.grd' \
This page took 0.037526 seconds and 4 git commands to generate.