]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - clean-source.sh
- icu rebuild
[packages/chromium-browser.git] / clean-source.sh
index 27ea57d5b2ca8e5aef9d0398e254be01cf9f10e8..f9d2a5b9065cf277f1caf1b13ce1477f90d90253 100755 (executable)
@@ -8,6 +8,7 @@ export LC_ALL=C
 # "v8=0" means "do not remove v8"
 eval "$@"
 
+# {{{ remove nonessential dirs
 # Strip tarball from some big directories not needed on the linux platform
 # https://code.google.com/p/chromium/wiki/LinuxPackaging
 # initial list from src/tools/export_tarball/export_tarball.py
@@ -48,7 +49,7 @@ remove_nonessential_dirs() {
        ash/shell/cocoa \
        ash/system/chromeos_ \
        base/android \
-       base/chromeos \
+       base/chromeos_ \
        base/ios \
        breakpad/src/client/mac \
        breakpad/src/common/android \
@@ -485,7 +486,7 @@ remove_nonessential_dirs() {
                '!' -path 'chrome/browser/chromeos/settings/device_settings_service.h' \
                '!' -path 'chrome/browser/chromeos/system_logs/*.h' \
                '!' -path 'chrome/tools/build/generate_policy_source.py' \
-               '!' -path 'chrome/tools/build/linux/sed.sh' \
+               '!' -path 'chrome/tools/build/linux/sed.py' \
                '!' -path 'chrome/tools/build/make_version_cc.py' \
                '!' -path 'chrome/tools/build/repack_locales.py' \
                '!' -path 'chrome/tools/build/version.py' \
@@ -526,7 +527,8 @@ remove_nonessential_dirs() {
                ')' \
        -print -delete
 }
-
+# }}}
+# {{{ almost_strip_dirs
 # There are directories we want to strip, but that are unnecessarily required by the build-system
 # So we drop everything but the gyp/gypi files
 almost_strip_dirs() {
@@ -562,8 +564,8 @@ almost_strip_dirs() {
                '!' -path 'tools/zip2msi.py' \
                -print -delete
 }
-
-# clean third party
+# }}}
+# {{{ clean third party
 # list based from archlinux PKGBUILD
 # https://aur.archlinux.org/packages/ch/chromium-dev/PKGBUILD
 clean_third_party() {
@@ -594,10 +596,11 @@ clean_third_party() {
                '!' -iname '*.isolate' \
                '!' -path 'third_party/WebKit/*' \
                '!' -path 'third_party/adobe/flash/*' \
+               '!' -path 'third_party/analytics/*' \
                '!' -path 'third_party/angle/enumerate_files.py' \
+               '!' -path 'third_party/angle/include/*.h' \
                '!' -path 'third_party/angle/include/EGL/*' \
                '!' -path 'third_party/angle/include/GLSLANG/*' \
-               '!' -path 'third_party/angle/include/*.h' \
                '!' -path 'third_party/angle/src/*' \
                '!' -path 'third_party/angle/src/common/*' \
                '!' -path 'third_party/angle/src/compiler/*' \
@@ -642,6 +645,7 @@ clean_third_party() {
                '!' -path 'third_party/mesa/src/include/GL/glxext.h' \
                '!' -path 'third_party/mesa/src/include/GL/osmesa.h' \
                '!' -path 'third_party/modp_b64/*' \
+               '!' -path 'third_party/mojo/*' \
                '!' -path 'third_party/mt19937ar/*' \
                '!' -path 'third_party/npapi/*' \
                '!' -path 'third_party/openmax_dl/*' \
@@ -665,6 +669,7 @@ clean_third_party() {
                '!' -path 'third_party/trace-viewer/*' \
                '!' -path 'third_party/undoview/*' \
                '!' -path 'third_party/usrsctp/*' \
+               '!' -path 'third_party/web-animations-js/*' \
                '!' -path 'third_party/v8-i18n/*' \
                '!' -path 'third_party/v8/*' \
                '!' -path 'third_party/webrtc/*' \
@@ -677,11 +682,13 @@ clean_third_party() {
                '!' -path 'third_party/libvpx/*' \
                '!' -path 'third_party/markupsafe/*' \
                '!' -path 'third_party/opus/*' \
+               '!' -path 'third_party/libudev/*' \
                -print -delete
 
        rm -vf third_party/expat/files/lib/expat.h
 }
-
+# }}}
+# {{{ remove_bin_only
 # parts based on ubuntu debian/rules
 # http://bazaar.launchpad.net/~chromium-team/chromium-browser/chromium-browser.head/view/head:/debian/rules
 remove_bin_only() {
@@ -698,7 +705,8 @@ remove_bin_only() {
                -name \*.dylib \
        \) -exec rm -fv {} \;
 }
-
+# }}}
+# {{{ strip_system_dirs
 # removes dir, if the bcond is not turned off
 strip_system_dirs() {
        local dir lib bcond args
@@ -719,7 +727,8 @@ strip_system_dirs() {
        done
        set +f
 }
-
+# }}}
+# {{{ remove_tests
 # remove test data and files
 # some scanned with find -name tests -o -name test -o -name test_data -o name testdata
 # and find -iname *test*
@@ -733,7 +742,7 @@ remove_tests() {
        breakpad/src/client/windows/tests \
        breakpad/src/common/linux/tests \
        breakpad/src/common/tests \
-       cc/test \
+       cc/test_ \
        chrome/browser/chromeos/bluetooth/test \
        chrome/browser/component_updater/test \
        chrome/browser/extensions/api/test_ \
@@ -1032,7 +1041,9 @@ remove_tests() {
        ')' \
                -print -delete || :
 }
+# }}}
 
+# {{{ remove_bundled_libraries
 # Remove most bundled libraries. Some are still needed.
 # Sync this with gentoo/chromium-*.ebuild
 # NOTE: argument list to script specifies paths to preserve
@@ -1064,6 +1075,7 @@ remove_bundled_libraries() {
                'net/third_party/mozilla_security_manager' \
                'net/third_party/nss' \
                'third_party/WebKit' \
+               'third_party/analytics' \
                'third_party/angle' \
                'third_party/angle/src/third_party/compiler' \
                'third_party/brotli' \
@@ -1072,7 +1084,7 @@ remove_bundled_libraries() {
                'third_party/cros_system_api' \
                'third_party/cython/python_flags.py' \
                'third_party/dom_distiller_js' \
-               'third_party/dom_distiller_js/package/proto_gen/third_party/dom_distiller_js' \
+               'third_party/dom_distiller_js/dist/proto_gen/third_party/dom_distiller_js' \
                'third_party/ffmpeg' \
                'third_party/fips181' \
                'third_party/flot' \
@@ -1088,10 +1100,10 @@ remove_bundled_libraries() {
                'third_party/libjingle' \
                'third_party/libphonenumber' \
                'third_party/libsrtp' \
+               'third_party/libudev' \
                'third_party/libusb' \
                'third_party/libvpx' \
                'third_party/libvpx/source/libvpx/third_party/x86inc' \
-               'third_party/libwebm' \
                'third_party/libxml/chromium' \
                'third_party/libXNVCtrl' \
                'third_party/libyuv' \
@@ -1099,16 +1111,16 @@ remove_bundled_libraries() {
                'third_party/lzma_sdk' \
                'third_party/mesa' \
                'third_party/modp_b64' \
+               'third_party/mojo' \
                'third_party/mt19937ar' \
                'third_party/npapi' \
                'third_party/openmax_dl' \
                'third_party/opus' \
                'third_party/ots' \
                'third_party/pdfium' \
-               'third_party/pdfium/third_party/logging.h' \
-               'third_party/pdfium/third_party/macros.h' \
-               'third_party/pdfium/third_party/numerics' \
-               'third_party/pdfium/third_party/template_util.h' \
+               'third_party/pdfium/third_party/base' \
+               'third_party/pdfium/third_party/bigint' \
+               'third_party/pdfium/third_party/freetype' \
                'third_party/polymer' \
                'third_party/protobuf' \
                'third_party/qcms' \
@@ -1118,7 +1130,6 @@ remove_bundled_libraries() {
                'third_party/smhasher' \
                'third_party/sqlite' \
                'third_party/tcmalloc' \
-               'third_party/tlslite' \
                'third_party/trace-viewer' \
                'third_party/trace-viewer/third_party/components/polymer' \
                'third_party/trace-viewer/third_party/d3' \
@@ -1128,6 +1139,7 @@ remove_bundled_libraries() {
                'third_party/trace-viewer/third_party/tvcm/third_party/beautifulsoup/polymer_soup.py' \
                'third_party/undoview' \
                'third_party/usrsctp' \
+               'third_party/web-animations-js' \
                'third_party/webdriver' \
                'third_party/webrtc' \
                'third_party/widevine' \
@@ -1140,6 +1152,7 @@ remove_bundled_libraries() {
                --do-print \
                --do-remove
 }
+# }}}
 
 remove_bundled_libraries > REMOVED-bundled_libraries.txt
 
@@ -1206,3 +1219,5 @@ fi
 for a in REMOVED-*.txt; do
        cat $a
 done
+
+# vim:fdm=marker
This page took 0.049396 seconds and 4 git commands to generate.