]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - clean-source.sh
up to 49.0.2623.110
[packages/chromium-browser.git] / clean-source.sh
index c6790740c9aab16ee586d036d36e9267527e677e..29534ede81ff9c92cabcad8edd9f708533f86189 100755 (executable)
@@ -49,7 +49,7 @@ remove_nonessential_dirs() {
        ash/shell/cocoa \
        ash/system/chromeos_ \
        base/android \
-       base/chromeos \
+       base/chromeos_ \
        base/ios \
        breakpad/src/client/mac \
        breakpad/src/common/android \
@@ -486,7 +486,7 @@ remove_nonessential_dirs() {
                '!' -path 'chrome/browser/chromeos/settings/device_settings_service.h' \
                '!' -path 'chrome/browser/chromeos/system_logs/*.h' \
                '!' -path 'chrome/tools/build/generate_policy_source.py' \
-               '!' -path 'chrome/tools/build/linux/sed.sh' \
+               '!' -path 'chrome/tools/build/linux/sed.py' \
                '!' -path 'chrome/tools/build/make_version_cc.py' \
                '!' -path 'chrome/tools/build/repack_locales.py' \
                '!' -path 'chrome/tools/build/version.py' \
@@ -506,6 +506,7 @@ remove_nonessential_dirs() {
                '!' -path 'native_client/src/include/win/mman.h' \
                '!' -path 'native_client/src/trusted/service_runtime/win/debug_exception_handler.h' \
                '!' -path 'native_client/src/trusted/service_runtime/win/exception_patch/ntdll_patch.h' \
+               '!' -path 'net/tools/dafsa/*' \
                '!' -path 'net/tools/tld_cleanup/*' \
                '!' -path 'remoting/tools/build/*' \
                '!' -path 'remoting/tools/verify_resources.py' \
@@ -514,6 +515,7 @@ remove_nonessential_dirs() {
                '!' -path 'third_party/cld/encodings/compact_lang_det/win/cld_*.cc' \
                '!' -path 'third_party/cld/encodings/compact_lang_det/win/cld_*.h' \
                '!' -path 'third_party/cros_system_api/dbus/*.proto' \
+               '!' -path 'third_party/cros_system_api/dbus/*/dbus-constants.h' \
                '!' -path 'third_party/cros_system_api/dbus/service_constants.h' \
                '!' -path 'third_party/sfntly/cpp/src/sample/chromium/*' \
                '!' -path 'third_party/tcmalloc/chromium/*' \
@@ -561,6 +563,7 @@ almost_strip_dirs() {
                '!' -path 'tools/protoc_wrapper/*' \
                '!' -path 'tools/usb_ids/*' \
                '!' -path 'tools/uuidgen.py' \
+               '!' -path 'tools/variations/*' \
                '!' -path 'tools/zip2msi.py' \
                -print -delete
 }
@@ -596,29 +599,37 @@ clean_third_party() {
                '!' -iname '*.isolate' \
                '!' -path 'third_party/WebKit/*' \
                '!' -path 'third_party/adobe/flash/*' \
+               '!' -path 'third_party/analytics/*' \
                '!' -path 'third_party/angle/enumerate_files.py' \
+               '!' -path 'third_party/angle/include/*.h' \
                '!' -path 'third_party/angle/include/EGL/*' \
                '!' -path 'third_party/angle/include/GLSLANG/*' \
-               '!' -path 'third_party/angle/include/*.h' \
                '!' -path 'third_party/angle/src/*' \
                '!' -path 'third_party/angle/src/common/*' \
                '!' -path 'third_party/angle/src/compiler/*' \
                '!' -path 'third_party/angle/src/enumerate_files.py' \
                '!' -path 'third_party/angle/src/third_party/compiler/*' \
+               '!' -path 'third_party/angle/src/third_party/murmurhash/*' \
+               '!' -path 'third_party/angle/src/third_party/trace_event/*' \
+               '!' -path 'third_party/boringssl/*' \
                '!' -path 'third_party/brotli/*' \
                '!' -path 'third_party/cacheinvalidation/*' \
+               '!' -path 'third_party/catapult/*' \
                '!' -path 'third_party/cld/*' \
                '!' -path 'third_party/cld_2/*' \
                '!' -path 'third_party/cros_system_api/*' \
                '!' -path 'third_party/cython/python_flags.py' \
+               '!' -path 'third_party/devscripts/*' \
                '!' -path 'third_party/dom_distiller_js/*' \
                '!' -path 'third_party/ffmpeg/*' \
                '!' -path 'third_party/fips181/*' \
                '!' -path 'third_party/flot/*.js' \
                '!' -path 'third_party/google_input_tools/*' \
                '!' -path 'third_party/hunspell/*' \
+               '!' -path 'third_party/hunspell_new/*' \
                '!' -path 'third_party/hyphen/*' \
                '!' -path 'third_party/iccjpeg/*' \
+               '!' -path 'third_party/icu/*' \
                '!' -path 'third_party/icu/icu.isolate' \
                '!' -path 'third_party/jinja2/*' \
                '!' -path 'third_party/jstemplate/*' \
@@ -628,9 +639,10 @@ clean_third_party() {
                '!' -path 'third_party/libaddressinput/*' \
                '!' -path 'third_party/libjingle/*' \
                '!' -path 'third_party/libphonenumber/*' \
+               '!' -path 'third_party/libsecret/*' \
                '!' -path 'third_party/libusb/*' \
                '!' -path 'third_party/libva/*' \
-               '!' -path 'third_party/libvpx/*' \
+               '!' -path 'third_party/libvpx_new/*' \
                '!' -path 'third_party/libwebm/*' \
                '!' -path 'third_party/libwebp/*' \
                '!' -path 'third_party/libxml/chromium/*' \
@@ -644,6 +656,7 @@ clean_third_party() {
                '!' -path 'third_party/mesa/src/include/GL/glxext.h' \
                '!' -path 'third_party/mesa/src/include/GL/osmesa.h' \
                '!' -path 'third_party/modp_b64/*' \
+               '!' -path 'third_party/mojo/*' \
                '!' -path 'third_party/mt19937ar/*' \
                '!' -path 'third_party/npapi/*' \
                '!' -path 'third_party/openmax_dl/*' \
@@ -664,13 +677,14 @@ clean_third_party() {
                '!' -path 'third_party/sqlite/sqlite3.h' \
                '!' -path 'third_party/sqlite/src/ext/*' \
                '!' -path 'third_party/tcmalloc/*' \
-               '!' -path 'third_party/trace-viewer/*' \
-               '!' -path 'third_party/undoview/*' \
                '!' -path 'third_party/usrsctp/*' \
                '!' -path 'third_party/v8-i18n/*' \
                '!' -path 'third_party/v8/*' \
+               '!' -path 'third_party/web-animations-js/*' \
                '!' -path 'third_party/webrtc/*' \
+               '!' -path 'third_party/webrtc_overrides/*' \
                '!' -path 'third_party/widevine/*' \
+               '!' -path 'third_party/woff2/*' \
                '!' -path 'third_party/x86inc/*' \
                '!' -path 'third_party/zlib/google/*' \
                '!' -path 'third_party/zlib/zlib.h' \
@@ -739,7 +753,7 @@ remove_tests() {
        breakpad/src/client/windows/tests \
        breakpad/src/common/linux/tests \
        breakpad/src/common/tests \
-       cc/test \
+       cc/test_ \
        chrome/browser/chromeos/bluetooth/test \
        chrome/browser/component_updater/test \
        chrome/browser/extensions/api/test_ \
@@ -931,7 +945,7 @@ remove_tests() {
        echo '> partial remove (keep .gyp)'
        for dir in \
                chrome/browser/nacl_host/test \
-               chrome/test/data \
+               chrome/test/data_ \
                testing/gtest_ \
                testing/gtest_ios \
                testing/gmock_ \
@@ -1022,6 +1036,8 @@ remove_tests() {
                '!' -path './third_party/trace-viewer/third_party/tvcm/src/tvcm/unittest/test_case.js' \
                '!' -path './third_party/trace-viewer/third_party/tvcm/src/tvcm/unittest/test_error.js' \
                '!' -path './third_party/trace-viewer/third_party/tvcm/src/tvcm/unittest/test_runner.js' \
+               '!' -path './third_party/trace-viewer/third_party/tvcm/third_party/rcssmin/*' \
+               '!' -path './third_party/trace-viewer/third_party/tvcm/third_party/rjsmin/*' \
                '!' -path './third_party/trace-viewer/trace_viewer/tracing/test_utils.js' \
                '!' -path './mojo/embedder/test_embedder.*' \
                '!' -path './ui/base/hit_test.*' \
@@ -1039,6 +1055,7 @@ remove_tests() {
                -print -delete || :
 }
 # }}}
+
 # {{{ remove_bundled_libraries
 # Remove most bundled libraries. Some are still needed.
 # Sync this with gentoo/chromium-*.ebuild
@@ -1053,8 +1070,8 @@ remove_bundled_libraries() {
                third_party/adobe/flash/flapper_version.h \
                third_party/jinja2 \
                third_party/markupsafe/ \
-               third_party/ply \
-               third_party/fips181 \
+               third_party/ply/ \
+               third_party/catapult/third_party/beautifulsoup4 \
                'base/third_party/dmg_fp' \
                'base/third_party/dynamic_annotations' \
                'base/third_party/icu' \
@@ -1071,15 +1088,31 @@ remove_bundled_libraries() {
                'net/third_party/mozilla_security_manager' \
                'net/third_party/nss' \
                'third_party/WebKit' \
+               'third_party/analytics' \
                'third_party/angle' \
                'third_party/angle/src/third_party/compiler' \
+               'third_party/angle/src/third_party/murmurhash' \
+               'third_party/angle/src/third_party/trace_event' \
+               'third_party/boringssl' \
                'third_party/brotli' \
                'third_party/cacheinvalidation' \
+               'third_party/catapult' \
+               'third_party/catapult/third_party/py_vulcanize' \
+               'third_party/catapult/third_party/py_vulcanize/third_party/rcssmin' \
+               'third_party/catapult/third_party/py_vulcanize/third_party/rjsmin' \
+               'third_party/catapult/tracing/third_party/components/polymer' \
+               'third_party/catapult/tracing/third_party/d3' \
+               'third_party/catapult/tracing/third_party/gl-matrix' \
+               'third_party/catapult/tracing/third_party/jszip' \
+               'third_party/catapult/tracing/third_party/tvcm' \
+               'third_party/catapult/tracing/third_party/tvcm/third_party/rcssmin' \
+               'third_party/catapult/tracing/third_party/tvcm/third_party/rjsmin' \
                'third_party/cld_2' \
                'third_party/cros_system_api' \
                'third_party/cython/python_flags.py' \
+               'third_party/devscripts' \
                'third_party/dom_distiller_js' \
-               'third_party/dom_distiller_js/package/proto_gen/third_party/dom_distiller_js' \
+               'third_party/dom_distiller_js/dist/proto_gen/third_party/dom_distiller_js' \
                'third_party/ffmpeg' \
                'third_party/fips181' \
                'third_party/flot' \
@@ -1091,66 +1124,74 @@ remove_bundled_libraries() {
                'third_party/jstemplate' \
                'third_party/khronos' \
                'third_party/leveldatabase' \
+               'third_party/libXNVCtrl' \
                'third_party/libaddressinput' \
                'third_party/libjingle' \
                'third_party/libphonenumber' \
+               'third_party/libsecret' \
                'third_party/libsrtp' \
                'third_party/libudev' \
                'third_party/libusb' \
-               'third_party/libvpx' \
-               'third_party/libvpx/source/libvpx/third_party/x86inc' \
+               'third_party/libvpx_new' \
+               'third_party/libvpx_new/source/libvpx/third_party/x86inc' \
+               'third_party/libwebm' \
                'third_party/libxml/chromium' \
-               'third_party/libXNVCtrl' \
                'third_party/libyuv' \
                'third_party/lss' \
                'third_party/lzma_sdk' \
                'third_party/mesa' \
                'third_party/modp_b64' \
+               'third_party/mojo' \
                'third_party/mt19937ar' \
                'third_party/npapi' \
                'third_party/openmax_dl' \
                'third_party/opus' \
                'third_party/ots' \
                'third_party/pdfium' \
+               'third_party/pdfium/third_party/agg23' \
+               'third_party/pdfium/third_party/base' \
                'third_party/pdfium/third_party/bigint' \
                'third_party/pdfium/third_party/freetype' \
-               'third_party/pdfium/third_party/logging.h' \
-               'third_party/pdfium/third_party/macros.h' \
-               'third_party/pdfium/third_party/numerics' \
-               'third_party/pdfium/third_party/template_util.h' \
+               'third_party/pdfium/third_party/lcms2-2.6' \
+               'third_party/pdfium/third_party/libjpeg' \
+               'third_party/pdfium/third_party/libopenjpeg20' \
+               'third_party/pdfium/third_party/zlib_v128' \
                'third_party/polymer' \
                'third_party/protobuf' \
                'third_party/qcms' \
+               'third_party/re2' \
                'third_party/readability' \
                'third_party/sfntly' \
                'third_party/skia' \
                'third_party/smhasher' \
                'third_party/sqlite' \
                'third_party/tcmalloc' \
-               'third_party/tlslite' \
-               'third_party/trace-viewer' \
-               'third_party/trace-viewer/third_party/components/polymer' \
-               'third_party/trace-viewer/third_party/d3' \
-               'third_party/trace-viewer/third_party/gl-matrix' \
-               'third_party/trace-viewer/third_party/jszip' \
-               'third_party/trace-viewer/third_party/tvcm' \
-               'third_party/trace-viewer/third_party/tvcm/third_party/beautifulsoup/polymer_soup.py' \
-               'third_party/undoview' \
                'third_party/usrsctp' \
+               'third_party/web-animations-js' \
                'third_party/webdriver' \
                'third_party/webrtc' \
+               'third_party/webrtc_overrides' \
                'third_party/widevine' \
+               'third_party/woff2' \
                'third_party/x86inc' \
                'third_party/zlib/google' \
                'url/third_party/mozilla' \
                'v8/src/third_party/fdlibm' \
-               'v8/src/third_party/kernel' \
                'v8/src/third_party/valgrind' \
                --do-print \
                --do-remove
 }
 # }}}
 
+# clean extra files that are cleaned in tarball provided by google
+clean_src_extra() {
+       rm -rfv \
+               .landmines \
+               chrome/browser/resources/pdf/html_office \
+               third_party/WebKit/ManualTests \
+               third_party/WebKit/PerformanceTests
+}
+
 remove_bundled_libraries > REMOVED-bundled_libraries.txt
 
 strip_system_dirs \
@@ -1194,6 +1235,8 @@ fi
 
 clean_third_party > REMOVED-third_party.txt
 
+clean_src_extra > REMOVED-extra.txt
+
 if [ "${v8:-1}" != "0" ]; then
        # The implementation files include v8 headers with full path,
        # like #include "v8/include/v8.h". Make sure the system headers
This page took 0.701688 seconds and 4 git commands to generate.