]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
up to 48.0.2564.103
[packages/chromium-browser.git] / chromium-browser.spec
index 4edf7fb25f44f0db8ab96a2627d9179866d32ff8..d44aa123c931461ccfccbfb31d9e4834c5a7fdae 100644 (file)
@@ -16,7 +16,7 @@
 %bcond_with            shared_libs             # with shared libs
 %bcond_with            sse2                    # use SSE2 instructions
 %bcond_without system_flac             # system flac
-%bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
+%bcond_without system_ffmpeg   # system ffmpeg
 %bcond_without system_harfbuzz # system harfbuzz
 %bcond_without system_icu      # system icu
 %bcond_without system_jsoncpp  # system jsoncpp
@@ -36,7 +36,7 @@
 %bcond_with    system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
 %bcond_without system_libsrtp  # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
 %bcond_with            system_v8               # system v8
-%bcond_without system_libvpx   # system libvpx, http://crbug.com/494939
+%bcond_with    system_libvpx   # system libvpx, http://crbug.com/494939
 %bcond_without system_yasm             # system yasm
 %bcond_without system_zlib             # system zlib
 %bcond_with    tcmalloc                # use tcmalloc
@@ -72,9 +72,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          46.0.2490
-%define                basever         71
-#define                patchver        130
+%define                branch          48.0.2564
+%define                basever         103
+#define                patchver        106
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -87,10 +87,10 @@ Release:    1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
 Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: ea1c198c02d6adf803150627d6ba2e14
+# Source0-md5: 4c527967ce3e6c141ebac00e4b26ae0d
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  02973b87b9564ed36220497b4bf83109
+# Patch0-md5:  214631f58aae3e9d9ca0795240a95def
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -123,6 +123,8 @@ Patch38:    vaapi_include.patch
 Patch39:       libsecret.patch
 Patch40:       ffmpeg-generate-errors.patch
 Patch41:       ffmpeg-generate.patch
+Patch42:       system-ffmpeg.patch
+Patch43:       system-icu.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -140,7 +142,7 @@ BuildRequires:      bzip2-devel
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel
-%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 1.0}
+%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 2.7.2}
 %{?with_system_flac:BuildRequires:     flac-devel >= 1.2.1-7}
 BuildRequires: fontconfig-devel
 BuildRequires: glib2-devel
@@ -166,7 +168,7 @@ BuildRequires:      libsecret-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
 %{?with_system_libusb:BuildRequires:   libusb-devel >= 1.0}
-%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 1.4.0}
+%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 1.5.0}
 %{?with_system_libwebp:BuildRequires:  libwebp-devel >= 0.4.0}
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
@@ -187,10 +189,11 @@ BuildRequires:    pkgconfig
 BuildRequires: python
 BuildRequires: python-BeautifulSoup
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
+BuildRequires: python-html5lib
 BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
 BuildRequires: python-ply >= 3.4
-%{?with_system_re2:BuildRequires:      re2-devel >= 20130115-2}
+%{?with_system_re2:BuildRequires:      re2-devel >= 20151101}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.453
 %{?with_system_snappy:BuildRequires:   snappy-devel}
@@ -219,7 +222,7 @@ Requires:   libevent >= 2.0.21
 %{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
 %{?with_system_libvpx:Requires:        libvpx >= 1.4.0}
 Requires:      lsb-release
-%{?with_system_re2:Requires:   re2 >= 20130115-2}
+%{?with_system_re2:Requires:   re2 >= 20151101}
 %{?with_system_protobuf:Requires:      protobuf-libs >= 2.5.0-2}
 Requires:      shared-mime-info
 %{?with_system_sqlite:Requires:        sqlite3(icu)}
@@ -334,8 +337,11 @@ ln -s %{SOURCE7} .
 %patch39 -p1
 %patch40 -p1
 %patch41 -p1
+%patch42 -p1
+%patch43 -p0
 
 # https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
+install -d chrome/test/data/webui
 touch chrome/test/data/webui/i18n_process_css_test.html
 
 %{?with_dev:exit 0}
@@ -621,6 +627,7 @@ exit 0
 %postun
 if [ "$1" = 0 ]; then
        %update_icon_cache hicolor
+       %update_desktop_database
        %update_browser_plugins
 fi
 
This page took 0.060882 seconds and 4 git commands to generate.