]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
up to 40.0.2214.69
[packages/chromium-browser.git] / chromium-browser.spec
index 8290be32722a66578076e1817301a78fb2337ffb..3b4206de7706f09a13d96e5eb67a9ab952a045d1 100644 (file)
@@ -18,6 +18,7 @@
 %bcond_without system_flac             # system flac
 %bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
 %bcond_without system_harfbuzz # system harfbuzz
+%bcond_without system_icu      # system icu
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
 %ifarch %{ix86}
 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
 %undefine      with_system_mesa
+
+# unable build with debuginfo on 32bit build systems
+# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
+%undefine      with_debuginfo
+%endif
+
+%ifarch %{x8664}
+# x86_64 systems fail with debugedit crashing
+# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
+%undefine      with_debuginfo
 %endif
 
 # TODO
@@ -61,9 +72,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          38.0.2125
-%define                basever         101
-#define                patchver        132
+%define                branch          40.0.2214
+%define                basever         69
+#define                patchver        95
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -76,10 +87,10 @@ Release:    1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
 Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: be4d3ad6944e43132e4fbde5a23d1ab8
+# Source0-md5: 238cbf816f3d3c01a58894a32eb9995d
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  4eafe1e64bd47a11dbfaf61a2dd50b6e
+# Patch0-md5:  1e03edf9545804bbc54ab3a77b1f4603
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -103,11 +114,11 @@ Patch24:  nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
 Patch28:       system-mesa.patch
-Patch30:       system-ply.patch
 Patch31:       system-jinja.patch
 Patch32:       remove_bundled_libraries-stale.patch
 Patch35:       etc-dir.patch
 Patch36:       angle.patch
+Patch37:       %{name}-build.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -142,7 +153,7 @@ BuildRequires:      hicolor-icon-theme
 BuildRequires: libevent-devel
 %{?with_system_libexif:BuildRequires:  libexif-devel >= 1:0.6.21}
 %{?with_keyring:BuildRequires: libgnome-keyring-devel}
-BuildRequires: libicu-devel >= 4.6
+%{?with_system_icu:BuildRequires:      libicu-devel >= 4.6}
 %{!?with_libjpegturbo:BuildRequires:   libjpeg-devel}
 %{?with_libjpegturbo:BuildRequires:    libjpeg-turbo-devel >= 1.2.0}
 %{?with_system_libmtp:BuildRequires:   libmtp-devel >= 1.1.3}
@@ -169,6 +180,7 @@ BuildRequires:      pkgconfig
 %{?with_system_protobuf:BuildRequires: protobuf-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: python
+BuildRequires: python-BeautifulSoup
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
 BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
@@ -203,6 +215,7 @@ Requires:   libevent >= 2.0.21
 %{?with_system_libvpx:Requires:        libvpx >= 1.3.0}
 Requires:      lsb-release
 %{?with_system_re2:Requires:   re2 >= 20130115-2}
+%{?with_system_protobuf:Requires:      protobuf-libs >= 2.5.0-2}
 Requires:      shared-mime-info
 %{?with_system_sqlite:Requires:        sqlite3(icu)}
 Requires:      xdg-utils >= 1.0.2-4
@@ -307,11 +320,11 @@ ln -s %{SOURCE7} .
 %{?with_nacl:%patch18 -p1}
 %patch24 -p1
 %patch26 -p2
-#%patch30 -p1
-#%patch31 -p0
+%patch31 -p0
 %patch32 -p1
 %patch35 -p1
 %patch36 -p1
+%patch37 -p1
 
 %{?with_dev:exit 0}
 
@@ -371,7 +384,8 @@ fi
 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
        # Re-configure bundled ffmpeg
        cd third_party/ffmpeg
-       chromium/scripts/build_ffmpeg.py linux %{target_arch}
+       chromium/scripts/build_ffmpeg.py linux %{target_arch} \
+               --branding Chromium
        chromium/scripts/copy_config.sh
        chromium/scripts/generate_gyp.py
        cd -
@@ -392,7 +406,7 @@ flags="
        %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
        %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
        %{?with_shared_libs:-Dlibrary=shared_library} \
-       %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
+       %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
        -Dinclude_tests__=0 \
 %if %{with nacl}
        -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
@@ -429,6 +443,7 @@ flags="
        %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
        %{gyp_with system_flac} \
        %{gyp_with system_harfbuzz} \
+       %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
        %{gyp_with system_jsoncpp} \
        %{gyp_with system_libexif} \
        %{gyp_with system_libmtp} \
@@ -450,7 +465,6 @@ flags="
        %{gyp_with system_zlib} \
        -Duse_system_bzip2=1 \
        -Duse_system_expat=1 \
-       -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
        -Duse_system_libevent=1 \
        -Duse_system_libjpeg=1 \
        -Duse_system_libpng=1 \
@@ -617,6 +631,9 @@ fi
 %{_libdir}/%{name}/locales
 %{_libdir}/%{name}/resources
 
+# conflicts with browser-plugin-chrome-pdf?
+%attr(755,root,root) %{_libdir}/%{name}/libpdf.so
+
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/locales
 %{_datadir}/%{name}/locales/en-US.pak
This page took 0.030361 seconds and 4 git commands to generate.