]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
sync clean source script
[packages/chromium-browser.git] / chromium-browser.spec
index b9df8b671799ef8297d4005fbdad70bee46adcdf..1ae7b3e39a809cbf38d07860c73eac8a98d5a8e6 100644 (file)
@@ -28,7 +28,8 @@
 %bcond_with    system_mesa             # system Mesa
 %bcond_without system_minizip  # system minizip
 %bcond_without system_opus             # system opus codec support, http://www.opus-codec.org/examples/
-%bcond_without system_protobuf # system protobuf
+# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
+%bcond_with    system_protobuf # system protobuf
 %bcond_without system_re2              # system re2
 %bcond_without system_snappy   # system snappy
 %bcond_without system_speex    # system speex
@@ -72,9 +73,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          39.0.2171
-%define                basever         71
-%define                patchver        95
+%define                branch          42.0.2311
+%define                basever         82
+#define                patchver        118
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -83,14 +84,14 @@ Version:    %{branch}.%{patchver}
 %else
 Version:       %{branch}.%{basever}
 %endif
-Release:       1
+Release:       0.1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: 238cbf816f3d3c01a58894a32eb9995d
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
+# Source0-md5: 7bdbf015d663e082f5bbe4cf24907049
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  1e03edf9545804bbc54ab3a77b1f4603
+# Patch0-md5:  fc9cd6fd3392142db2ada6b98b89fa80
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -100,8 +101,8 @@ Source6:    update-source.sh
 Source7:       clean-source.sh
 Source8:       get-source.sh
 Source9:       master_preferences.json
+# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
 Patch2:                enable-video-decode-accel.patch
-Patch4:                path-libpdf.patch
 Patch7:                dlopen_sonamed_gl.patch
 Patch8:                chromium_useragent.patch.in
 # https://bugs.gentoo.org/show_bug.cgi?id=393471
@@ -119,6 +120,8 @@ Patch32:    remove_bundled_libraries-stale.patch
 Patch35:       etc-dir.patch
 Patch36:       angle.patch
 Patch37:       %{name}-build.patch
+Patch38:       vaapi_include.patch
+Patch39:       libsecret.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -158,6 +161,7 @@ BuildRequires:      libevent-devel
 %{?with_libjpegturbo:BuildRequires:    libjpeg-turbo-devel >= 1.2.0}
 %{?with_system_libmtp:BuildRequires:   libmtp-devel >= 1.1.3}
 BuildRequires: libpng-devel
+BuildRequires: libsecret-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
 %{?with_system_libusb:BuildRequires:   libusb-devel >= 1.0}
@@ -180,6 +184,7 @@ BuildRequires:      pkgconfig
 %{?with_system_protobuf:BuildRequires: protobuf-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: python
+BuildRequires: python-BeautifulSoup
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
 BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
@@ -308,8 +313,7 @@ sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
 ln -s %{SOURCE7} .
 
-#%patch2 -p1 NOT COMPILING
-%patch4 -p3
+#%patch2 -p1 CHECK
 %patch7 -p1
 %patch15 -p2
 %{!?with_libjpegturbo:%patch11 -p0}
@@ -324,6 +328,8 @@ ln -s %{SOURCE7} .
 %patch35 -p1
 %patch36 -p1
 %patch37 -p1
+#%patch38 -p1 CHECK
+%patch39 -p1
 
 %{?with_dev:exit 0}
 
@@ -533,7 +539,7 @@ install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
        }
 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
-cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
+cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
@@ -542,7 +548,6 @@ install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
 %if %{without system_ffmpeg}
 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 %endif
-install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
 
@@ -627,12 +632,11 @@ fi
 %{_libdir}/%{name}/content_resources.pak
 %{_libdir}/%{name}/keyboard_resources.pak
 %{_libdir}/%{name}/resources.pak
+%{_libdir}/%{name}/natives_blob.bin
+%{_libdir}/%{name}/snapshot_blob.bin
 %{_libdir}/%{name}/locales
 %{_libdir}/%{name}/resources
 
-# conflicts with browser-plugin-chrome-pdf?
-%attr(755,root,root) %{_libdir}/%{name}/libpdf.so
-
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/locales
 %{_datadir}/%{name}/locales/en-US.pak
This page took 0.035257 seconds and 4 git commands to generate.