]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
sync clean source script
[packages/chromium-browser.git] / chromium-browser.spec
index 155158ac5bf0957f764554a9eb6464d7f0c7fa2a..1ae7b3e39a809cbf38d07860c73eac8a98d5a8e6 100644 (file)
@@ -18,6 +18,7 @@
 %bcond_without system_flac             # system flac
 %bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
 %bcond_without system_harfbuzz # system harfbuzz
+%bcond_without system_icu      # system icu
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
@@ -27,7 +28,8 @@
 %bcond_with    system_mesa             # system Mesa
 %bcond_without system_minizip  # system minizip
 %bcond_without system_opus             # system opus codec support, http://www.opus-codec.org/examples/
-%bcond_without system_protobuf # system protobuf
+# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
+%bcond_with    system_protobuf # system protobuf
 %bcond_without system_re2              # system re2
 %bcond_without system_snappy   # system snappy
 %bcond_without system_speex    # system speex
 %ifarch %{ix86}
 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
 %undefine      with_system_mesa
+
+# unable build with debuginfo on 32bit build systems
+# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
+%undefine      with_debuginfo
+%endif
+
+%ifarch %{x8664}
+# x86_64 systems fail with debugedit crashing
+# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
+%undefine      with_debuginfo
 %endif
 
 # TODO
@@ -61,9 +73,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          38.0.2125
-%define                basever         101
-#define                patchver        132
+%define                branch          42.0.2311
+%define                basever         82
+#define                patchver        118
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -72,14 +84,14 @@ Version:    %{branch}.%{patchver}
 %else
 Version:       %{branch}.%{basever}
 %endif
-Release:       1
+Release:       0.1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: f2ec6a50864d8b2ddcda0baef50e9c33
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
+# Source0-md5: 7bdbf015d663e082f5bbe4cf24907049
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  4eafe1e64bd47a11dbfaf61a2dd50b6e
+# Patch0-md5:  fc9cd6fd3392142db2ada6b98b89fa80
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -89,8 +101,8 @@ Source6:     update-source.sh
 Source7:       clean-source.sh
 Source8:       get-source.sh
 Source9:       master_preferences.json
+# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
 Patch2:                enable-video-decode-accel.patch
-Patch4:                path-libpdf.patch
 Patch7:                dlopen_sonamed_gl.patch
 Patch8:                chromium_useragent.patch.in
 # https://bugs.gentoo.org/show_bug.cgi?id=393471
@@ -103,11 +115,13 @@ Patch24:  nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
 Patch28:       system-mesa.patch
-Patch30:       system-ply.patch
 Patch31:       system-jinja.patch
 Patch32:       remove_bundled_libraries-stale.patch
 Patch35:       etc-dir.patch
 Patch36:       angle.patch
+Patch37:       %{name}-build.patch
+Patch38:       vaapi_include.patch
+Patch39:       libsecret.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -142,11 +156,12 @@ BuildRequires:    hicolor-icon-theme
 BuildRequires: libevent-devel
 %{?with_system_libexif:BuildRequires:  libexif-devel >= 1:0.6.21}
 %{?with_keyring:BuildRequires: libgnome-keyring-devel}
-BuildRequires: libicu-devel >= 4.6
+%{?with_system_icu:BuildRequires:      libicu-devel >= 4.6}
 %{!?with_libjpegturbo:BuildRequires:   libjpeg-devel}
 %{?with_libjpegturbo:BuildRequires:    libjpeg-turbo-devel >= 1.2.0}
 %{?with_system_libmtp:BuildRequires:   libmtp-devel >= 1.1.3}
 BuildRequires: libpng-devel
+BuildRequires: libsecret-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
 %{?with_system_libusb:BuildRequires:   libusb-devel >= 1.0}
@@ -169,6 +184,7 @@ BuildRequires:      pkgconfig
 %{?with_system_protobuf:BuildRequires: protobuf-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: python
+BuildRequires: python-BeautifulSoup
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
 BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
@@ -203,6 +219,7 @@ Requires:   libevent >= 2.0.21
 %{?with_system_libvpx:Requires:        libvpx >= 1.3.0}
 Requires:      lsb-release
 %{?with_system_re2:Requires:   re2 >= 20130115-2}
+%{?with_system_protobuf:Requires:      protobuf-libs >= 2.5.0-2}
 Requires:      shared-mime-info
 %{?with_system_sqlite:Requires:        sqlite3(icu)}
 Requires:      xdg-utils >= 1.0.2-4
@@ -296,8 +313,7 @@ sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
 ln -s %{SOURCE7} .
 
-#%patch2 -p1 NOT COMPILING
-%patch4 -p3
+#%patch2 -p1 CHECK
 %patch7 -p1
 %patch15 -p2
 %{!?with_libjpegturbo:%patch11 -p0}
@@ -307,11 +323,13 @@ ln -s %{SOURCE7} .
 %{?with_nacl:%patch18 -p1}
 %patch24 -p1
 %patch26 -p2
-#%patch30 -p1
-#%patch31 -p0
+%patch31 -p0
 %patch32 -p1
 %patch35 -p1
 %patch36 -p1
+%patch37 -p1
+#%patch38 -p1 CHECK
+%patch39 -p1
 
 %{?with_dev:exit 0}
 
@@ -371,7 +389,8 @@ fi
 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
        # Re-configure bundled ffmpeg
        cd third_party/ffmpeg
-       chromium/scripts/build_ffmpeg.py linux %{target_arch}
+       chromium/scripts/build_ffmpeg.py linux %{target_arch} \
+               --branding Chromium
        chromium/scripts/copy_config.sh
        chromium/scripts/generate_gyp.py
        cd -
@@ -392,7 +411,7 @@ flags="
        %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
        %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
        %{?with_shared_libs:-Dlibrary=shared_library} \
-       %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
+       %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
        -Dinclude_tests__=0 \
 %if %{with nacl}
        -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
@@ -429,6 +448,7 @@ flags="
        %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
        %{gyp_with system_flac} \
        %{gyp_with system_harfbuzz} \
+       %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
        %{gyp_with system_jsoncpp} \
        %{gyp_with system_libexif} \
        %{gyp_with system_libmtp} \
@@ -450,7 +470,6 @@ flags="
        %{gyp_with system_zlib} \
        -Duse_system_bzip2=1 \
        -Duse_system_expat=1 \
-       -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
        -Duse_system_libevent=1 \
        -Duse_system_libjpeg=1 \
        -Duse_system_libpng=1 \
@@ -520,7 +539,7 @@ install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
        }
 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
-cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
+cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
@@ -529,7 +548,6 @@ install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
 %if %{without system_ffmpeg}
 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 %endif
-install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
 
@@ -614,12 +632,11 @@ fi
 %{_libdir}/%{name}/content_resources.pak
 %{_libdir}/%{name}/keyboard_resources.pak
 %{_libdir}/%{name}/resources.pak
+%{_libdir}/%{name}/natives_blob.bin
+%{_libdir}/%{name}/snapshot_blob.bin
 %{_libdir}/%{name}/locales
 %{_libdir}/%{name}/resources
 
-# conflicts with browser-plugin-chrome-pdf?
-%attr(755,root,root) %{_libdir}/%{name}/libpdf.so
-
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/locales
 %{_datadir}/%{name}/locales/en-US.pak
This page took 0.412931 seconds and 4 git commands to generate.