]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
a7e8e70c2edb2c20ac87148e51296b2541da35f1
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
11 %bcond_with     ninja                   # use Ninja instead of make to build
12 %bcond_without  pulseaudio              # with pulseaudio
13 %bcond_without  sandboxing              # with sandboxing
14 %bcond_with             selinux                 # with SELinux (need policy first)
15 %bcond_with             shared_libs             # with shared libs
16 %bcond_with             sse2                    # use SSE2 instructions
17 %bcond_without  system_flac             # system flac
18 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
19 %bcond_without  system_harfbuzz # system harfbuzz
20 %bcond_without  system_jsoncpp  # system jsoncpp
21 %bcond_without  system_libexif  # system libexif
22 %bcond_without  system_libmtp   # system libmtp
23 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
24 %bcond_without  system_libwebp  # system libwebp
25 %bcond_without  system_libxnvctrl       # system libxnvctrl
26 %bcond_with     system_mesa             # system Mesa
27 %bcond_without  system_minizip  # system minizip
28 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
29 %bcond_without  system_protobuf # system protobuf
30 %bcond_without  system_re2              # system re2
31 %bcond_without  system_snappy   # system snappy
32 %bcond_without  system_speex    # system speex
33 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
34 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
35 %bcond_with             system_v8               # system v8
36 %bcond_without  system_libvpx   # system libvpx
37 %bcond_without  system_yasm             # system yasm
38 %bcond_without  system_zlib             # system zlib
39 %bcond_without  tcmalloc                # use tcmalloc
40 %bcond_without  verbose                 # verbose build (V=1)
41
42 %ifarch %{ix86}
43 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
44 %undefine       with_system_mesa
45 %endif
46
47 # TODO
48 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
49 # - use_system_skia
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_stlport (android specific)
52 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
53
54 # NOTES:
55 # - mute BEEP mixer if you do not want to hear horrible system bell when
56 #   pressing home/end in url bar or more ^F search results on page.
57 # - space considerations:
58 #   - unpacked sources: ~490MiB
59 #   - built code: ~1.4GiB (x86_64/i686)
60 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
61 # - to look for new tarball, use update-source.sh script
62
63 %define         branch          34.0.1847
64 %define         basever         116
65 %define         patchver        132
66 %define         gyp_rev 1014
67 Summary:        A WebKit powered web browser
68 Name:           chromium-browser
69 %if "%{?patchver}" != ""
70 Version:        %{branch}.%{patchver}
71 %else
72 Version:        %{branch}.%{basever}
73 %endif
74 Release:        2
75 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
76 Group:          X11/Applications/Networking
77 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
78 # Source0-md5:  987b25c0a3aa7bc2354c573113e94e04
79 %if "%{?patchver}" != ""
80 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
81 # Patch0-md5:   4eafe1e64bd47a11dbfaf61a2dd50b6e
82 %endif
83 Source1:        %{name}.default
84 Source2:        %{name}.sh
85 Source3:        %{name}.desktop
86 Source5:        find-lang.sh
87 Source6:        update-source.sh
88 Source7:        clean-source.sh
89 Source8:        get-source.sh
90 Source9:        master_preferences.json
91 Patch1:         plugin-searchdirs.patch
92 Patch2:         enable-video-decode-accel.patch
93 Patch4:         path-libpdf.patch
94 Patch7:         dlopen_sonamed_gl.patch
95 Patch8:         chromium_useragent.patch.in
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch30:        system-ply.patch
107 Patch31:        system-jinja.patch
108 Patch32:        remove_bundled_libraries-stale.patch
109 Patch33:        gn.patch
110 Patch34:        depot-tools.patch
111 Patch35:        etc-dir.patch
112 URL:            http://www.chromium.org/Home
113 %{?with_gconf:BuildRequires:    GConf2-devel}
114 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
115 BuildRequires:  Mesa-libGLES-devel >= 9.1
116 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
117 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
118 BuildRequires:  alsa-lib-devel
119 BuildRequires:  atk-devel
120 BuildRequires:  bison
121 BuildRequires:  bzip2-devel
122 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
123 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
124 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
125 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
126 %{?with_cups:BuildRequires:     cups-devel}
127 BuildRequires:  elfutils-devel
128 BuildRequires:  expat-devel
129 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
130 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
131 BuildRequires:  fontconfig-devel
132 BuildRequires:  glib2-devel
133 BuildRequires:  gperf
134 %{?with_gps:BuildRequires:      gpsd-devel}
135 BuildRequires:  gtest-devel
136 BuildRequires:  gtk+2-devel
137 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
138 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
139 %{?with_kerberos:BuildRequires: heimdal-devel}
140 BuildRequires:  hicolor-icon-theme
141 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
142 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
143 BuildRequires:  libevent-devel
144 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
145 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
146 BuildRequires:  libicu-devel >= 4.6
147 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
148 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
149 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
150 BuildRequires:  libpng-devel
151 %{?with_selinux:BuildRequires:  libselinux-devel}
152 BuildRequires:  libstdc++-devel
153 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
154 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
155 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
156 BuildRequires:  libxml2-devel
157 BuildRequires:  libxslt-devel
158 BuildRequires:  man-db
159 %{?with_system_minizip:BuildRequires:   minizip-devel}
160 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
161 BuildRequires:  nspr-devel
162 BuildRequires:  nss-devel >= 1:3.12.3
163 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
164 BuildRequires:  pam-devel
165 BuildRequires:  pango-devel
166 BuildRequires:  pciutils-devel
167 BuildRequires:  perl-JSON
168 BuildRequires:  perl-modules
169 BuildRequires:  pkgconfig
170 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
171 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
172 BuildRequires:  python
173 #BuildRequires: python-gyp >= 1-%{gyp_rev}
174 BuildRequires:  python-jinja2 >= 2.7
175 BuildRequires:  python-modules
176 BuildRequires:  python-ply >= 3.4
177 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
178 BuildRequires:  rpm >= 4.4.9-56
179 BuildRequires:  rpmbuild(macros) >= 1.453
180 %{?with_system_snappy:BuildRequires:    snappy-devel}
181 BuildRequires:  speech-dispatcher-devel >= 0.8
182 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
183 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
184 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
185 BuildRequires:  tar >= 1:1.22
186 BuildRequires:  udev-devel
187 BuildRequires:  usbutils
188 BuildRequires:  util-linux
189 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
190 BuildRequires:  which
191 BuildRequires:  xorg-lib-libXScrnSaver-devel
192 BuildRequires:  xorg-lib-libXtst-devel
193 BuildRequires:  xz
194 %{?with_system_yasm:BuildRequires:      yasm}
195 %{?with_system_zlib:BuildRequires:      zlib-devel}
196 Requires:       browser-plugins >= 2.0
197 Requires:       desktop-file-utils
198 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
199 # crashes if no fontconfig font present
200 Requires:       fonts-Type1-urw
201 Requires:       hicolor-icon-theme
202 Requires:       libevent >= 2.0.21
203 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
204 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
205 Requires:       lsb-release
206 %{?with_system_re2:Requires:    re2 >= 20130115-2}
207 Requires:       shared-mime-info
208 %{?with_system_sqlite:Requires: sqlite3(icu)}
209 Requires:       xdg-utils >= 1.0.2-4
210 Requires:       xorg-lib-libX11 >= 1.4.99.1
211 Provides:       wwwbrowser
212 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
213 Obsoletes:      chromium-browser-inspector < 15.0.863.0
214 ExclusiveArch:  %{ix86} %{x8664} arm
215 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
216
217 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
218 # Note: these are for PLD Linux use ONLY.
219 # For your own distribution, please get your own set of keys.
220 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
221 %define         google_default_client_id 724288223830.apps.googleusercontent.com
222 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
223
224 %define         find_lang       sh find-lang.sh %{buildroot}
225
226 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
227 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
228
229 %ifarch %{ix86}
230 %define         target_arch ia32
231 %endif
232 %ifarch %{x8664}
233 %define         target_arch x64
234 %endif
235
236 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
237 %define         builddir        out/%{buildtype}
238
239 %if %{without debuginfo}
240 %define         _enable_debug_packages  0
241 %endif
242
243 %description
244 Chromium is an open-source browser project that aims to build a safer,
245 faster, and more stable way for all Internet users to experience the
246 web.
247
248 Chromium serves as a base for Google Chrome, which is Chromium
249 rebranded (name and logo) with very few additions such as usage
250 tracking and an auto-updater system.
251
252 %package l10n
253 Summary:        chromium-browser language packages
254 Group:          I18n
255 Requires:       %{name} = %{version}-%{release}
256 %if "%{_rpmversion}" >= "5"
257 BuildArch:      noarch
258 %endif
259
260 %description l10n
261 Chromium is an open-source browser project that aims to build a safer,
262 faster, and more stable way for all Internet users to experience the
263 web.
264
265 This package contains language packages for 50 languages:
266
267 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
268 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
269 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
270 zh-TW
271
272 %prep
273 %setup -qc
274 %if "%{?patchver}" != ""
275 cd chromium*-%{branch}.%{basever}
276 %patch0 -p1
277 cd ..
278 %endif
279 mv chromium*-%{branch}.%{basever}/* .
280
281 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
282 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
283 . ./chrome/VERSION
284 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
285 test "$chrome" = %{version}
286
287 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
288 test "$gyp_rev" = %{gyp_rev} || :
289
290 # add chromium and pld to useragent
291 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
292 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
293         -e 's/@BUILD_DIST_NAME@/PLD/g' \
294         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
295         < %{PATCH8} | %{__patch} -p1
296
297 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
298 ln -s %{SOURCE7} .
299
300 %patch1 -p1
301 #%patch2 -p1 NOT COMPILING
302 %patch4 -p3
303 %patch7 -p1
304 %patch15 -p2
305 %{!?with_libjpegturbo:%patch11 -p0}
306 %patch16 -p1
307 %patch28 -p1
308 %patch25 -p1
309 %{?with_nacl:%patch18 -p1}
310 %patch24 -p2
311 %patch26 -p2
312 #%patch30 -p1
313 #%patch31 -p0
314 %patch32 -p1
315 %patch33 -p1
316 %patch34 -p0
317 %patch35 -p1
318
319 sh -x clean-source.sh \
320         %{!?with_nacl:nacl=0} \
321         %{!?with_system_libvpx:libvpx=0} \
322         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
323         %{!?with_system_mesa:mesa=0} \
324         %{!?with_system_protobuf:protobuf=0} \
325         %{!?with_system_re2:re2=0} \
326         %{!?with_system_snappy:snappy=0} \
327         %{!?with_system_sqlite:sqlite=0} \
328         %{!?with_system_v8:v8=0} \
329         %{!?with_system_libwebp:libwebp=0} \
330         %{!?with_system_zlib:zlib=0} \
331         %{!?with_system_ffmpeg:ffmpeg=0} \
332         %{nil}
333
334 %build
335 %if %{with nacl}
336 rm -rf native_client/toolchain/linux_x86_newlib
337 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
338 # Make symlinks for NaCL
339 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
340
341 cd native_client/toolchain/linux_x86_newlib
342 ln -s x86_64-nacl/bin bin
343 cd x86_64-nacl/bin
344 __cc='%{__cc}'
345 if [ "${__cc#ccache}" != "$__cc" ]; then
346         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
347         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
348         %{__sed} -i -e '1i#!/bin/sh' gcc g++
349         chmod +x gcc g++
350 else
351         ln -s %{_bindir}/x86_64-nacl-gcc gcc
352         ln -s %{_bindir}/x86_64-nacl-g++ g++
353 fi
354 ln -s gcc x86_64-nacl-gcc
355 ln -s g++ x86_64-nacl-g++
356 ln -s %{_bindir}/x86_64-nacl-ar .
357 ln -s %{_bindir}/x86_64-nacl-ar ar
358 ln -s %{_bindir}/x86_64-nacl-as as
359 ln -s %{_bindir}/x86_64-nacl-ranlib .
360 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
361 ln -s %{_bindir}/x86_64-nacl-strip .
362 ln -s %{_bindir}/x86_64-nacl-strip strip
363 ln -s %{_bindir}/x86_64-nacl-objcopy .
364 ln -s %{_prefix}/x86_64-nacl/lib ../lib
365 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
366 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
367 cd ../../../../..
368 fi
369 %endif
370
371 %if %{without system_ffmpeg}
372 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
373         # Re-configure bundled ffmpeg
374         cd third_party/ffmpeg
375         chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
376         chromium/scripts/copy_config.sh
377         cd -
378 fi
379 %endif
380
381 flags="
382         -Dtarget_arch=%{target_arch} \
383         -Dpython_arch=%{target_arch} \
384         -Dsystem_libdir=%{_lib} \
385         -Dpython_ver=%{py_ver} \
386 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
387         -Dno_strict_aliasing=1 -Dgcc_version=44 \
388 %endif
389         %{!?debug:-Dwerror=} \
390         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
391         %{?with_shared_libs:-Dlibrary=shared_library} \
392         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
393         -Dinclude_tests__=0 \
394 %if %{with nacl}
395         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
396         -Ddisable_glibc_untar=1 \
397         -Ddisable_newlib_untar=1 \
398         -Ddisable_glibc=1 \
399         -Ddisable_pnacl=1 \
400         -Dbuild_pnacl_newlib=0 \
401 %else
402         -Ddisable_pnacl_untar=1 \
403         -Ddisable_nacl=1 \
404 %endif
405         %{!?with_sse2:-Ddisable_sse2=1} \
406         %{?with_selinux:-Dselinux=1} \
407         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
408         -Dlinux_link_libpci=1 \
409         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
410         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
411         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
412         -Dlinux_use_gold_binary=0 \
413         -Dlinux_use_gold_flags=0 \
414         -Dlogging_like_official_build=1 \
415         -Dgoogle_api_key=%{google_api_key} \
416         -Dgoogle_default_client_id=%{google_default_client_id} \
417         -Dgoogle_default_client_secret=%{google_default_client_secret} \
418         %{gyp_with cups} \
419         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
420         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
421         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
422         %{gyp_with pulseaudio} \
423         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
424         %{gyp_with system_flac} \
425         %{gyp_with system_harfbuzz} \
426         %{gyp_with system_jsoncpp} \
427         %{gyp_with system_libexif} \
428         %{gyp_with system_libmtp} \
429         %{gyp_with system_libsrtp} \
430         %{gyp_with system_libusb} \
431         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
432         %{gyp_with system_libwebp} \
433         %{gyp_with system_libxnvctrl} \
434         %{gyp_with system_mesa} \
435         %{gyp_with system_minizip} \
436         %{gyp_with system_opus} \
437         %{gyp_with system_protobuf} \
438         %{gyp_with system_re2} \
439         %{gyp_with system_snappy} \
440         %{gyp_with system_speex} \
441         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
442         %{gyp_with system_v8} \
443         %{gyp_with system_yasm} \
444         %{gyp_with system_zlib} \
445         -Duse_system_bzip2=1 \
446         -Duse_system_expat=1 \
447         -Duse_system_icu=1 \
448         -Duse_system_libevent=1 \
449         -Duse_system_libjpeg=1 \
450         -Duse_system_libpng=1 \
451         -Duse_system_libxml=1 \
452         -Duse_system_libxslt=1 \
453         -Duse_system_nspr=1 \
454         -Duse_system_xdg_utils=1 \
455 "
456
457 build/linux/unbundle/replace_gyp_files.py $flags
458
459 %if %{with ninja}
460 chkfile=%{builddir}/build.ninja
461 %else
462 chkfile=Makefile
463 %endif
464 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
465 test -e $chkfile || \
466         CC="%{__cc}" \
467         CXX="%{__cxx}" \
468         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
469         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
470         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
471         CC_host="%{__cc}" \
472         CXX_host="%{__cxx}" \
473         LD_host="%{__cxx}" \
474 %{__python} build/gyp_chromium \
475         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
476         --depth=. \
477         build/all.gyp \
478         $flags
479
480 %if %{with ninja}
481 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
482 %else
483 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
484 %{__make} -r \
485         BUILDTYPE=%{buildtype} \
486         %{?with_verbose:V=1} \
487         CC.host="%{__cc}" \
488         CXX.host="%{__cxx}" \
489         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
490 %endif
491         chrome %{?with_sandboxing:chrome_sandbox} \
492         %{nil}
493
494 cd %{builddir}
495 MANWIDTH=80 man ./chrome.1 > man.out
496 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
497
498 %install
499 rm -rf $RPM_BUILD_ROOT
500 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
501         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
502         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
503
504 cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
505
506 cd %{builddir}
507 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
508 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
509 %{__sed} -i -e '
510         s,@libdir@,%{_libdir}/%{name},
511
512         /@OPTIONS@/ {
513                 r options.txt
514                 d
515         }
516 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
517 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
518 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
519 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
520 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
521 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
522 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
523 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
524 %if %{without system_ffmpeg}
525 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
526 %endif
527 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
528 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
529
530 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
531
532 %if %{with nacl}
533 # Install Native Client files on platforms that support it.
534 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
535 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
536 %ifarch %{x8664}
537 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
538 %endif
539 %ifarch %{ix86}
540 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
541 %endif
542 %endif
543
544 cd -
545
546 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
547         size=${icon##*/product_logo_}
548         size=${size%.png}
549
550         # this will skip non-numeric (22_mono_invert, 22_mono)
551         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
552         test -d "$dir" || continue
553
554         install -d $RPM_BUILD_ROOT$dir
555         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
556 done
557
558 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
559 # http://code.google.com/p/chromium/issues/detail?id=24507
560 gecko-mediaplayer*.so
561 EOF
562
563 # find locales
564 %find_lang %{name}.lang
565 # always package en-US
566 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %pretrans
572 for d in locales resources; do
573         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
574                 install -d %{_datadir}/%{name}
575                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
576         fi
577 done
578 exit 0
579
580 %post
581 %update_icon_cache hicolor
582 %update_desktop_database
583 %update_browser_plugins
584
585 %postun
586 if [ "$1" = 0 ]; then
587         %update_icon_cache hicolor
588         %update_browser_plugins
589 fi
590
591 %files
592 %defattr(644,root,root,755)
593 %doc AUTHORS LICENSE
594 %{_browserpluginsconfdir}/browsers.d/%{name}.*
595 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
596 %dir %{_sysconfdir}/%{name}
597 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
598 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
599 %attr(755,root,root) %{_bindir}/%{name}
600 %{_mandir}/man1/%{name}.1*
601 %{_desktopdir}/*.desktop
602 %{_iconsdir}/hicolor/*/apps/%{name}.png
603 %dir %{_libdir}/%{name}
604 %{_libdir}/%{name}/chrome*.pak
605 %{_libdir}/%{name}/icudtl.dat
606 %{_libdir}/%{name}/content_resources.pak
607 %{_libdir}/%{name}/resources.pak
608 %{_libdir}/%{name}/locales
609 %{_libdir}/%{name}/resources
610
611 %dir %{_datadir}/%{name}
612 %dir %{_datadir}/%{name}/locales
613 %{_datadir}/%{name}/locales/en-US.pak
614 %dir %{_datadir}/%{name}/resources
615 %{_datadir}/%{name}/resources/inspector
616
617 %dir %{_libdir}/%{name}/plugins
618 %attr(755,root,root) %{_libdir}/%{name}/%{name}
619 # These unique permissions are intentional and necessary for the sandboxing
620 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
621
622 # ffmpeg libs
623 %if %{without system_ffmpeg}
624 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
625 %endif
626
627 %if %{with nacl}
628 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
629 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
630 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
631 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
632 %endif
633
634 %files l10n -f %{name}.lang
635 %defattr(644,root,root,755)
This page took 0.081081 seconds and 2 git commands to generate.