]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
23536cd00444e7c0ca45c382c870f6c02762024b
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_jsoncpp  # system jsoncpp
22 %bcond_without  system_libexif  # system libexif
23 %bcond_without  system_libmtp   # system libmtp
24 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
25 %bcond_without  system_libwebp  # system libwebp
26 %bcond_without  system_libxnvctrl       # system libxnvctrl
27 %bcond_with     system_mesa             # system Mesa
28 %bcond_without  system_minizip  # system minizip
29 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
30 %bcond_without  system_protobuf # system protobuf
31 %bcond_without  system_re2              # system re2
32 %bcond_without  system_snappy   # system snappy
33 %bcond_without  system_speex    # system speex
34 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
35 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
36 %bcond_with             system_v8               # system v8
37 %bcond_with     system_libvpx   # system libvpx
38 %bcond_without  system_yasm             # system yasm
39 %bcond_without  system_zlib             # system zlib
40 %bcond_with     tcmalloc                # use tcmalloc
41 %bcond_without  verbose                 # verbose build (V=1)
42
43 %ifarch %{ix86}
44 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
45 %undefine       with_system_mesa
46 %endif
47
48 # TODO
49 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
50 # - use_system_skia
51 # - use_system_ssl (use_openssl: http://crbug.com/62803)
52 # - use_system_stlport (android specific)
53 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
54
55 # NOTES:
56 # - mute BEEP mixer if you do not want to hear horrible system bell when
57 #   pressing home/end in url bar or more ^F search results on page.
58 # - space considerations:
59 #   - unpacked sources: ~490MiB
60 #   - built code: ~1.4GiB (x86_64/i686)
61 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
62 # - to look for new tarball, use update-source.sh script
63
64 %define         branch          36.0.1985
65 %define         basever         143
66 #define         patchver        132
67 %define         gyp_rev 1014
68 Summary:        A WebKit powered web browser
69 Name:           chromium-browser
70 %if "%{?patchver}" != ""
71 Version:        %{branch}.%{patchver}
72 %else
73 Version:        %{branch}.%{basever}
74 %endif
75 Release:        1
76 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
77 Group:          X11/Applications/Networking
78 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
79 # Source0-md5:  8180f26a32fec2f28ae0a2f9a25bdca2
80 %if "%{?patchver}" != ""
81 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
82 # Patch0-md5:   4eafe1e64bd47a11dbfaf61a2dd50b6e
83 %endif
84 Source1:        %{name}.default
85 Source2:        %{name}.sh
86 Source3:        %{name}.desktop
87 Source5:        find-lang.sh
88 Source6:        update-source.sh
89 Source7:        clean-source.sh
90 Source8:        get-source.sh
91 Source9:        master_preferences.json
92 Patch2:         enable-video-decode-accel.patch
93 Patch4:         path-libpdf.patch
94 Patch7:         dlopen_sonamed_gl.patch
95 Patch8:         chromium_useragent.patch.in
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch30:        system-ply.patch
107 Patch31:        system-jinja.patch
108 Patch32:        remove_bundled_libraries-stale.patch
109 Patch35:        etc-dir.patch
110 URL:            http://www.chromium.org/Home
111 %{?with_gconf:BuildRequires:    GConf2-devel}
112 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
113 BuildRequires:  Mesa-libGLES-devel >= 9.1
114 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
115 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
116 BuildRequires:  alsa-lib-devel
117 BuildRequires:  atk-devel
118 BuildRequires:  bison
119 BuildRequires:  bzip2-devel
120 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
123 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
124 %{?with_cups:BuildRequires:     cups-devel}
125 BuildRequires:  elfutils-devel
126 BuildRequires:  expat-devel
127 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
128 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
129 BuildRequires:  fontconfig-devel
130 BuildRequires:  glib2-devel
131 BuildRequires:  gperf
132 %{?with_gps:BuildRequires:      gpsd-devel}
133 BuildRequires:  gtest-devel
134 BuildRequires:  gtk+2-devel
135 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
136 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
137 %{?with_kerberos:BuildRequires: heimdal-devel}
138 BuildRequires:  hicolor-icon-theme
139 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
140 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
141 BuildRequires:  libevent-devel
142 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
143 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
144 BuildRequires:  libicu-devel >= 4.6
145 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
146 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
147 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
148 BuildRequires:  libpng-devel
149 %{?with_selinux:BuildRequires:  libselinux-devel}
150 BuildRequires:  libstdc++-devel
151 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
152 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
153 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
154 BuildRequires:  libxml2-devel
155 BuildRequires:  libxslt-devel
156 BuildRequires:  man-db
157 %{?with_system_minizip:BuildRequires:   minizip-devel}
158 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
159 BuildRequires:  nspr-devel
160 BuildRequires:  nss-devel >= 1:3.12.3
161 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
162 BuildRequires:  pam-devel
163 BuildRequires:  pango-devel
164 BuildRequires:  pciutils-devel
165 BuildRequires:  perl-JSON
166 BuildRequires:  perl-modules
167 BuildRequires:  pkgconfig
168 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
169 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
170 BuildRequires:  python
171 #BuildRequires: python-gyp >= 1-%{gyp_rev}
172 BuildRequires:  python-jinja2 >= 2.7
173 BuildRequires:  python-modules
174 BuildRequires:  python-ply >= 3.4
175 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
176 BuildRequires:  rpm >= 4.4.9-56
177 BuildRequires:  rpmbuild(macros) >= 1.453
178 %{?with_system_snappy:BuildRequires:    snappy-devel}
179 BuildRequires:  speech-dispatcher-devel >= 0.8
180 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
181 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
182 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
183 BuildRequires:  tar >= 1:1.22
184 BuildRequires:  udev-devel
185 BuildRequires:  usbutils
186 BuildRequires:  util-linux
187 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
188 BuildRequires:  which
189 BuildRequires:  xorg-lib-libXScrnSaver-devel
190 BuildRequires:  xorg-lib-libXtst-devel
191 BuildRequires:  xz
192 %{?with_system_yasm:BuildRequires:      yasm}
193 %{?with_system_zlib:BuildRequires:      zlib-devel}
194 Requires:       browser-plugins >= 2.0
195 Requires:       desktop-file-utils
196 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
197 # crashes if no fontconfig font present
198 Requires:       fonts-Type1-urw
199 Requires:       hicolor-icon-theme
200 Requires:       libevent >= 2.0.21
201 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
202 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
203 Requires:       lsb-release
204 %{?with_system_re2:Requires:    re2 >= 20130115-2}
205 Requires:       shared-mime-info
206 %{?with_system_sqlite:Requires: sqlite3(icu)}
207 Requires:       xdg-utils >= 1.0.2-4
208 Requires:       xorg-lib-libX11 >= 1.4.99.1
209 Provides:       wwwbrowser
210 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
211 Obsoletes:      chromium-browser-inspector < 15.0.863.0
212 ExclusiveArch:  %{ix86} %{x8664} arm
213 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
214
215 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
216 # Note: these are for PLD Linux use ONLY.
217 # For your own distribution, please get your own set of keys.
218 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
219 %define         google_default_client_id 724288223830.apps.googleusercontent.com
220 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
221
222 %define         find_lang       sh find-lang.sh %{buildroot}
223
224 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
225 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
226
227 %ifarch %{ix86}
228 %define         target_arch ia32
229 %endif
230 %ifarch %{x8664}
231 %define         target_arch x64
232 %endif
233
234 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
235 %define         builddir        out/%{buildtype}
236
237 %if %{without debuginfo}
238 %define         _enable_debug_packages  0
239 %endif
240
241 %description
242 Chromium is an open-source browser project that aims to build a safer,
243 faster, and more stable way for all Internet users to experience the
244 web.
245
246 Chromium serves as a base for Google Chrome, which is Chromium
247 rebranded (name and logo) with very few additions such as usage
248 tracking and an auto-updater system.
249
250 %package l10n
251 Summary:        chromium-browser language packages
252 Group:          I18n
253 Requires:       %{name} = %{version}-%{release}
254 %if "%{_rpmversion}" >= "5"
255 BuildArch:      noarch
256 %endif
257
258 %description l10n
259 Chromium is an open-source browser project that aims to build a safer,
260 faster, and more stable way for all Internet users to experience the
261 web.
262
263 This package contains language packages for 50 languages:
264
265 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
266 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
267 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
268 zh-TW
269
270 %prep
271 %setup -qc
272 %if "%{?patchver}" != ""
273 cd chromium*-%{branch}.%{basever}
274 %patch0 -p1
275 cd ..
276 %endif
277 mv chromium*-%{branch}.%{basever}/* .
278
279 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
280 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
281 . ./chrome/VERSION
282 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
283 test "$chrome" = %{version}
284
285 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
286 test "$gyp_rev" = %{gyp_rev} || :
287
288 # add chromium and pld to useragent
289 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
290 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
291         -e 's/@BUILD_DIST_NAME@/PLD/g' \
292         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
293         < %{PATCH8} | %{__patch} -p1
294
295 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
296 ln -s %{SOURCE7} .
297
298 #%patch2 -p1 NOT COMPILING
299 %patch4 -p3
300 %patch7 -p1
301 %patch15 -p2
302 %{!?with_libjpegturbo:%patch11 -p0}
303 %patch16 -p1
304 %patch28 -p1
305 %patch25 -p1
306 %{?with_nacl:%patch18 -p1}
307 %patch24 -p1
308 %patch26 -p2
309 #%patch30 -p1
310 #%patch31 -p0
311 %patch32 -p1
312 %patch35 -p1
313
314 %{?with_dev:exit 0}
315
316 sh -x clean-source.sh \
317         %{!?with_nacl:nacl=0} \
318         %{!?with_system_libvpx:libvpx=0} \
319         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
320         %{!?with_system_mesa:mesa=0} \
321         %{!?with_system_protobuf:protobuf=0} \
322         %{!?with_system_re2:re2=0} \
323         %{!?with_system_snappy:snappy=0} \
324         %{!?with_system_sqlite:sqlite=0} \
325         %{!?with_system_v8:v8=0} \
326         %{!?with_system_libwebp:libwebp=0} \
327         %{!?with_system_zlib:zlib=0} \
328         %{!?with_system_ffmpeg:ffmpeg=0} \
329         %{nil}
330
331 %build
332 %if %{with nacl}
333 rm -rf native_client/toolchain/linux_x86_newlib
334 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
335 # Make symlinks for NaCL
336 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
337
338 cd native_client/toolchain/linux_x86_newlib
339 ln -s x86_64-nacl/bin bin
340 cd x86_64-nacl/bin
341 __cc='%{__cc}'
342 if [ "${__cc#ccache}" != "$__cc" ]; then
343         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
344         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
345         %{__sed} -i -e '1i#!/bin/sh' gcc g++
346         chmod +x gcc g++
347 else
348         ln -s %{_bindir}/x86_64-nacl-gcc gcc
349         ln -s %{_bindir}/x86_64-nacl-g++ g++
350 fi
351 ln -s gcc x86_64-nacl-gcc
352 ln -s g++ x86_64-nacl-g++
353 ln -s %{_bindir}/x86_64-nacl-ar .
354 ln -s %{_bindir}/x86_64-nacl-ar ar
355 ln -s %{_bindir}/x86_64-nacl-as as
356 ln -s %{_bindir}/x86_64-nacl-ranlib .
357 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
358 ln -s %{_bindir}/x86_64-nacl-strip .
359 ln -s %{_bindir}/x86_64-nacl-strip strip
360 ln -s %{_bindir}/x86_64-nacl-objcopy .
361 ln -s %{_prefix}/x86_64-nacl/lib ../lib
362 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
363 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
364 cd ../../../../..
365 fi
366 %endif
367
368 %if %{without system_ffmpeg}
369 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
370         # Re-configure bundled ffmpeg
371         cd third_party/ffmpeg
372         chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
373         chromium/scripts/copy_config.sh
374         cd -
375 fi
376 %endif
377
378 flags="
379         -Dtarget_arch=%{target_arch} \
380         -Dpython_arch=%{target_arch} \
381         -Dsystem_libdir=%{_lib} \
382         -Dpython_ver=%{py_ver} \
383 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
384         -Dno_strict_aliasing=1 -Dgcc_version=44 \
385 %endif
386         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
387         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
388         %{?with_shared_libs:-Dlibrary=shared_library} \
389         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
390         -Dinclude_tests__=0 \
391 %if %{with nacl}
392         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
393         -Ddisable_glibc_untar=1 \
394         -Ddisable_newlib_untar=1 \
395         -Ddisable_glibc=1 \
396         -Ddisable_pnacl=1 \
397         -Dbuild_pnacl_newlib=0 \
398 %else
399         -Ddisable_pnacl_untar=1 \
400         -Ddisable_nacl=1 \
401 %endif
402         %{!?with_sse2:-Ddisable_sse2=1} \
403         %{?with_selinux:-Dselinux=1} \
404         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
405         -Dlinux_link_libpci=1 \
406         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
407         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
408         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
409         -Dlinux_use_bundled_binutils=0 \
410         -Dlinux_use_bundled_gold=0 \
411         -Dlinux_use_gold_flags=0 \
412         -Dlogging_like_official_build=1 \
413         -Dgoogle_api_key=%{google_api_key} \
414         -Dgoogle_default_client_id=%{google_default_client_id} \
415         -Dgoogle_default_client_secret=%{google_default_client_secret} \
416         %{gyp_with cups} \
417         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
418         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
419         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
420         %{gyp_with pulseaudio} \
421         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
422         %{gyp_with system_flac} \
423         %{gyp_with system_harfbuzz} \
424         %{gyp_with system_jsoncpp} \
425         %{gyp_with system_libexif} \
426         %{gyp_with system_libmtp} \
427         %{gyp_with system_libsrtp} \
428         %{gyp_with system_libusb} \
429         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
430         %{gyp_with system_libwebp} \
431         %{gyp_with system_libxnvctrl} \
432         %{gyp_with system_mesa} \
433         %{gyp_with system_minizip} \
434         %{gyp_with system_opus} \
435         %{gyp_with system_protobuf} \
436         %{gyp_with system_re2} \
437         %{gyp_with system_snappy} \
438         %{gyp_with system_speex} \
439         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
440         %{gyp_with system_v8} \
441         %{gyp_with system_yasm} \
442         %{gyp_with system_zlib} \
443         -Duse_system_bzip2=1 \
444         -Duse_system_expat=1 \
445         -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
446         -Duse_system_libevent=1 \
447         -Duse_system_libjpeg=1 \
448         -Duse_system_libpng=1 \
449         -Duse_system_libxml=1 \
450         -Duse_system_libxslt=1 \
451         -Duse_system_nspr=1 \
452         -Duse_system_xdg_utils=1 \
453 "
454
455 build/linux/unbundle/replace_gyp_files.py $flags
456
457 %if %{with ninja}
458 chkfile=%{builddir}/build.ninja
459 %else
460 chkfile=Makefile
461 %endif
462 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
463 test -e $chkfile || \
464         CC="%{__cc}" \
465         CXX="%{__cxx}" \
466         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
467         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
468         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
469         CC_host="%{__cc}" \
470         CXX_host="%{__cxx}" \
471         LD_host="%{__cxx}" \
472 %{__python} build/gyp_chromium \
473         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
474         --depth=. \
475         build/all.gyp \
476         $flags
477
478 %if %{with ninja}
479 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
480 %else
481 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
482 %{__make} -r \
483         BUILDTYPE=%{buildtype} \
484         %{?with_verbose:V=1} \
485         CC.host="%{__cc}" \
486         CXX.host="%{__cxx}" \
487         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
488 %endif
489         chrome %{?with_sandboxing:chrome_sandbox} \
490         %{nil}
491
492 cd %{builddir}
493 MANWIDTH=80 man ./chrome.1 > man.out
494 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
495
496 %install
497 rm -rf $RPM_BUILD_ROOT
498 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
499         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
500         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
501         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
502
503 cd %{builddir}
504 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
505 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
506 %{__sed} -i -e '
507         s,@libdir@,%{_libdir}/%{name},
508
509         /@OPTIONS@/ {
510                 r options.txt
511                 d
512         }
513 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
514 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
515 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
516 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
517 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
518 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
519 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
520 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
521 %if %{without system_ffmpeg}
522 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
523 %endif
524 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
525 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
526
527 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
528
529 %if %{with nacl}
530 # Install Native Client files on platforms that support it.
531 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
532 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
533 %ifarch %{x8664}
534 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
535 %endif
536 %ifarch %{ix86}
537 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
538 %endif
539 %endif
540
541 cd -
542
543 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
544         size=${icon##*/product_logo_}
545         size=${size%.png}
546
547         # this will skip non-numeric (22_mono_invert, 22_mono)
548         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
549         test -d "$dir" || continue
550
551         install -d $RPM_BUILD_ROOT$dir
552         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
553 done
554
555 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
556 # http://code.google.com/p/chromium/issues/detail?id=24507
557 gecko-mediaplayer*.so
558 EOF
559
560 # find locales
561 %find_lang %{name}.lang
562 # always package en-US
563 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
564
565 %clean
566 rm -rf $RPM_BUILD_ROOT
567
568 %pretrans
569 for d in locales resources; do
570         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
571                 install -d %{_datadir}/%{name}
572                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
573         fi
574 done
575 exit 0
576
577 %post
578 %update_icon_cache hicolor
579 %update_desktop_database
580 %update_browser_plugins
581
582 %postun
583 if [ "$1" = 0 ]; then
584         %update_icon_cache hicolor
585         %update_browser_plugins
586 fi
587
588 %files
589 %defattr(644,root,root,755)
590 %doc AUTHORS LICENSE
591 %{_browserpluginsconfdir}/browsers.d/%{name}.*
592 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
593 %dir %{_sysconfdir}/%{name}
594 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
595 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
596 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
597 %dir %{_sysconfdir}/%{name}/policies
598 %dir %{_sysconfdir}/%{name}/policies/managed
599 %attr(755,root,root) %{_bindir}/%{name}
600 %{_mandir}/man1/%{name}.1*
601 %{_desktopdir}/*.desktop
602 %{_iconsdir}/hicolor/*/apps/%{name}.png
603 %dir %{_libdir}/%{name}
604 %{_libdir}/%{name}/chrome*.pak
605 %{_libdir}/%{name}/content_resources.pak
606 %{_libdir}/%{name}/keyboard_resources.pak
607 %{_libdir}/%{name}/resources.pak
608 %{_libdir}/%{name}/locales
609 %{_libdir}/%{name}/resources
610
611 %dir %{_datadir}/%{name}
612 %dir %{_datadir}/%{name}/locales
613 %{_datadir}/%{name}/locales/en-US.pak
614 %dir %{_datadir}/%{name}/resources
615 %{_datadir}/%{name}/resources/inspector
616
617 %dir %{_libdir}/%{name}/plugins
618 %attr(755,root,root) %{_libdir}/%{name}/%{name}
619 # These unique permissions are intentional and necessary for the sandboxing
620 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
621
622 # ffmpeg libs
623 %if %{without system_ffmpeg}
624 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
625 %endif
626
627 %if %{with nacl}
628 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
629 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
630 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
631 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
632 %endif
633
634 %files l10n -f %{name}.lang
635 %defattr(644,root,root,755)
This page took 0.062965 seconds and 2 git commands to generate.