]> git.pld-linux.org Git - packages/chromium-browser.git/blame_incremental - chromium-browser.spec
up to 42.0.2311.135
[packages/chromium-browser.git] / chromium-browser.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without cups # with cups
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_with dev # with dev optimizations (skip clean source)
6%bcond_without gconf # with GConf
7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10%bcond_without libjpegturbo # use libjpeg-turbo features
11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
12%bcond_without ninja # use Ninja instead of make to build
13%bcond_without pulseaudio # with pulseaudio
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
18%bcond_without system_flac # system flac
19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
20%bcond_without system_harfbuzz # system harfbuzz
21%bcond_without system_icu # system icu
22%bcond_without system_jsoncpp # system jsoncpp
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
26%bcond_without system_libwebp # system libwebp
27%bcond_without system_libxnvctrl # system libxnvctrl
28%bcond_with system_mesa # system Mesa
29%bcond_without system_minizip # system minizip
30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
33%bcond_without system_re2 # system re2
34%bcond_without system_snappy # system snappy
35%bcond_without system_speex # system speex
36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
38%bcond_with system_v8 # system v8
39%bcond_with system_libvpx # system libvpx
40%bcond_without system_yasm # system yasm
41%bcond_without system_zlib # system zlib
42%bcond_with tcmalloc # use tcmalloc
43%bcond_without verbose # verbose build (V=1)
44
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
48
49# unable build with debuginfo on 32bit build systems
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
57%undefine with_debuginfo
58%endif
59
60# TODO
61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
62# - use_system_skia
63# - use_system_ssl (use_openssl: http://crbug.com/62803)
64# - use_system_stlport (android specific)
65# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
66
67# NOTES:
68# - mute BEEP mixer if you do not want to hear horrible system bell when
69# pressing home/end in url bar or more ^F search results on page.
70# - space considerations:
71# - unpacked sources: ~490MiB
72# - built code: ~1.4GiB (x86_64/i686)
73# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74# - to look for new tarball, use update-source.sh script
75
76%define branch 42.0.2311
77%define basever 135
78#define patchver 118
79%define gyp_rev 1014
80Summary: A WebKit powered web browser
81Name: chromium-browser
82%if "%{?patchver}" != ""
83Version: %{branch}.%{patchver}
84%else
85Version: %{branch}.%{basever}
86%endif
87Release: 1
88License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
89Group: X11/Applications/Networking
90Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91# Source0-md5: 817a2db7a43928ed2d0c60460c13f4b1
92%if "%{?patchver}" != ""
93Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
94# Patch0-md5: fc9cd6fd3392142db2ada6b98b89fa80
95%endif
96Source1: %{name}.default
97Source2: %{name}.sh
98Source3: %{name}.desktop
99Source5: find-lang.sh
100Source6: update-source.sh
101Source7: clean-source.sh
102Source8: get-source.sh
103Source9: master_preferences.json
104# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
105Patch2: enable-video-decode-accel.patch
106Patch7: dlopen_sonamed_gl.patch
107Patch8: chromium_useragent.patch.in
108# https://bugs.gentoo.org/show_bug.cgi?id=393471
109# libjpeg-turbo >= 1.1.90 supports that feature
110Patch11: chromium-revert-jpeg-swizzle-r2.patch
111Patch15: nacl-build-irt.patch
112Patch16: nacl-linkingfix.patch
113Patch18: nacl-no-untar.patch
114Patch24: nacl-verbose.patch
115Patch25: gnome3-volume-control.patch
116Patch26: master-prefs-path.patch
117Patch28: system-mesa.patch
118Patch31: system-jinja.patch
119Patch32: remove_bundled_libraries-stale.patch
120Patch35: etc-dir.patch
121Patch36: angle.patch
122Patch37: %{name}-build.patch
123Patch38: vaapi_include.patch
124Patch39: libsecret.patch
125URL: http://www.chromium.org/Home
126%{?with_gconf:BuildRequires: GConf2-devel}
127%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
128BuildRequires: Mesa-libGLES-devel >= 9.1
129%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
130%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
131BuildRequires: alsa-lib-devel
132BuildRequires: atk-devel
133BuildRequires: bison
134BuildRequires: bzip2-devel
135%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
136%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
137%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
138%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
139%{?with_cups:BuildRequires: cups-devel}
140BuildRequires: elfutils-devel
141BuildRequires: expat-devel
142%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
143%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
144BuildRequires: fontconfig-devel
145BuildRequires: glib2-devel
146BuildRequires: gperf
147%{?with_gps:BuildRequires: gpsd-devel}
148BuildRequires: gtest-devel
149BuildRequires: gtk+2-devel
150%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
151%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
152%{?with_kerberos:BuildRequires: heimdal-devel}
153BuildRequires: hicolor-icon-theme
154%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
155%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
156BuildRequires: libevent-devel
157%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
158%{?with_keyring:BuildRequires: libgnome-keyring-devel}
159%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
160%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
161%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
162%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
163BuildRequires: libpng-devel
164BuildRequires: libsecret-devel
165%{?with_selinux:BuildRequires: libselinux-devel}
166BuildRequires: libstdc++-devel
167%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
168%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
169%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
170BuildRequires: libxml2-devel
171BuildRequires: libxslt-devel
172BuildRequires: man-db
173%{?with_system_minizip:BuildRequires: minizip-devel}
174%{?with_ninja:BuildRequires: ninja >= 1.3.0}
175BuildRequires: nspr-devel
176BuildRequires: nss-devel >= 1:3.12.3
177%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
178BuildRequires: pam-devel
179BuildRequires: pango-devel
180BuildRequires: pciutils-devel
181BuildRequires: perl-JSON
182BuildRequires: perl-modules
183BuildRequires: pkgconfig
184%{?with_system_protobuf:BuildRequires: protobuf-devel}
185%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
186BuildRequires: python
187BuildRequires: python-BeautifulSoup
188#BuildRequires: python-gyp >= 1-%{gyp_rev}
189BuildRequires: python-jinja2 >= 2.7
190BuildRequires: python-modules
191BuildRequires: python-ply >= 3.4
192%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
193BuildRequires: rpm >= 4.4.9-56
194BuildRequires: rpmbuild(macros) >= 1.453
195%{?with_system_snappy:BuildRequires: snappy-devel}
196BuildRequires: speech-dispatcher-devel >= 0.8
197%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
198%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
199%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
200BuildRequires: tar >= 1:1.22
201BuildRequires: udev-devel
202BuildRequires: usbutils
203BuildRequires: util-linux
204%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
205BuildRequires: which
206BuildRequires: xorg-lib-libXScrnSaver-devel
207BuildRequires: xorg-lib-libXtst-devel
208BuildRequires: xz
209%{?with_system_yasm:BuildRequires: yasm}
210%{?with_system_zlib:BuildRequires: zlib-devel}
211Requires: browser-plugins >= 2.0
212Requires: desktop-file-utils
213%{?with_system_flac:Requires: flac >= 1.2.1-7}
214# crashes if no fontconfig font present
215Requires: fonts-Type1-urw
216Requires: hicolor-icon-theme
217Requires: libevent >= 2.0.21
218%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
219%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
220Requires: lsb-release
221%{?with_system_re2:Requires: re2 >= 20130115-2}
222%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
223Requires: shared-mime-info
224%{?with_system_sqlite:Requires: sqlite3(icu)}
225Requires: xdg-utils >= 1.0.2-4
226Requires: xorg-lib-libX11 >= 1.4.99.1
227Provides: wwwbrowser
228Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
229Obsoletes: chromium-browser-inspector < 15.0.863.0
230ExclusiveArch: %{ix86} %{x8664} arm
231BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
232
233# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
234# Note: these are for PLD Linux use ONLY.
235# For your own distribution, please get your own set of keys.
236%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
237%define google_default_client_id 724288223830.apps.googleusercontent.com
238%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
239
240%define find_lang sh find-lang.sh %{buildroot}
241
242# Usage: gyp_with BCOND_NAME [OPTION_NAME]
243%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
244
245%ifarch %{ix86}
246%define target_arch ia32
247%endif
248%ifarch %{x8664}
249%define target_arch x64
250%endif
251
252%define buildtype %{?debug:Debug}%{!?debug:Release}
253%define builddir out/%{buildtype}
254
255%if %{without debuginfo}
256%define _enable_debug_packages 0
257%endif
258
259%description
260Chromium is an open-source browser project that aims to build a safer,
261faster, and more stable way for all Internet users to experience the
262web.
263
264Chromium serves as a base for Google Chrome, which is Chromium
265rebranded (name and logo) with very few additions such as usage
266tracking and an auto-updater system.
267
268%package l10n
269Summary: chromium-browser language packages
270Group: I18n
271Requires: %{name} = %{version}-%{release}
272%if "%{_rpmversion}" >= "5"
273BuildArch: noarch
274%endif
275
276%description l10n
277Chromium is an open-source browser project that aims to build a safer,
278faster, and more stable way for all Internet users to experience the
279web.
280
281This package contains language packages for 50 languages:
282
283ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
284he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
285pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
286zh-TW
287
288%prep
289%setup -qc
290%if "%{?patchver}" != ""
291cd chromium*-%{branch}.%{basever}
292%patch0 -p1
293cd ..
294%endif
295mv chromium*-%{branch}.%{basever}/* .
296
297# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
298# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
299. ./chrome/VERSION
300chrome=$MAJOR.$MINOR.$BUILD.$PATCH
301test "$chrome" = %{version}
302
303gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
304test "$gyp_rev" = %{gyp_rev} || :
305
306# add chromium and pld to useragent
307%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
308sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
309 -e 's/@BUILD_DIST_NAME@/PLD/g' \
310 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
311 < %{PATCH8} | %{__patch} -p1
312
313%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
314ln -s %{SOURCE7} .
315
316#%patch2 -p1 CHECK
317%patch7 -p1
318%patch15 -p2
319%{!?with_libjpegturbo:%patch11 -p0}
320%patch16 -p1
321%patch28 -p1
322%patch25 -p1
323%{?with_nacl:%patch18 -p1}
324%patch24 -p1
325%patch26 -p2
326%patch31 -p0
327%patch32 -p1
328%patch35 -p1
329%patch36 -p1
330%patch37 -p1
331#%patch38 -p1 CHECK
332%patch39 -p1
333
334%{?with_dev:exit 0}
335
336sh -x clean-source.sh \
337 %{!?with_nacl:nacl=0} \
338 %{!?with_system_libvpx:libvpx=0} \
339 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
340 %{!?with_system_mesa:mesa=0} \
341 %{!?with_system_protobuf:protobuf=0} \
342 %{!?with_system_re2:re2=0} \
343 %{!?with_system_snappy:snappy=0} \
344 %{!?with_system_sqlite:sqlite=0} \
345 %{!?with_system_v8:v8=0} \
346 %{!?with_system_libwebp:libwebp=0} \
347 %{!?with_system_zlib:zlib=0} \
348 %{!?with_system_ffmpeg:ffmpeg=0} \
349 %{nil}
350
351%build
352%if %{with nacl}
353rm -rf native_client/toolchain/linux_x86_newlib
354if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
355# Make symlinks for NaCL
356install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
357
358cd native_client/toolchain/linux_x86_newlib
359ln -s x86_64-nacl/bin bin
360cd x86_64-nacl/bin
361__cc='%{__cc}'
362if [ "${__cc#ccache}" != "$__cc" ]; then
363 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
364 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
365 %{__sed} -i -e '1i#!/bin/sh' gcc g++
366 chmod +x gcc g++
367else
368 ln -s %{_bindir}/x86_64-nacl-gcc gcc
369 ln -s %{_bindir}/x86_64-nacl-g++ g++
370fi
371ln -s gcc x86_64-nacl-gcc
372ln -s g++ x86_64-nacl-g++
373ln -s %{_bindir}/x86_64-nacl-ar .
374ln -s %{_bindir}/x86_64-nacl-ar ar
375ln -s %{_bindir}/x86_64-nacl-as as
376ln -s %{_bindir}/x86_64-nacl-ranlib .
377ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
378ln -s %{_bindir}/x86_64-nacl-strip .
379ln -s %{_bindir}/x86_64-nacl-strip strip
380ln -s %{_bindir}/x86_64-nacl-objcopy .
381ln -s %{_prefix}/x86_64-nacl/lib ../lib
382ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
383ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
384cd ../../../../..
385fi
386%endif
387
388%if %{without system_ffmpeg}
389if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
390 # Re-configure bundled ffmpeg
391 cd third_party/ffmpeg
392 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
393 --branding Chromium
394 chromium/scripts/copy_config.sh
395 chromium/scripts/generate_gyp.py
396 cd -
397fi
398%endif
399
400third_party/libaddressinput/chromium/tools/update-strings.py
401
402flags="
403 -Dtarget_arch=%{target_arch} \
404 -Dpython_arch=%{target_arch} \
405 -Dffmpeg_branding=Chromium \
406 -Dsystem_libdir=%{_lib} \
407 -Dpython_ver=%{py_ver} \
408%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
409 -Dno_strict_aliasing=1 -Dgcc_version=44 \
410%endif
411 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
412 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
413 %{?with_shared_libs:-Dlibrary=shared_library} \
414 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
415 -Dinclude_tests__=0 \
416%if %{with nacl}
417 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
418 -Ddisable_glibc_untar=1 \
419 -Ddisable_newlib_untar=1 \
420 -Ddisable_glibc=1 \
421 -Ddisable_pnacl=1 \
422 -Dbuild_pnacl_newlib=0 \
423%else
424 -Ddisable_pnacl_untar=1 \
425 -Ddisable_nacl=1 \
426%endif
427 %{!?with_sse2:-Ddisable_sse2=1} \
428 %{?with_selinux:-Dselinux=1} \
429 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
430 -Dlinux_link_libpci=1 \
431 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
432 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
433 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
434 -Dclang=0 \
435 -Dhost_clang=0 \
436 -Dlinux_use_bundled_binutils=0 \
437 -Dlinux_use_bundled_gold=0 \
438 -Dlinux_use_gold_flags=0 \
439 -Dlogging_like_official_build=1 \
440 -Dgoogle_api_key=%{google_api_key} \
441 -Dgoogle_default_client_id=%{google_default_client_id} \
442 -Dgoogle_default_client_secret=%{google_default_client_secret} \
443 %{gyp_with cups} \
444 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
445 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
446 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
447 %{gyp_with pulseaudio} \
448 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
449 %{gyp_with system_flac} \
450 %{gyp_with system_harfbuzz} \
451 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
452 %{gyp_with system_jsoncpp} \
453 %{gyp_with system_libexif} \
454 %{gyp_with system_libmtp} \
455 %{gyp_with system_libsrtp} \
456 %{gyp_with system_libusb} \
457 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
458 %{gyp_with system_libwebp} \
459 %{gyp_with system_libxnvctrl} \
460 %{gyp_with system_mesa} \
461 %{gyp_with system_minizip} \
462 %{gyp_with system_opus} \
463 %{gyp_with system_protobuf} \
464 %{gyp_with system_re2} \
465 %{gyp_with system_snappy} \
466 %{gyp_with system_speex} \
467 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
468 %{gyp_with system_v8} \
469 %{gyp_with system_yasm} \
470 %{gyp_with system_zlib} \
471 -Duse_system_bzip2=1 \
472 -Duse_system_expat=1 \
473 -Duse_system_libevent=1 \
474 -Duse_system_libjpeg=1 \
475 -Duse_system_libpng=1 \
476 -Duse_system_libxml=1 \
477 -Duse_system_libxslt=1 \
478 -Duse_system_nspr=1 \
479 -Duse_system_xdg_utils=1 \
480"
481
482build/linux/unbundle/replace_gyp_files.py $flags
483
484%if %{with ninja}
485chkfile=%{builddir}/build.ninja
486%else
487chkfile=Makefile
488%endif
489test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
490test -e $chkfile || \
491 CC="%{__cc}" \
492 CXX="%{__cxx}" \
493 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
494 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
495 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
496 CC_host="%{__cc}" \
497 CXX_host="%{__cxx}" \
498 LD_host="%{__cxx}" \
499%{__python} build/gyp_chromium \
500 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
501 --depth=. \
502 build/all.gyp \
503 $flags
504
505%if %{with ninja}
506ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
507%else
508# need {CC/CXX/LDFLAGS}.host overrides for v8 build
509%{__make} -r \
510 BUILDTYPE=%{buildtype} \
511 %{?with_verbose:V=1} \
512 CC.host="%{__cc}" \
513 CXX.host="%{__cxx}" \
514 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
515%endif
516 chrome %{?with_sandboxing:chrome_sandbox} \
517 %{nil}
518
519cd %{builddir}
520MANWIDTH=80 man ./chrome.1 > man.out
521%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
522
523%install
524rm -rf $RPM_BUILD_ROOT
525install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
526 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
527 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
528 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
529
530cd %{builddir}
531cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
532install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
533%{__sed} -i -e '
534 s,@libdir@,%{_libdir}/%{name},
535
536 /@OPTIONS@/ {
537 r options.txt
538 d
539 }
540' $RPM_BUILD_ROOT%{_bindir}/%{name}
541cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
542cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
543ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
544ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
545cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
546install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
547install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
548%if %{without system_ffmpeg}
549install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
550%endif
551cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
552cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
553
554%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
555
556%if %{with nacl}
557# Install Native Client files on platforms that support it.
558install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
559install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
560%ifarch %{x8664}
561install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
562%endif
563%ifarch %{ix86}
564install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
565%endif
566%endif
567
568cd -
569
570for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
571 size=${icon##*/product_logo_}
572 size=${size%.png}
573
574 # this will skip non-numeric (22_mono_invert, 22_mono)
575 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
576 test -d "$dir" || continue
577
578 install -d $RPM_BUILD_ROOT$dir
579 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
580done
581
582%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
583# http://code.google.com/p/chromium/issues/detail?id=24507
584gecko-mediaplayer*.so
585EOF
586
587# find locales
588%find_lang %{name}.lang
589# always package en-US
590%{__sed} -i -e '/en-US.pak/d' %{name}.lang
591
592%clean
593rm -rf $RPM_BUILD_ROOT
594
595%pretrans
596for d in locales resources; do
597 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
598 install -d %{_datadir}/%{name}
599 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
600 fi
601done
602exit 0
603
604%post
605%update_icon_cache hicolor
606%update_desktop_database
607%update_browser_plugins
608
609%postun
610if [ "$1" = 0 ]; then
611 %update_icon_cache hicolor
612 %update_browser_plugins
613fi
614
615%files
616%defattr(644,root,root,755)
617%doc AUTHORS LICENSE
618%{_browserpluginsconfdir}/browsers.d/%{name}.*
619%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
620%dir %{_sysconfdir}/%{name}
621%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
622%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
623%dir %{_sysconfdir}/%{name}/native-messaging-hosts
624%dir %{_sysconfdir}/%{name}/policies
625%dir %{_sysconfdir}/%{name}/policies/managed
626%attr(755,root,root) %{_bindir}/%{name}
627%{_mandir}/man1/%{name}.1*
628%{_desktopdir}/*.desktop
629%{_iconsdir}/hicolor/*/apps/%{name}.png
630%dir %{_libdir}/%{name}
631%{_libdir}/%{name}/chrome*.pak
632%{_libdir}/%{name}/content_resources.pak
633%{_libdir}/%{name}/keyboard_resources.pak
634%{_libdir}/%{name}/resources.pak
635%{_libdir}/%{name}/natives_blob.bin
636%{_libdir}/%{name}/snapshot_blob.bin
637%{_libdir}/%{name}/locales
638%{_libdir}/%{name}/resources
639
640%dir %{_datadir}/%{name}
641%dir %{_datadir}/%{name}/locales
642%{_datadir}/%{name}/locales/en-US.pak
643%dir %{_datadir}/%{name}/resources
644%{_datadir}/%{name}/resources/inspector
645
646%dir %{_libdir}/%{name}/plugins
647%attr(755,root,root) %{_libdir}/%{name}/%{name}
648# These unique permissions are intentional and necessary for the sandboxing
649%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
650
651# ffmpeg libs
652%if %{without system_ffmpeg}
653%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
654%endif
655
656%if %{with nacl}
657%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
658%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
659%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
660%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
661%endif
662
663%files l10n -f %{name}.lang
664%defattr(644,root,root,755)
This page took 0.033922 seconds and 4 git commands to generate.